A probelm about generate a rails project

D:\app>rails mm

create
create app/controllers
create app/helpers
create app/models
create app/views/layouts
create config/environments
create config/initializers
create db
create doc
create lib
create lib/tasks
create log
create public/images
create public/javascripts
create public/stylesheets
create script/performance
create script/process
create test/fixtures
create test/functional
create test/integration
create test/unit
create vendor
create vendor/plugins
create tmp/sessions
create tmp/sockets
create tmp/cache
create tmp/pids
create Rakefile
create README
create app/controllers/application.rb
create app/helpers/application_helper.rb
create test/test_helper.rb
create config/database.yml
create config/routes.rb
create config/initializers/inflections.rb
create config/initializers/mime_types.rb
create config/initializers/new_rails_defaults.rb
create config/boot.rb
create config/environment.rb
create config/environments/production.rb
create config/environments/development.rb
create config/environments/test.rb
create script/about
create script/dbconsole
create script/destroy
create script/generate
create script/performance/benchmarker
create script/performance/profiler
create script/performance/request
create script/process/reaper
create script/process/spawner
create script/process/inspector
create script/runner
create script/server
create script/plugin
create public/dispatch.rb
create public/dispatch.cgi
create public/dispatch.fcgi
create public/404.html
(erb):9:in template': compile error (SyntaxError) (erb):9: syntax error, unexpected '=', expecting $end from c:/ruby/ lib/ruby/gems/1.8/gems/rails-2.1.0/bin/../lib/rails_generator/ commands.rb:287:intemplate’
from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/bin/…/lib/
rails_generator/commands.rb:365:in render_file' from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/bin/../lib/ rails_generator/commands.rb:363:inopen’
from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/bin/…/lib/
rails_generator/commands.rb:363:in render_file' from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/bin/../lib/ rails_generator/commands.rb:246:infile’
from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/bin/…/lib/
rails_generator/commands.rb:245:in open' from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/bin/../lib/ rails_generator/commands.rb:245:infile’
from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/bin/…/lib/
rails_generator/commands.rb:284:in template' ... 6 levels... from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/bin/../lib/ rails_generator/scripts/../scripts.rb:31:inrun’
from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/bin/rails:17
from c:/ruby/bin/rails:16:in `load’
from c:/ruby/bin/rails:16

my rails is 2.1.0 , OS is Windows XP
I have tried any versions of rails.
but it also like that~
I don’t know why, who can help me please~~
thanks very much

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs