A Couple Questions

I have a data file that was recorded to a RAMDisk and transferred to the
hard drive on my Linux machine. When I run it through a throttle, a
and into an FFT, the file repeats. When I was running it off the
it only played for the ~15 seconds of the data. I was having the problem
with repeating before I rebooted and lost the RAMDisk file (I thought
having it stored in RAM, too, was causing a problem). Also, the buttons
the FFT plot don’t work (Autoscale, Stop) Can anyone provide any insight
into why the file on my hard drive is repeating? “Repeat” is set to “No”
the file source block.

Second question - On the FFT (same flow) how can I make it so it STARTS
viewing all the data? The FFT shows up going from 0 to 100, and the
majority of the data is negative. As mentioned, it only runs for about
seconds, and even if the Autoscale button worked, I have such a small
window to view everything. It is my understanding that I can’t get an
Autoscale prior to viewing the plot, but is there a way to scale it with
the parameters on the flow block (maybe set it to go from 0 to -100)?



If the buttons aren’t working then the thing is probably locked up, try
lowering the fft_rate parameter and see if that fixes things.


Thanks, Andrew, I will give that a try. But I am curious as to why it
worked fine when running it off of the RAMDisk, but I have problems
the exact same file off of the hard drive. Am I having an issue with the
read-speed on the hard drive (just as I was having an issue with the
write-speed, which led to me using the RAMDisk)?