502 bad gateway error with php5-fpm on Debian 7

Hello,

First, I’m new to this Mailing List. As say my signature I’m non-English
and I’m trying the best to be understandable. If something isn’t clear
or
noisy, please tell me.

I’m using Nginx 1.2.1 on Debian Wheezy 64 bits, I want to host some
personals website on my dedicated server. I’ve installed php5-fpm,
looked
at the configuration file which is /etc/php5/fpm/pool.d/www.conf and the
“listen” parameters is ‘/var/run/php5-fpm.sock’.
Some peoples on #removed_email_address@domain.invalid tell me I need to put ‘fastcgi_pass
unix:/var/run/php5-fpm.sock;’ into the virtual host configuration file
into /etc/nginx/conf.d/ directory.

I do that and then I’ve checked one of my website which given me a “502
Bad Gateway”, it worked.

But when I’m trying to test if PHP is working with phpinfo, I’ve a 502
and
Wordpress doesn’t works so it’s clear. My configuration is messed up.

This is my configuration:

/etc/nginx/nginx.conf:

user www-data;
worker_processes 1;

error_log /var/log/nginx/error.log debug;
pid /var/run/nginx.pid;

events {
worker_connections 1024;
}

http {
include /etc/nginx/mime.types;
default_type application/octet-stream;

 index index.html index.php;

 log_format  main  '$remote_addr - $remote_user [$time_local]

“$request” ’
'$status $body_bytes_sent “$http_referer” ’
‘"$http_user_agent" “$http_x_forwarded_for”’;

 access_log  /var/log/nginx/access.log  main;

 sendfile        on;
 #tcp_nopush     on;

 keepalive_timeout  65;

 gzip  on;

 include /etc/nginx/conf.d/*.conf;
 include /etc/nginx/fastcgi_params;

}

Example of a vhost configuration file at /etc/nginx/conf.d/:

server {
listen 80;
listen 443 ssl;
# server_name *..*.;
server_name subdomain.koshie.fr www.subdomain.koshie.fr;
root /var/www/koshie.fr/subdomain;

     msie_padding on;

ssl_certificate /etc/nginx/certs/auction-web.crt;

ssl_certificate_key /etc/nginx/certs/auction-web.key;

     ssl_session_timeout  5m;

     ssl_protocols  SSLv2 SSLv3 TLSv1;
     ssl_ciphers  HIGH:!aNULL:!MD5;
     ssl_prefer_server_ciphers   on;

     error_log       /var/log/nginx/error.log;
     access_log      /var/log/nginx/access.log;

     index         index.php;
     fastcgi_index index.php;

     client_max_body_size      8M;
     client_body_buffer_size 256K;

     location ~ \.php$ {
             include fastcgi_params;

             # Assuming php-fastcgi running on localhost port 9000

fastcgi_pass 127.0.0.1:9000;

fastcgi_pass unix:/var/run/php5-fpm.sock;
             fastcgi_param SCRIPT_FILENAME

$document_root$fastcgi_script_name;

             fastcgi_connect_timeout 60;
             fastcgi_send_timeout 180;
             fastcgi_read_timeout 180;
             fastcgi_buffer_size 128k;
             fastcgi_buffers 4 256k;
             fastcgi_busy_buffers_size 256k;
             fastcgi_temp_file_write_size 256k;
             fastcgi_intercept_errors on;
     }

}

/etc/php5/fpm/pool.d/www.conf (unchanged):

; Start a new pool named ‘www’.
; the variable $pool can we used in any directive and will be replaced
by
the
; pool name (‘www’ here)
[www]

; Per pool prefix
; It only applies on the following directives:
; - ‘slowlog’
; - ‘listen’ (unixsocket)
; - ‘chroot’
; - ‘chdir’
; - ‘php_values’
; - ‘php_admin_values’
; When not set, the global prefix (or /usr) applies instead.
; Note: This directive can also be relative to the global prefix.
; Default Value: none
;prefix = /path/to/pools/$pool

; Unix user/group of processes
; Note: The user is mandatory. If the group is not set, the default
user’s
group
; will be used.
user = www-data
group = www-data

; The address on which to accept FastCGI requests.
; Valid syntaxes are:
; ‘ip.add.re.ss:port’ - to listen on a TCP socket to a specific
address on
; a specific port;
; ‘port’ - to listen on a TCP socket to all addresses
on
a
; specific port;
; ‘/path/to/unix/socket’ - to listen on a unix socket.
; Note: This value is mandatory.
listen = /var/run/php5-fpm.sock

; Set listen(2) backlog.
; Default Value: 128 (-1 on FreeBSD and OpenBSD)
;listen.backlog = 128

; Set permissions for unix socket, if one is used. In Linux, read/write
; permissions must be set in order to allow connections from a web
server.
Many
; BSD-derived systems allow connections regardless of permissions.
; Default Values: user and group are set as the running user
; mode is set to 0666
;listen.owner = www-data
;listen.group = www-data
;listen.mode = 0666

; List of ipv4 addresses of FastCGI clients which are allowed to
connect.
; Equivalent to the FCGI_WEB_SERVER_ADDRS environment variable in the
original
; PHP FCGI (5.2.2+). Makes sense only with a tcp listening socket. Each
address
; must be separated by a comma. If this value is left blank, connections
will be
; accepted from any ip address.
; Default Value: any
;listen.allowed_clients = 127.0.0.1

; Choose how the process manager will control the number of child
processes.
; Possible Values:
; static - a fixed number (pm.max_children) of child processes;
; dynamic - the number of child processes are set dynamically based on
the
; following directives. With this process management, there
will be
; always at least 1 children.
; pm.max_children - the maximum number of children that
can
; be alive at the same time.
; pm.start_servers - the number of children created on
startup.
; pm.min_spare_servers - the minimum number of children in
‘idle’
; state (waiting to process). If the
number
; of ‘idle’ processes is less than
this
; number then some children will be
created.
; pm.max_spare_servers - the maximum number of children in
‘idle’
; state (waiting to process). If the
number
; of ‘idle’ processes is greater than
this
; number then some children will be
killed.
; ondemand - no children are created at startup. Children will be
forked
when
; new requests will connect. The following parameter are
used:
; pm.max_children - the maximum number of children
that
; can be alive at the same time.
; pm.process_idle_timeout - The number of seconds after
which
; an idle process will be
killed.
; Note: This value is mandatory.
pm = dynamic

; The number of child processes to be created when pm is set to ‘static’
and the
; maximum number of child processes when pm is set to ‘dynamic’ or
‘ondemand’.
; This value sets the limit on the number of simultaneous requests that
will be
; served. Equivalent to the ApacheMaxClients directive with mpm_prefork.
; Equivalent to the PHP_FCGI_CHILDREN environment variable in the
original
PHP
; CGI. The below defaults are based on a server without much resources.
Don’t
; forget to tweak pm.* to fit your needs.
; Note: Used when pm is set to ‘static’, ‘dynamic’ or ‘ondemand’
; Note: This value is mandatory.
pm.max_children = 5

; The number of child processes created on startup.
; Note: Used only when pm is set to ‘dynamic’
; Default Value: min_spare_servers + (max_spare_servers -
min_spare_servers) / 2
pm.start_servers = 2

; The desired minimum number of idle server processes.
; Note: Used only when pm is set to ‘dynamic’
; Note: Mandatory when pm is set to ‘dynamic’
pm.min_spare_servers = 1

; The desired maximum number of idle server processes.
; Note: Used only when pm is set to ‘dynamic’
; Note: Mandatory when pm is set to ‘dynamic’
pm.max_spare_servers = 3

; The number of seconds after which an idle process will be killed.
; Note: Used only when pm is set to ‘ondemand’
; Default Value: 10s
;pm.process_idle_timeout = 10s;

; The number of requests each child process should execute before
respawning.
; This can be useful to work around memory leaks in 3rd party libraries.
For
; endless request processing specify ‘0’. Equivalent to
PHP_FCGI_MAX_REQUESTS.
; Default Value: 0
;pm.max_requests = 500

; The URI to view the FPM status page. If this value is not set, no URI
will be
; recognized as a status page. It shows the following informations:
; pool - the name of the pool;
; process manager - static, dynamic or ondemand;
; start time - the date and time FPM has started;
; start since - number of seconds since FPM has started;
; accepted conn - the number of request accepted by the pool;
; listen queue - the number of request in the queue of pending
; connections (see backlog in listen(2));
; max listen queue - the maximum number of requests in the queue
; of pending connections since FPM has started;
; listen queue len - the size of the socket queue of pending
connections;
; idle processes - the number of idle processes;
; active processes - the number of active processes;
; total processes - the number of idle + active processes;
; max active processes - the maximum number of active processes since
FPM
; has started;
; max children reached - number of times, the process limit has been
reached,
; when pm tries to start more children (works
only for
; pm ‘dynamic’ and ‘ondemand’);
; Value are updated in real time.
; Example output:
; pool: www
; process manager: static
; start time: 01/Jul/2011:17:53:49 +0200
; start since: 62636
; accepted conn: 190460
; listen queue: 0
; max listen queue: 1
; listen queue len: 42
; idle processes: 4
; active processes: 11
; total processes: 15
; max active processes: 12
; max children reached: 0
;
; By default the status page output is formatted as text/plain. Passing
either
; ‘html’, ‘xml’ or ‘json’ in the query string will return the
corresponding
; output syntax. Example:
; http://www.foo.bar/status
; http://www.foo.bar/status?json
; http://www.foo.bar/status?html
; http://www.foo.bar/status?xml
;
; By default the status page only outputs short status. Passing ‘full’
in
the
; query string will also return status for each pool process.
; Example:
; http://www.foo.bar/status?full
; http://www.foo.bar/status?json&full
; http://www.foo.bar/status?html&full
; http://www.foo.bar/status?xml&full
; The Full status returns for each process:
; pid - the PID of the process;
; state - the state of the process (Idle, Running,
…);
; start time - the date and time the process has started;
; start since - the number of seconds since the process has
started;
; requests - the number of requests the process has
served;
; request duration - the duration in µs of the requests;
; request method - the request method (GET, POST, …);
; request URI - the request URI with the query string;
; content length - the content length of the request (only with
POST);
; user - the user (PHP_AUTH_USER) (or ‘-’ if not set);
; script - the main script called (or ‘-’ if not set);
; last request cpu - the %cpu the last request consumed
; it’s always 0 if the process is not in Idle
state
; because CPU calculation is done when the
request
; processing has terminated;
; last request memory - the max amount of memory the last request
consumed
; it’s always 0 if the process is not in Idle
state
; because memory calculation is done when the
request
; processing has terminated;
; If the process is in Idle state, then informations are related to the
; last request the process has served. Otherwise informations are
related
to
; the current request being served.
; Example output:
; ************************
; pid: 31330
; state: Running
; start time: 01/Jul/2011:17:53:49 +0200
; start since: 63087
; requests: 12808
; request duration: 1250261
; request method: GET
; request URI: /test_mem.php?N=10000
; content length: 0
; user: -
; script: /home/fat/web/docs/php/test_mem.php
; last request cpu: 0.00
; last request memory: 0
;
; Note: There is a real-time FPM status monitoring sample web page
available
; It’s available in: ${prefix}/share/fpm/status.html
;
; Note: The value must start with a leading slash (/). The value can be
; anything, but it may not be a good idea to use the .php
extension
or it
; may conflict with a real PHP file.
; Default Value: not set
;pm.status_path = /status

; The ping URI to call the monitoring page of FPM. If this value is not
set, no
; URI will be recognized as a ping page. This could be used to test from
outside
; that FPM is alive and responding, or to
; - create a graph of FPM availability (rrd or such);
; - remove a server from a group if it is not responding (load
balancing);
; - trigger alerts for the operating team (24/7).
; Note: The value must start with a leading slash (/). The value can be
; anything, but it may not be a good idea to use the .php
extension
or it
; may conflict with a real PHP file.
; Default Value: not set
;ping.path = /ping

; This directive may be used to customize the response of a ping
request.
The
; response is formatted as text/plain with a 200 response code.
; Default Value: pong
;ping.response = pong

; The access log file
; Default: not set
;access.log = log/$pool.access.log

; The access log format.
; The following syntax is allowed
; %%: the ‘%’ character
; %C: %CPU used by the request
; it can accept the following format:
; - %{user}C for user CPU only
; - %{system}C for system CPU only
; - %{total}C for user + system CPU (default)
; %d: time taken to serve the request
; it can accept the following format:
; - %{seconds}d (default)
; - %{miliseconds}d
; - %{mili}d
; - %{microseconds}d
; - %{micro}d
; %e: an environment variable (same as $_ENV or $_SERVER)
; it must be associated with embraces to specify the name of the
env
; variable. Some exemples:
; - server specifics like: %{REQUEST_METHOD}e or
%{SERVER_PROTOCOL}e
; - HTTP headers like: %{HTTP_HOST}e or %{HTTP_USER_AGENT}e
; %f: script filename
; %l: content-length of the request (for POST request only)
; %m: request method
; %M: peak of memory allocated by PHP
; it can accept the following format:
; - %{bytes}M (default)
; - %{kilobytes}M
; - %{kilo}M
; - %{megabytes}M
; - %{mega}M
; %n: pool name
; %o: ouput header
; it must be associated with embraces to specify the name of the
header:
; - %{Content-Type}o
; - %{X-Powered-By}o
; - %{Transfert-Encoding}o
; - …
; %p: PID of the child that serviced the request
; %P: PID of the parent of the child that serviced the request
; %q: the query string
; %Q: the ‘?’ character if query string exists
; %r: the request URI (without the query string, see %q and %Q)
; %R: remote IP address
; %s: status (response code)
; %t: server time the request was received
; it can accept a strftime(3) format:
; %d/%b/%Y:%H:%M:%S %z (default)
; %T: time the log has been written (the request has finished)
; it can accept a strftime(3) format:
; %d/%b/%Y:%H:%M:%S %z (default)
; %u: remote user
;
; Default: “%R - %u %t “%m %r” %s”
;access.format = “%R - %u %t “%m %r%Q%q” %s %f %{mili}d %{kilo}M %C%%”

; The log file for slow requests
; Default Value: not set
; Note: slowlog is mandatory if request_slowlog_timeout is set
;slowlog = log/$pool.log.slow

; The timeout for serving a single request after which a PHP backtrace
will be
; dumped to the ‘slowlog’ file. A value of ‘0s’ means ‘off’.
; Available units: s(econds)(default), m(inutes), h(ours), or d(ays)
; Default Value: 0
;request_slowlog_timeout = 0

; The timeout for serving a single request after which the worker
process
will
; be killed. This option should be used when the ‘max_execution_time’
ini
option
; does not stop script execution for some reason. A value of ‘0’ means
‘off’.
; Available units: s(econds)(default), m(inutes), h(ours), or d(ays)
; Default Value: 0
;request_terminate_timeout = 0

; Set open file descriptor rlimit.
; Default Value: system defined value
;rlimit_files = 1024

; Set max core size rlimit.
; Possible Values: ‘unlimited’ or an integer greater or equal to 0
; Default Value: system defined value
;rlimit_core = 0

; Chroot to this directory at the start. This value must be defined as
an
; absolute path. When this value is not set, chroot is not used.
; Note: you can prefix with ‘$prefix’ to chroot to the pool prefix or
one
; of its subdirectories. If the pool prefix is not set, the global
prefix
; will be used instead.
; Note: chrooting is a great security feature and should be used
whenever
; possible. However, all PHP paths will be relative to the chroot
; (error_log, sessions.save_path, …).
; Default Value: not set
;chroot =

; Chdir to this directory at the start.
; Note: relative path can be used.
; Default Value: current directory or / when chroot
chdir = /

; Redirect worker stdout and stderr into main error log. If not set,
stdout and
; stderr will be redirected to /dev/null according to FastCGI specs.
; Note: on highloaded environement, this can cause some delay in the
page
; process time (several ms).
; Default Value: no
;catch_workers_output = yes

; Limits the extensions of the main script FPM will allow to parse. This
can
; prevent configuration mistakes on the web server side. You should only
limit
; FPM to .php extensions to prevent malicious users to use other
extensions to
; exectute php code.
; Note: set an empty value to allow all extensions.
; Default Value: .php
;security.limit_extensions = .php .php3 .php4 .php5

; Pass environment variables like LD_LIBRARY_PATH. All $VARIABLEs are
taken from
; the current environment.
; Default Value: clean env
;env[HOSTNAME] = $HOSTNAME
;env[PATH] = /usr/local/bin:/usr/bin:/bin
;env[TMP] = /tmp
;env[TMPDIR] = /tmp
;env[TEMP] = /tmp

; Additional php.ini defines, specific to this pool of workers. These
settings
; overwrite the values previously defined in the php.ini. The directives
are the
; same as the PHP SAPI:
; php_value/php_flag - you can set classic ini defines
which
can
; be overwritten from PHP call
‘ini_set’.
; php_admin_value/php_admin_flag - these directives won’t be
overwritten
by
; PHP call ‘ini_set’
; For php_*flag, valid values are on, off, 1, 0, true, false, yes or no.

; Defining ‘extension’ will load the corresponding shared extension from
; extension_dir. Defining ‘disable_functions’ or ‘disable_classes’ will
not
; overwrite previously defined php.ini values, but will append the new
value
; instead.

; Note: path INI options can be relative and will be expanded with the
prefix
; (pool, global or /usr)

; Default Value: nothing is defined by default except the values in
php.ini and
; specified at startup with the -d argument
;php_admin_value[sendmail_path] = /usr/sbin/sendmail -t -i -f
[email protected]
;php_flag[display_errors] = off
;php_admin_value[error_log] = /var/log/fpm-php.www.log
;php_admin_flag[log_errors] = on
;php_admin_value[memory_limit] = 32M

This is the kind of log (/var/log/nginx/error.log, debug enabled) I have
when I’m trying to connect on a page which give 502, exactly the same
vhost configuration as above except for domain and document root:

2013/02/20 23:19:25 [debug] 17211#0: epoll: fd:6 ev:0001
d:00000000007D1AF0
2013/02/20 23:19:25 [debug] 17211#0: timer delta: 14959
2013/02/20 23:19:25 [debug] 17211#0: posted events 0000000000000000
2013/02/20 23:19:25 [debug] 17211#0: worker cycle
2013/02/20 23:19:25 [debug] 17211#0: epoll timer: 60000
2013/02/20 23:19:25 [debug] 17211#0: epoll: fd:3 ev:0001
d:00000000007D1F70
2013/02/20 23:19:25 [debug] 17211#0: timer delta: 0
2013/02/20 23:19:25 [debug] 17211#0: posted events 0000000000000000
2013/02/20 23:19:25 [debug] 17211#0: worker cycle
2013/02/20 23:19:25 [debug] 17211#0: epoll timer: 60000
2013/02/20 23:19:25 [debug] 17211#0: epoll: fd:3 ev:0004
d:00000000007D1F70
2013/02/20 23:19:25 [debug] 17211#0: epoll: fd:10 ev:001D
d:00000000007D1DF1
2013/02/20 23:19:25 [debug] 17211#0: epoll_wait() error on fd:10 ev:001D
2013/02/20 23:19:25 [error] 17211#0: *207 connect() failed (111:
Connection refused) while connecting to upstream, client:
80.239.242.190,
server: subdomain.koshie.fr, request: “GET /wp-admin/info.php HTTP/1.1”,
upstream: “fastcgi://127.0.0.1:9000”, host: “blog.koshie.fr
2013/02/20 23:19:25 [debug] 17211#0: timer delta: 0
2013/02/20 23:19:25 [debug] 17211#0: posted events 0000000000801D70
2013/02/20 23:19:25 [debug] 17211#0: posted event 0000000000801D70
2013/02/20 23:19:25 [debug] 17211#0: posted event 0000000000000000
2013/02/20 23:19:25 [debug] 17211#0: worker cycle
2013/02/20 23:19:25 [debug] 17211#0: epoll timer: 65000
2013/02/20 23:19:25 [debug] 17211#0: epoll: fd:3 ev:0005
d:00000000007D1F70
2013/02/20 23:19:25 [debug] 17211#0: timer delta: 32
2013/02/20 23:19:25 [debug] 17211#0: posted events 0000000000000000
2013/02/20 23:19:25 [debug] 17211#0: worker cycle
2013/02/20 23:19:25 [debug] 17211#0: epoll timer: -1

If you need more logs or paste, please ask.

Cordially, Koshie


Sorry for my English, I’m trying the best in each e-mail writing. Tell
me
if I’m not clear enough.
This mail account is only for list reading, to contact me send an e-mail
at [email protected]

On Wed, Feb 20, 2013 at 11:27:04PM +0100, GASPARD Kvin wrote:

Hi there,

I’m using Nginx 1.2.1 on Debian Wheezy 64 bits, I want to host some
personals website on my dedicated server. I’ve installed php5-fpm, looked
at the configuration file which is /etc/php5/fpm/pool.d/www.conf and the
“listen” parameters is ‘/var/run/php5-fpm.sock’.

So your fastcgi server is expected to be at /var/run/php5-fpm.sock.

ls -l /var/run/php5-fpm.sock

should show you that it really is there.

fastcgi_pass 127.0.0.1:9000;

fastcgi_pass unix:/var/run/php5-fpm.sock;

This looks like it used to try to access 127.0.0.1:9000, but now it
accesses the expected socket.

2013/02/20 23:19:25 [error] 17211#0: *207 connect() failed (111:
Connection refused) while connecting to upstream, client: 80.239.242.190,
server: subdomain.koshie.fr, request: “GET /wp-admin/info.php HTTP/1.1”,
upstream: “fastcgi://127.0.0.1:9000”, host: “blog.koshie.fr

This says it actually tried to access 127.0.0.1:9000, and failed.

The nginx config you showed is not the one that the running nginx is
using when it created this log file.

Does the appropriate “nginx -t” show any problems? Does “nginx -s
reload”
give any indication that it did not reload correctly?

f

Francis D. [email protected]

So your fastcgi server is expected to be at /var/run/php5-fpm.sock.

ls -l /var/run/php5-fpm.sock

srw-rw-rw- 1 root root 0 Feb 20 14:08 /var/run/php5-fpm.sock

should show you that it really is there.

I forget to say, but yes it’s here and I’ve runned the daemon php-fpm.

fastcgi_pass 127.0.0.1:9000;

fastcgi_pass unix:/var/run/php5-fpm.sock;

This looks like it used to try to access 127.0.0.1:9000, but now it
accesses the expected socket.

Yeah, also forget to say that but this configuration was first used on
CentOS 6 and it worked well.

2013/02/20 23:19:25 [error] 17211#0: *207 connect() failed (111:
Connection refused) while connecting to upstream, client:
80.239.242.190,
server: subdomain.koshie.fr, request: “GET /wp-admin/info.php HTTP/1.1”,
upstream: “fastcgi://127.0.0.1:9000”, host: “blog.koshie.fr

This says it actually tried to access 127.0.0.1:9000, and failed.

Seems logical because I ask to use /var/run/php5-fpm.sock instead of the
commented value in /etc/nginx/nginx.conf, right?

The nginx config you showed is not the one that the running nginx is
using when it created this log file.

I’ve pasted a working vhost configuration file and pasted an error on an
other configuration file but they are identical except for document root
and domain. To create this file I’ve used ‘cp’ and modified it.

Does the appropriate “nginx -t” show any problems? Does “nginx -s reload”
give any indication that it did not reload correctly?

f

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

And no output for ‘nginx -s reload’.

Thanks for your answer.

Cordially, Koshie


Sorry for my english, I’m trying the best in each e-mail writing. Tell
me
if I’m not clear enough.
This mail account is only for list reading, to contact me send an e-mail
at removed[email protected]

On Wed, Feb 20, 2013 at 11:54:08PM +0100, GASPARD Kvin wrote:

On Wed, Feb 20, 2013 at 11:27:04PM +0100, GASPARD Kvin wrote:

So your fastcgi server is expected to be at /var/run/php5-fpm.sock.

ls -l /var/run/php5-fpm.sock

srw-rw-rw- 1 root root 0 Feb 20 14:08 /var/run/php5-fpm.sock

should show you that it really is there.

I forget to say, but yes it’s here and I’ve runned the daemon php-fpm.

That’s fine - the fastcgi server is listening on the unix socket.

fastcgi_pass 127.0.0.1:9000;

fastcgi_pass unix:/var/run/php5-fpm.sock;

This looks like it used to try to access 127.0.0.1:9000, but now it
accesses the expected socket.

Yeah, also forget to say that but this configuration was first used on
CentOS 6 and it worked well.

That’s also fine.

The issue is that the nginx that you are testing is not trying to
access the unix socket – it is instead trying to access to network
port.

So either this is not the running config; or this is not the server{}
block used in your test request.

2013/02/20 23:19:25 [error] 17211#0: *207 connect() failed (111:
Connection refused) while connecting to upstream, client:
80.239.242.190,
server: subdomain.koshie.fr, request: “GET /wp-admin/info.php HTTP/1.1”,
upstream: “fastcgi://127.0.0.1:9000”, host: “blog.koshie.fr

This says it actually tried to access 127.0.0.1:9000, and failed.

Seems logical because I ask to use /var/run/php5-fpm.sock instead of the
commented value in /etc/nginx/nginx.conf, right?

You want nginx to access the unix socket. It is trying to access the
network port.

The nginx config you showed is not the one that the running nginx is
using when it created this log file.

I’ve pasted a working vhost configuration file and pasted an error on an
other configuration file but they are identical except for document root
and domain. To create this file I’ve used ‘cp’ and modified it.

When a request comes in to nginx, it chooses exactly one server{} block
to handle it. That server{} block is chosen based firstly on the
incoming
ip:port; and then secondly on the incoming host name used in the
request.

Looking at your config file, plus every file include’d in it, can you
see which one server{} block is used for this request? (You’ll need
to look at all of the “listen” directives first, and then all of the
“server_name” directives in the server{}s with the “listen” that best
matches the incoming ip:port.)

What fastcgi_pass line is used in that one server{} block?

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

And no output for ‘nginx -s reload’.

Because of that, I guess that the problem is in identifying the correct
server{}.

f

Francis D. [email protected]

On Thu, Feb 21, 2013 at 12:36:27AM +0100, GASPARD Kvin wrote:

Hi there,

    listen      80;
    listen      443 ssl;

Ok, since all of the “listen” lines are the same, then the server{}
that is chosen depends on the host name used in the test request.

So: what is the hostname in the url that you try to get, when you see
the 502 error?

And which vhost configuration file has the matching server_name
directive? If there is no exact match, then the first regex match is
used. If there is none, then the default server{} is used. Which exactly
is “the first regex” may not be immediately obvious if there are some
in different files.

I’m sorry but I’m not sure to understand why you are asking me to do and I
given you what I can. If I miss something can you point me on the good way
please?

The problem you report is consistent with the log output you showed.

But the configuration you showed is not consistent with that log output.

So something is unexpected.

Maybe it is simplest if you rename the conf.d directory, then create
a new conf.d directory with just one vhost file. Then reload nginx and
re-do your test of a php request and see what it says.

If it still fails, then you have a simpler test case to work from.

f

Francis D. [email protected]

Looking at your config file, plus every file include’d in it, can you
see which one server{} block is used for this request? (You’ll need
to look at all of the “listen” directives first, and then all of the
“server_name” directives in the server{}s with the “listen” that best
matches the incoming ip:port.)

What fastcgi_pass line is used in that one server{} block?

I’ve do a grep -R ‘listen’ /etc/nginx/conf.d/ and every vhost
configuration file have two lines, exactly the same:

     listen      80;
     listen      443 ssl;

In the past, to be sure to don’t make mistake I copied an old vhost
configuration file and I modified it every times for a new website. So
you’ll see this kind of line:

     server_name     subdomain.koshie.fr www.subdomain.koshie.fr;

Some of these vhost are different but that’s because they need regex for
some stuff.

Finally, for fastcgi_pass, I’ve only tested my configuration and pasted
here data with the vhosts containing the value pasted in the first mail:
fastcgi_pass unix:/var/run/php5-fpm.sock;

I’ve for now a lot of domain with my old configuration value, listening
on
the network if I don’t say rubish (and as you say before).

I’m sorry but I’m not sure to understand why you are asking me to do and
I
given you what I can. If I miss something can you point me on the good
way
please?

Good night, Koshie


Sorry for my english, I’m trying the best in each e-mail writing. Tell
me
if I’m not clear enough.
This mail account is only for list reading, to contact me send an e-mail
at [email protected]

I’ve do a grep -R ‘listen’ /etc/nginx/conf.d/ and every vhost
configuration file have two lines, exactly the same:

    listen      80;
    listen      443 ssl;

Ok, since all of the “listen” lines are the same, then the server{}
that is chosen depends on the host name used in the test request.

So: what is the hostname in the url that you try to get, when you see
the 502 error?

Trying to install a Wordpress, used a info.php page here:
http://blog.koshie.fr/wp-admin/info.php

As you can see, there is a 502 Bad Gateway error.

And which vhost configuration file has the matching server_name
directive? If there is no exact match, then the first regex match is
used. If there is none, then the default server{} is used. Which exactly
is “the first regex” may not be immediately obvious if there are some
in different files.

Logically, this is the vhost configuration file for
http://blog.koshie.fr/wp-admin/info.php:

server {
listen 80;
listen 443 ssl;

server_name 176.31.122.26;

server_name blog.koshie.fr www.blog.koshie.fr;
root /var/www/koshie.fr/blog/wordpress;

msie_padding on;
ssl_session_timeout 5m;

ssl_protocols SSLv2 SSLv3 TLSv1;
ssl_ciphers HIGH:!aNULL:!MD5;
ssl_prefer_server_ciphers on;

error_log /var/log/nginx/error.log;
access_log /var/log/nginx/access.log;

index index.php;

fastcgi_index index.php;

client_max_body_size 8M;
client_body_buffer_size 256K;

     location ~ \.php$ {
             include fastcgi_params;

             # Assuming php-fastcgi running on localhost port 9000

fastcgi_pass 127.0.0.1:9000;

fastcgi_pass unix:/var/run/php5-fpm.sock;
             fastcgi_param SCRIPT_FILENAME

$document_root$fastcgi_script_name;

             fastcgi_connect_timeout 60;
             fastcgi_send_timeout 180;
             fastcgi_read_timeout 180;
             fastcgi_buffer_size 128k;
             fastcgi_buffers 4 256k;
             fastcgi_busy_buffers_size 256k;
             fastcgi_temp_file_write_size 256k;
             fastcgi_intercept_errors on;
     }

}

}

So something is unexpected.

Maybe it is simplest if you rename the conf.d directory, then create
a new conf.d directory with just one vhost file. Then reload nginx and
re-do your test of a php request and see what it says.

So, above you’ve the configuration file related to this log error:

2013/02/21 09:37:35 [error] 3631#0: *1476 connect() failed (111:
Connection refused) while connecting to upstream, client:
46.218.152.242,
server: island.koshie.fr, request: “GET /wp-admin/info.php HTTP/1.1”,
upstream: “fastcgi://127.0.0.1:9000”, host: “blog.koshie.fr
2013/02/21 09:37:35 [debug] 3631#0: timer delta: 1
2013/02/21 09:37:35 [debug] 3631#0: posted events 0000000000801CA0
2013/02/21 09:37:35 [debug] 3631#0: posted event 0000000000801CA0
2013/02/21 09:37:35 [debug] 3631#0: posted event 0000000000000000
2013/02/21 09:37:35 [debug] 3631#0: worker cycle
2013/02/21 09:37:35 [debug] 3631#0: epoll timer: 65000

I’ve copied /etc/nginx/conf.d/ to /etc/nginx/conf.d.backup/, removed
files
into /etc/nginx/conf.d/ and moved /etc/nginx/conf.d/koshie.fr.conf and
/etc/nginx/conf.d/blog.koshie.fr.conf to /etc/nginx/conf.d/ (because
unless the both conf I has an error… With squid ! I don’t get it, I’ve
no squid on my desktop or my server, anyway… I think it’s maybe
related
to the fact koshie.fr is the main domain?), restarted nginx and
koshie.fr
works, but blog.koshie.fr/wordpress/info.php gimme again a 502. This is
the log for this request:

2013/02/21 10:21:22 [error] 1097#0: *5 connect() failed (111: Connection
refused) while connecting to upstream, client: 46.218.152.242, server:
koshie.fr, request: “GET /wordpress/info.php HTTP/1.1”, upstream:
“fastcgi://127.0.0.1:9000”, host: “blog.koshie.fr
2013/02/21 10:21:22 [debug] 1097#0: timer delta: 0
2013/02/21 10:21:22 [debug] 1097#0: posted events 00000000007299F0
2013/02/21 10:21:22 [debug] 1097#0: posted event 00000000007299F0
2013/02/21 10:21:22 [debug] 1097#0: posted event 0000000000000000
2013/02/21 10:21:22 [debug] 1097#0: worker cycle
2013/02/21 10:21:22 [debug] 1097#0: epoll timer: 65000

If it still fails, then you have a simpler test case to work from.

What is this test case please?

Cordially, Koshie

Dump question, but why did you put the vhost-files into “conf.d”?
Normally
they are stored in “sites-available” and symlinked in “sites-enabled”.
nginx
(as apache) uses this directory to read all information about the
vhosts.
Are there any templates in “sites-enabled”? How do they look like?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236396,236413#msg-236413

Can you please do a grep 'fastcgi_pass ' /etc/nginx/*/* and post the
output? Maybe there are other configuration files with a fefault
‘fastcgi_pass’ which overwrites your vhost.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236396,236415#msg-236415

Le Thu, 21 Feb 2013 11:26:57 +0100, Wolfsrudel [email protected] a
écrit:

Can you please do a grep 'fastcgi_pass ' /etc/nginx/*/* and post the
output? Maybe there are other configuration files with a fefault
‘fastcgi_pass’ which overwrites your vhost.

With a sudo grep -R 'fastcgi_pass ’ /etc/nginx// I have exactly what
you
tell and I know that, but I don’t know if it can create a conflict.

I’m using the new fastcgi_pass value for 3 of my vhost now: fastcgi_pass
unix:/var/run/php5-fpm.sock;

But older (worked on CentOS) has for now fastcgi_pass 127.0.0.1:9000;

I’ve see that too:

/etc/nginx/sites-available/default: # fastcgi_pass 127.0.0.1:9000;
/etc/nginx/sites-available/default: # fastcgi_pass
unix:/var/run/php5-fpm.sock;
/etc/nginx/sites-enabled/default: # fastcgi_pass 127.0.0.1:9000;
/etc/nginx/sites-enabled/default: # fastcgi_pass
unix:/var/run/php5-fpm.sock;

I never touched them in my whole Nginx life.

Cordially, Koshie


Sorry for my english, I’m trying the best in each e-mail writing. Tell
me
if I’m not clear enough.
This mail account is only for list reading, to contact me send an e-mail
at [email protected]

Le Thu, 21 Feb 2013 11:17:21 +0100, Wolfsrudel [email protected] a
écrit:

Dump question, but why did you put the vhost-files into “conf.d”?
Normally
they are stored in “sites-available” and symlinked in “sites-enabled”.
nginx
(as apache) uses this directory to read all information about the vhosts.
Are there any templates in “sites-enabled”? How do they look like?

To be honest I don’ know. When I’ve setup this configuration (more than
1
year ago I think) I’ve probably take 2 or 3 days on #nginx IRC channel
and
when it was working I’ve never modified the configuration.

This is the only file into /etc/nginx/sites-enabled/ inf file default:

You may add here your

server {

}

statements for each of your virtual hosts to this file

You should look at the following URL’s in order to grasp a solid

understanding

of Nginx configuration files in order to fully unleash the power of

Nginx.

http://wiki.nginx.org/Pitfalls

http://wiki.nginx.org/QuickStart

http://wiki.nginx.org/Configuration

Generally, you will want to move this file somewhere, and start with a

clean

file but keep this around for reference. Or just disable in

sites-enabled.

Please see /usr/share/doc/nginx-doc/examples/ for more detailed

examples.

server {
#listen 80; ## listen for ipv4; this line is default and implied
#listen [::]:80 default_server ipv6only=on; ## listen for ipv6

root /usr/share/nginx/www;
index index.html index.htm;

Make site accessible from http://localhost/

server_name localhost;

location / {
# First attempt to serve request as file, then
# as directory, then fall back to displaying a 404.
try_files $uri $uri/ /index.html;
# Uncomment to enable naxsi on this location
# include /etc/nginx/naxsi.rules
}

location /doc/ {
alias /usr/share/doc/;
autoindex on;
allow 127.0.0.1;
allow ::1;
deny all;
}

Only for nginx-naxsi used with nginx-naxsi-ui : process denied

requests
#location /RequestDenied {

proxy_pass http://127.0.0.1:8080;

#}

#error_page 404 /404.html;

redirect server error pages to the static page /50x.html

#error_page 500 502 503 504 /50x.html;
#location = /50x.html {

root /usr/share/nginx/www;

#}

pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000

#location ~ .php$ {

fastcgi_split_path_info ^(.+.php)(/.+)$;

# NOTE: You should have “cgi.fix_pathinfo = 0;” in php.ini

# With php5-cgi alone:

fastcgi_pass 127.0.0.1:9000;

# With php5-fpm:

fastcgi_pass unix:/var/run/php5-fpm.sock;

fastcgi_index index.php;

include fastcgi_params;

#}

deny access to .htaccess files, if Apache’s document root

concurs with nginx’s one

#location ~ /.ht {

deny all;

#}
}

another virtual host using mix of IP-, name-, and port-based

configuration

#server {

listen 8000;

listen somename:8080;

server_name somename alias another.alias;

root html;

index index.html index.htm;

location / {

try_files $uri $uri/ =404;

}

#}

HTTPS server

#server {

listen 443;

server_name localhost;

root html;

index index.html index.htm;

ssl on;

ssl_certificate cert.pem;

ssl_certificate_key cert.key;

ssl_session_timeout 5m;

ssl_protocols SSLv3 TLSv1;

ssl_ciphers

ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv3:+EXP;

ssl_prefer_server_ciphers on;

location / {

try_files $uri $uri/ =404;

}

#}


Sorry for my english, I’m trying the best in each e-mail writing. Tell
me
if I’m not clear enough.
This mail account is only for list reading, to contact me send an e-mail
at [email protected]

On Thu, Feb 21, 2013 at 10:26:22AM +0100, GASPARD Kvin wrote:

Hi there,

So: what is the hostname in the url that you try to get, when you see
the 502 error?

Trying to install a Wordpress, used a info.php page here:
http://blog.koshie.fr/wp-admin/info.php

Ok - so the one server{} block that is used is either the one that has
server_name blog.koshie.fr, or is the default one.

As you can see, there is a 502 Bad Gateway error.

Yes, and that error log shows that:

2013/02/21 10:21:22 [error] 1097#0: *5 connect() failed (111: Connection
refused) while connecting to upstream, client: 46.218.152.242, server:
koshie.fr, request: “GET /wordpress/info.php HTTP/1.1”, upstream:
“fastcgi://127.0.0.1:9000”, host: “blog.koshie.fr

it is using the server “koshie.fr”, not the server
blog.koshie.fr”. Presumably the server “koshie.fr” is the default,
and the server “blog.koshie.fr” does not exist.

So the configuration that is running, is not the configuration that
you are showing here.

Logically, this is the vhost configuration file for
http://blog.koshie.fr/wp-admin/info.php:

But based on your later mail, this configuration file does not exist.

If you want to get this configured correctly, your best bet is probably
to simplify the configuration significantly.

Leave /etc/nginx/nginx.conf as it is.

Let /etc/nginx/conf.d have exactly one file in it, this one.

Then run your test and see if it works or fails.

Maybe it is simplest if you rename the conf.d directory, then create
a new conf.d directory with just one vhost file. Then reload nginx and
re-do your test of a php request and see what it says.

So, above you’ve the configuration file related to this log error:

No.

That configuration file does not result in this error.

If it still fails, then you have a simpler test case to work from.

What is this test case please?

Your test case is:

Then do whatever it takes to get the expected output.

I think that one part of the problem is that you have only half-changed
from an old system to a new system.

You new system has nothing listening on 127.0.0.1:9000, so any
configuration that mentions that ip:port is broken. It should be
removed,
or replaced with the unix socket.

And your new system does not actually include all of the files that you
want it to.

When your nginx starts, it reads exactly one configuration file:
/etc/nginx/nginx.conf.

That file then uses “include” to read some other files. Those other
files do not seem to be the ones you want, for some reason.

I suggest: stop nginx. Make sure it is stopped, and not running, and
has nothing listening on port 80 or port 443. Then look at the files
in /etc/nginx/conf.d, and make sure that they are exactly the ones that
you want. Then start nginx, access the info.php url, and see if it
works.

Good luck,

f

Francis D. [email protected]

On Thu, 21 Feb 2013 12:07:41 +0100, GASPARD Kévin
[email protected] wrote:

To be honest I don’ know. When I’ve setup this configuration (more
than 1 year ago I think)

It seems that you are trying to force a non Debian directory
structure into a Debian one.

Show us the result of:

nginx -V 2>&1|sed ‘s,–,\n–,g’

find /etc/nginx/ -name .conf|xargs -r grep -v '^\s(#|$)’

find /etc/nginx/sites-/|xargs -r grep -v ‘^\s*(#|$)’

M.

On Thu, 21 Feb 2013 14:07:45 +0100, GASPARD Kévin
[email protected] wrote:

nginx -V 2>&1|sed ‘s,–,\n–,g’
nginx version: nginx/1.2.1

Ok, this seems pretty standard for Debian.

find /etc/nginx/ -name .conf|xargs -r grep -v '^\s(#|$)’
/etc/nginx/conf.d/koshie-island.koshie.fr.conf:server {
/etc/nginx/conf.d/koshie-island.koshie.fr.conf:
listen

To get out of a hole, first you must stop digging.

So, in order to regain control of your Nginx under Debian:

  1. Clean /etc/nginx/conf.d/
    sudo mkdir /etc/nginx/conf.d-backup
    sudo mv /etc/nginx/conf.d/* /etc/nginx/conf.d-backup/

  2. Simplify your /etc/nginx/sites-available/default
    server {
    listen 80 default_server;
    server_name_in_redirect off;
    return 444;
    }
    server {
    listen 443 default_server ssl;
    server_name_in_redirect off;
    ssl_certificate /etc/ssl/certs/dummy-web.crt;
    ssl_certificate_key /etc/ssl/private/dummy-web.key;
    return 444;
    }

  3. Create simpler domain config files,
    and put them inside /etc/nginx/sites-available/:

/etc/nginx/sites-available/koshiefr # for http only

server {
listen 80;
server_name www.koshie.fr; # may also add IP here
return 301 $scheme://koshie.fr$request_uri; # 301/perm 302/temp
}
server {
listen 80;
server_name koshie.fr;
root /var/www/koshiefr; # avoid non alfanum here & rm last /
#client_max_body_size 8M;
#client_body_buffer_size 256K;
index index.php /index.php;
location ~ .php$ {
include fastcgi_params;
fastcgi_pass 127.0.0.1:9000;
}
}

/etc/nginx/sites-available/koshiefrs # for https only

server {
listen 443; # ssl not needed here
server_name www.koshie.fr; # may also add IP here
return 301 $scheme://koshie.fr$request_uri; # 301=perm, 302=temp
}
server {
listen 443 ssl;
server_name koshie.fr;
root /var/www/koshiefr; # avoid non alfanum here
#client_max_body_size 8M;
#client_body_buffer_size 256K;
ssl_certificate /etc/ssl/certs/dummy-web.crt;
ssl_certificate_key /etc/ssl/private/dummy-web.key;
location ~ .php$ {
include fastcgi_params;
fastcgi_pass 127.0.0.1:9000;
}
}

  1. link files into place:

sudo ln -svf /etc/nginx/sites-available/default
/etc/nginx/sites-enabled/

sudo ln -svf /etc/nginx/sites-available/koshiefr
\ /etc/nginx/sites-enabled/

sudo ln -svf /etc/nginx/sites-available/koshiefrs
\ /etc/nginx/sites-enabled/

  1. restart nginx:
    a) again keep it simple (I don’t trust Debian’s nginx restart)
    sudo /etc/init.d/nginx stop
    sudo /etc/init.d/nginx start
    sudo /etc/init.d/nginx status

b) OR, if the server is ‘in production’, use alternative ‘restart’
trying to not disturb the established connections:

pgrep nginx && sudo kill -s USR2 $(cat /var/run/nginx.pid)
pgrep nginx >/dev/null && sudo kill -s QUIT
$(cat /var/run/nginx.pid.oldbin)
sleep .5
pgrep nginx || sudo /etc/init.d/nginx start

check status

sudo /usr/sbin/nginx -t && /etc/init.d/nginx status

  1. regarding PHP-FPM:
    a) DO install at least:
    sudo apt-get install php5-fpm php5-suhosin php-apc
    and, if needed:

sudo apt-get install php5-mysql php5-mcrypt php5-gd

A common simple PHP config could include:

grep -v ‘^\s*(;|$)’ /etc/php5/fpm/*.conf

[global]
pid = /var/run/php5-fpm.pid
error_log = /var/log/php5-fpm.log
include=/etc/php5/fpm/pool.d/*.conf

grep -v ‘^\s*(;|$)’ /etc/php5/fpm/pool.d/*.conf[www]

user = www-data
group = www-data
listen = 127.0.0.1:9000
pm = dynamic
pm.max_children = 10
pm.start_servers = 4
pm.min_spare_servers = 2
pm.max_spare_servers = 6
pm.max_requests = 384
request_terminate_timeout = 30s
chdir = /var/www

restart it

pgrep php5-fpm && sudo /etc/init.d/php5-fpm restart
sleep .5
pgrep php5-fpm || sudo /etc/init.d/php5-fpm start

Because of the above ‘chdir = /var/www’ and ‘group = www-data’ files
inside /var/www/ like, for instance, those inside /var/www/koshiefr/
should be owned (and readable, or read/writeable) by group www-data

REMEMBER:

  • keep it simple,
  • do trust nginx defaults as they usually work rather well,
  • test each config file well and restart/reload its parent app (nginx
    or php) before doing another config change.

And, if you can live with a lighter Nginx, you can try my own
extra-light nginx builds from: https://launchpad.net/~malan/+archive/dev
sudo dpkg -i nginx-common*.deb
sudo dpkg -i nginx-light*.deb

Regards,

M.

I’ve removed all “127.0.0.1:9000” lines by “fastcgi_pass
unix:/var/run/php5-fpm.sock;” and everything works now :-).

Thanks for your help !

Le Thu, 21 Feb 2013 14:50:41 +0100, Francis D. [email protected] a
écrit:

Ok - so the one server{} block that is used is either the one that has

But based on your later mail, this configuration file does not exist.

Maybe it is simplest if you rename the conf.d directory, then create

I think that one part of the problem is that you have only half-changed
/etc/nginx/nginx.conf.

f


Utilisant le logiciel de courrier d’Opera : http://www.opera.com/mail/

Well, in fact I’ve a new problem.

info.php file works, so php works.

But when I’m trying to access to my install.php file for wordpress
installation I’ve “File not found.” and in /var/log/nginx/error.log I
have: “*1 FastCGI sent in stderr: “Primary script unknown” while reading
response header from upstream, client: 89.2.128.79, server:
blog.koshie.fr, request: “GET /wp-admin/install.php HTTP/1.1”, upstream:
“fastcgi://unix:/var/run/php5-fpm.sock:”, host: “blog.koshie.fr””

An idea? I’ve googled a little and some peoples talk about
/etc/nginx/fastcgi_params’s SCRIPT_FILE_NAME parameters. But I don’t
understand what value to put into.

PS : Sorry for the noise of my last e-mail.

Cordially, Koshie

Le Sat, 02 Mar 2013 20:00:47 +0100, GASPARD kévin
[email protected]
a écrit:

Hi there,

As you can see, there is a 502 Bad Gateway error.
blog.koshie.fr”. Presumably the server “koshie.fr” is the default,
If you want to get this configured correctly, your best bet is probably

re-do your test of a php request and see what it says.

f


Utilisant le logiciel de courrier d’Opera : http://www.opera.com/mail/

Hi,

I’ve solved my issue, I’ve moved all wordpress file into the document
root
of blog.koshie.fr, modified it into
/etc/nginx/conf.d/blog.koshie.fr.conf
according to my new structure and now it works.

Again thanks :).

Le Sat, 02 Mar 2013 20:14:55 +0100, GASPARD kévin
[email protected]
a écrit:

Hi there,

As you can see, there is a 502 Bad Gateway error.
blog.koshie.fr”. Presumably the server “koshie.fr” is the default,
If you want to get this configured correctly, your best bet is probably
and
What is this test case please?
from an old system to a new system.
/etc/nginx/nginx.conf.
Good luck,

f


Utilisant le logiciel de courrier d’Opera : http://www.opera.com/mail/

Dump question, but why did you put the vhost-files into “conf.d”?
Normally
they are stored in “sites-available” and symlinked in “sites-enabled”.

nginx
(as apache) uses this directory to read all information about the
vhosts.

Are there any templates in “sites-enabled”? How do they look like?

To be honest I don’ know. When I’ve setup this configuration (more than
1
year ago I think) I’ve probably take 2 or 3 days on #nginx IRC channel
and
when it was working I’ve never modified the configuration.

If your install is anything like, mine there was no sites-available and
sites-enabled directories. I used the directions on the download page
to
install the stable version. (
http://nginx.org/packages/centos/6/noarch/RPMS/nginx-release-centos-6-0.el6.ngx.noarch.rpm
followed by “yum install nginx”) /etc/nginx.conf had an include for
conf.d and in that directory, they had a sample

From the context, I take it the sites-available directory had the
various
site definition files, and for those that you want to use, you create
the
link in sites-enabled, much like rc3.d links to init.d?

Confidentiality Notice:
This electronic message and any attachments may contain confidential or
privileged information, and is intended only for the individual or
entity
identified above as the addressee. If you are not the addressee (or the
employee or agent responsible to deliver it to the addressee), or if
this
message has been addressed to you in error, you are hereby notified that
you may not copy, forward, disclose or use any part of this message or
any
attachments. Please notify the sender immediately by return e-mail or
telephone and delete this message from your system.

Le Thu, 21 Feb 2013 13:46:35 +0100, Mark A. [email protected] a
écrit:

nginx -V 2>&1|sed ‘s,–,\n–,g’

nginx version: nginx/1.2.1
TLS SNI support enabled
configure arguments:
–prefix=/etc/nginx
–conf-path=/etc/nginx/nginx.conf
–error-log-path=/var/log/nginx/error.log
–http-client-body-temp-path=/var/lib/nginx/body
–http-fastcgi-temp-path=/var/lib/nginx/fastcgi
–http-log-path=/var/log/nginx/access.log
–http-proxy-temp-path=/var/lib/nginx/proxy
–http-scgi-temp-path=/var/lib/nginx/scgi
–http-uwsgi-temp-path=/var/lib/nginx/uwsgi
–lock-path=/var/lock/nginx.lock
–pid-path=/var/run/nginx.pid
–with-pcre-jit
–with-debug
–with-http_addition_module
–with-http_dav_module
–with-http_geoip_module
–with-http_gzip_static_module
–with-http_image_filter_module
–with-http_realip_module
–with-http_stub_status_module
–with-http_ssl_module
–with-http_sub_module
–with-http_xslt_module
–with-ipv6
–with-sha1=/usr/include/openssl
–with-md5=/usr/include/openssl
–with-mail
–with-mail_ssl_module
–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-auth-pam
–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-echo
–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-upstream-fair
–add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-dav-ext-module

find /etc/nginx/ -name .conf|xargs -r grep -v '^\s(#|$)’

/etc/nginx/conf.d/koshie-island.koshie.fr.conf:server {
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: server_name
island.koshie.fr
www.island.koshie.fr;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: root
/var/www/koshie.fr/island;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: ssl_session_timeout
5m;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: ssl_protocols SSLv2
SSLv3
TLSv1;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf:
ssl_prefer_server_ciphers
on;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: client_max_body_size
8M;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: client_body_buffer_size
256K;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: include
fastcgi_params;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: fastcgi_param
SCRIPT_FILENAME $document_root$fastcgi_script_name;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf:
fastcgi_connect_timeout
60;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: fastcgi_send_timeout
180;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: fastcgi_read_timeout
180;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: fastcgi_buffer_size
128k;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: fastcgi_buffers 4
256k;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf:
fastcgi_busy_buffers_size
256k;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf:
fastcgi_temp_file_write_size
256k;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf:
fastcgi_intercept_errors
on;
/etc/nginx/conf.d/koshie-island.koshie.fr.conf: }
/etc/nginx/conf.d/koshie-island.koshie.fr.conf:}
/etc/nginx/conf.d/documents.koshie.fr.conf:server {
/etc/nginx/conf.d/documents.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/documents.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/documents.koshie.fr.conf: server_name
documents.koshie.fr www.documents.koshie.fr;
/etc/nginx/conf.d/documents.koshie.fr.conf: root
/var/www/koshie.fr/documents;
/etc/nginx/conf.d/documents.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/documents.koshie.fr.conf: ssl_session_timeout
5m;
/etc/nginx/conf.d/documents.koshie.fr.conf: ssl_protocols SSLv2
SSLv3 TLSv1;
/etc/nginx/conf.d/documents.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/documents.koshie.fr.conf:
ssl_prefer_server_ciphers on;
/etc/nginx/conf.d/documents.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/documents.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/documents.koshie.fr.conf:
client_max_body_size 8M;
/etc/nginx/conf.d/documents.koshie.fr.conf:
client_body_buffer_size
256K;
/etc/nginx/conf.d/documents.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/documents.koshie.fr.conf: include
fastcgi_params;
/etc/nginx/conf.d/documents.koshie.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/documents.koshie.fr.conf: fastcgi_param
SCRIPT_FILENAME $document_root$fastcgi_script_name;
/etc/nginx/conf.d/documents.koshie.fr.conf:
fastcgi_connect_timeout 60;
/etc/nginx/conf.d/documents.koshie.fr.conf:
fastcgi_send_timeout 180;
/etc/nginx/conf.d/documents.koshie.fr.conf:
fastcgi_read_timeout 180;
/etc/nginx/conf.d/documents.koshie.fr.conf:
fastcgi_buffer_size 128k;
/etc/nginx/conf.d/documents.koshie.fr.conf:
fastcgi_buffers
4 256k;
/etc/nginx/conf.d/documents.koshie.fr.conf:
fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/documents.koshie.fr.conf:
fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/documents.koshie.fr.conf:
fastcgi_intercept_errors on;
/etc/nginx/conf.d/documents.koshie.fr.conf: }
/etc/nginx/conf.d/documents.koshie.fr.conf:}
/etc/nginx/conf.d/jmuller.koshie.fr.conf:server {
/etc/nginx/conf.d/jmuller.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: server_name
176.31.122.26;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: server_name
jmuller.koshie.fr
www.jmuller.koshie.fr;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: root
/var/www/koshie.fr/jmuller;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: ssl_session_timeout 5m;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: ssl_protocols SSLv2 SSLv3
TLSv1;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: ssl_prefer_server_ciphers
on;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: client_max_body_size 8M;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: client_body_buffer_size 256K;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/jmuller.koshie.fr.conf: include fastcgi_params;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: fastcgi_param
SCRIPT_FILENAME
$document_root$fastcgi_script_name;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: fastcgi_connect_timeout 60;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: fastcgi_send_timeout 180;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: fastcgi_read_timeout 180;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: fastcgi_buffer_size 128k;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: fastcgi_buffers 4 256k;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: fastcgi_busy_buffers_size
256k;
/etc/nginx/conf.d/jmuller.koshie.fr.conf:
fastcgi_temp_file_write_size
256k;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: fastcgi_intercept_errors
on;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: }
/etc/nginx/conf.d/jmuller.koshie.fr.conf:location / {
/etc/nginx/conf.d/jmuller.koshie.fr.conf: rewrite
^/([a-z_]+).html$ /index.php?page=$1;
/etc/nginx/conf.d/jmuller.koshie.fr.conf: }
/etc/nginx/conf.d/jmuller.koshie.fr.conf:}
/etc/nginx/conf.d/images.koshie.fr.conf:server {
/etc/nginx/conf.d/images.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/images.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/images.koshie.fr.conf: server_name
images.koshie.fr www.images.koshie.fr;
/etc/nginx/conf.d/images.koshie.fr.conf: root
/var/www/koshie.fr/images;
/etc/nginx/conf.d/images.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/images.koshie.fr.conf: ssl_session_timeout 5m;
/etc/nginx/conf.d/images.koshie.fr.conf: ssl_protocols SSLv2
SSLv3
TLSv1;
/etc/nginx/conf.d/images.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/images.koshie.fr.conf:
ssl_prefer_server_ciphers on;
/etc/nginx/conf.d/images.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/images.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/images.koshie.fr.conf: client_max_body_size
8M;
/etc/nginx/conf.d/images.koshie.fr.conf: client_body_buffer_size
256K;
/etc/nginx/conf.d/images.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/images.koshie.fr.conf: include
fastcgi_params;
/etc/nginx/conf.d/images.koshie.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/images.koshie.fr.conf: fastcgi_param
SCRIPT_FILENAME $document_root$fastcgi_script_name;
/etc/nginx/conf.d/images.koshie.fr.conf:
fastcgi_connect_timeout 60;
/etc/nginx/conf.d/images.koshie.fr.conf:
fastcgi_send_timeout 180;
/etc/nginx/conf.d/images.koshie.fr.conf:
fastcgi_read_timeout 180;
/etc/nginx/conf.d/images.koshie.fr.conf:
fastcgi_buffer_size 128k;
/etc/nginx/conf.d/images.koshie.fr.conf: fastcgi_buffers
4
256k;
/etc/nginx/conf.d/images.koshie.fr.conf:
fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/images.koshie.fr.conf:
fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/images.koshie.fr.conf:
fastcgi_intercept_errors on;
/etc/nginx/conf.d/images.koshie.fr.conf: }
/etc/nginx/conf.d/images.koshie.fr.conf:}
/etc/nginx/conf.d/wiki.koshie.fr.conf:server {
/etc/nginx/conf.d/wiki.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/wiki.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/wiki.koshie.fr.conf: server_name
wiki.koshie.fr www.wiki.koshie.fr;
/etc/nginx/conf.d/wiki.koshie.fr.conf: root
/var/www/koshie.fr/wiki;
/etc/nginx/conf.d/wiki.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/wiki.koshie.fr.conf: ssl_session_timeout 5m;
/etc/nginx/conf.d/wiki.koshie.fr.conf: ssl_protocols SSLv2 SSLv3
TLSv1;
/etc/nginx/conf.d/wiki.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/wiki.koshie.fr.conf: ssl_prefer_server_ciphers
on;
/etc/nginx/conf.d/wiki.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/wiki.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/wiki.koshie.fr.conf: client_max_body_size
8M;
/etc/nginx/conf.d/wiki.koshie.fr.conf: client_body_buffer_size
256K;
/etc/nginx/conf.d/wiki.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/wiki.koshie.fr.conf: include
fastcgi_params;
/etc/nginx/conf.d/wiki.koshie.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/wiki.koshie.fr.conf: fastcgi_param
SCRIPT_FILENAME $document_root$fastcgi_script_name;
/etc/nginx/conf.d/wiki.koshie.fr.conf:
fastcgi_connect_timeout 60;
/etc/nginx/conf.d/wiki.koshie.fr.conf:
fastcgi_send_timeout
180;
/etc/nginx/conf.d/wiki.koshie.fr.conf:
fastcgi_read_timeout
180;
/etc/nginx/conf.d/wiki.koshie.fr.conf:
fastcgi_buffer_size
128k;
/etc/nginx/conf.d/wiki.koshie.fr.conf: fastcgi_buffers 4
256k;
/etc/nginx/conf.d/wiki.koshie.fr.conf:
fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/wiki.koshie.fr.conf:
fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/wiki.koshie.fr.conf:
fastcgi_intercept_errors on;
/etc/nginx/conf.d/wiki.koshie.fr.conf: }
/etc/nginx/conf.d/wiki.koshie.fr.conf:}
/etc/nginx/conf.d/enka.koshie.fr.conf:server {
/etc/nginx/conf.d/enka.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/enka.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/enka.koshie.fr.conf: server_name
enka.koshie.fr www.enka.koshie.fr;
/etc/nginx/conf.d/enka.koshie.fr.conf: root
/var/www/koshie.fr/enka;
/etc/nginx/conf.d/enka.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/enka.koshie.fr.conf: ssl_session_timeout 5m;
/etc/nginx/conf.d/enka.koshie.fr.conf: ssl_protocols SSLv2 SSLv3
TLSv1;
/etc/nginx/conf.d/enka.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/enka.koshie.fr.conf: ssl_prefer_server_ciphers
on;
/etc/nginx/conf.d/enka.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/enka.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/enka.koshie.fr.conf: client_max_body_size
8M;
/etc/nginx/conf.d/enka.koshie.fr.conf: client_body_buffer_size
256K;
/etc/nginx/conf.d/enka.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/enka.koshie.fr.conf: include
fastcgi_params;
/etc/nginx/conf.d/enka.koshie.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/enka.koshie.fr.conf: fastcgi_param
SCRIPT_FILENAME $document_root$fastcgi_script_name;
/etc/nginx/conf.d/enka.koshie.fr.conf:
fastcgi_connect_timeout 60;
/etc/nginx/conf.d/enka.koshie.fr.conf:
fastcgi_send_timeout
180;
/etc/nginx/conf.d/enka.koshie.fr.conf:
fastcgi_read_timeout
180;
/etc/nginx/conf.d/enka.koshie.fr.conf:
fastcgi_buffer_size
128k;
/etc/nginx/conf.d/enka.koshie.fr.conf: fastcgi_buffers 4
256k;
/etc/nginx/conf.d/enka.koshie.fr.conf:
fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/enka.koshie.fr.conf:
fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/enka.koshie.fr.conf:
fastcgi_intercept_errors on;
/etc/nginx/conf.d/enka.koshie.fr.conf: }
/etc/nginx/conf.d/enka.koshie.fr.conf:}
grep: /etc/nginx/conf.d/doinalefort.com.conf: Permission denied
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:server {
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: server_name
geekdujour.koshie.fr www.geekdujour.koshie.fr;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: root
/var/www/koshie.fr/geekdujour;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: ssl_session_timeout
5m;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: ssl_protocols SSLv2
SSLv3 TLSv1;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:
ssl_prefer_server_ciphers on;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: index
index.php;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: fastcgi_index
index.php;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: include
fastcgi_params;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:
fastcgi_param
SCRIPT_FILENAME $document_root$fastcgi_script_name;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:
fastcgi_connect_timeout 60;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:
fastcgi_send_timeout 180;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:
fastcgi_read_timeout 180;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:
fastcgi_buffer_size 128k;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:
fastcgi_buffers 4 256k;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:
fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:
fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:
fastcgi_intercept_errors on;
/etc/nginx/conf.d/geekdujour.koshie.fr.conf: }
/etc/nginx/conf.d/geekdujour.koshie.fr.conf:}
/etc/nginx/conf.d/vaporideas.fr.conf:server {
/etc/nginx/conf.d/vaporideas.fr.conf: listen 80;
/etc/nginx/conf.d/vaporideas.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/vaporideas.fr.conf: server_name
vaporideas.fr
www.vaporideas.fr;
/etc/nginx/conf.d/vaporideas.fr.conf: root
/var/www/koshie.fr/vaporideas;
/etc/nginx/conf.d/vaporideas.fr.conf: msie_padding on;
/etc/nginx/conf.d/vaporideas.fr.conf: ssl_session_timeout 5m;
/etc/nginx/conf.d/vaporideas.fr.conf: ssl_protocols SSLv2 SSLv3
TLSv1;
/etc/nginx/conf.d/vaporideas.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/vaporideas.fr.conf: ssl_prefer_server_ciphers
on;
/etc/nginx/conf.d/vaporideas.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/vaporideas.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/vaporideas.fr.conf: client_max_body_size
8M;
/etc/nginx/conf.d/vaporideas.fr.conf: client_body_buffer_size
256K;
/etc/nginx/conf.d/vaporideas.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/vaporideas.fr.conf: include
fastcgi_params;
/etc/nginx/conf.d/vaporideas.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/vaporideas.fr.conf: fastcgi_param
SCRIPT_FILENAME $document_root$fastcgi_script_name;
/etc/nginx/conf.d/vaporideas.fr.conf:
fastcgi_connect_timeout 60;
/etc/nginx/conf.d/vaporideas.fr.conf:
fastcgi_send_timeout
180;
/etc/nginx/conf.d/vaporideas.fr.conf:
fastcgi_read_timeout
180;
/etc/nginx/conf.d/vaporideas.fr.conf: fastcgi_buffer_size
128k;
/etc/nginx/conf.d/vaporideas.fr.conf: fastcgi_buffers 4
256k;
/etc/nginx/conf.d/vaporideas.fr.conf:
fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/vaporideas.fr.conf:
fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/vaporideas.fr.conf:
fastcgi_intercept_errors on;
/etc/nginx/conf.d/vaporideas.fr.conf: }
/etc/nginx/conf.d/vaporideas.fr.conf:}
/etc/nginx/conf.d/le-numero.koshie.fr.conf:server {
/etc/nginx/conf.d/le-numero.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: server_name
le-numero.koshie.fr
www.le-numero.koshie.fr;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: root
/var/www/koshie.fr/le-numero;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: ssl_session_timeout 5m;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: ssl_protocols SSLv2 SSLv3
TLSv1;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: ssl_prefer_server_ciphers
on;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: client_max_body_size
8M;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: client_body_buffer_size
256K;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/le-numero.koshie.fr.conf: include fastcgi_params;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: fastcgi_param
SCRIPT_FILENAME
$document_root$fastcgi_script_name;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: fastcgi_connect_timeout
60;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: fastcgi_send_timeout 180;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: fastcgi_read_timeout 180;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: fastcgi_buffer_size 128k;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: fastcgi_buffers 4 256k;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: fastcgi_busy_buffers_size
256k;
/etc/nginx/conf.d/le-numero.koshie.fr.conf:
fastcgi_temp_file_write_size
256k;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: fastcgi_intercept_errors
on;
/etc/nginx/conf.d/le-numero.koshie.fr.conf: }
/etc/nginx/conf.d/le-numero.koshie.fr.conf:}
/etc/nginx/conf.d/koshie.fr.conf:server {
/etc/nginx/conf.d/koshie.fr.conf: listen 80;
/etc/nginx/conf.d/koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/koshie.fr.conf: server_name koshie.fr www.koshie.fr;
/etc/nginx/conf.d/koshie.fr.conf: root /var/www/koshie.fr/;
/etc/nginx/conf.d/koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/koshie.fr.conf: ssl_session_timeout 5m;
/etc/nginx/conf.d/koshie.fr.conf: ssl_protocols SSLv2 SSLv3 TLSv1;
/etc/nginx/conf.d/koshie.fr.conf: ssl_ciphers HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/koshie.fr.conf: ssl_prefer_server_ciphers on;
/etc/nginx/conf.d/koshie.fr.conf: error_log /var/log/nginx/error.log;
/etc/nginx/conf.d/koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/koshie.fr.conf: client_max_body_size 8M;
/etc/nginx/conf.d/koshie.fr.conf: client_body_buffer_size 256K;
/etc/nginx/conf.d/koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/koshie.fr.conf: include fastcgi_params;
/etc/nginx/conf.d/koshie.fr.conf: fastcgi_pass 127.0.0.1:9000;
/etc/nginx/conf.d/koshie.fr.conf: fastcgi_param SCRIPT_FILENAME
$document_root$fastcgi_script_name;
/etc/nginx/conf.d/koshie.fr.conf: fastcgi_connect_timeout 60;
/etc/nginx/conf.d/koshie.fr.conf: fastcgi_send_timeout 180;
/etc/nginx/conf.d/koshie.fr.conf: fastcgi_read_timeout 180;
/etc/nginx/conf.d/koshie.fr.conf: fastcgi_buffer_size 128k;
/etc/nginx/conf.d/koshie.fr.conf: fastcgi_buffers 4 256k;
/etc/nginx/conf.d/koshie.fr.conf: fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/koshie.fr.conf: fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/koshie.fr.conf: fastcgi_intercept_errors on;
/etc/nginx/conf.d/koshie.fr.conf: }
/etc/nginx/conf.d/koshie.fr.conf:}
/etc/nginx/conf.d/bacqup.com.conf:server {
/etc/nginx/conf.d/bacqup.com.conf: listen 80;
/etc/nginx/conf.d/bacqup.com.conf: listen 443 ssl;
/etc/nginx/conf.d/bacqup.com.conf: server_name bacqup.com
www.bacqup.com;
/etc/nginx/conf.d/bacqup.com.conf: root /var/www/bacqup.com/;
/etc/nginx/conf.d/bacqup.com.conf: msie_padding on;
/etc/nginx/conf.d/bacqup.com.conf: ssl_session_timeout 5m;
/etc/nginx/conf.d/bacqup.com.conf: ssl_protocols SSLv2 SSLv3 TLSv1;
/etc/nginx/conf.d/bacqup.com.conf: ssl_ciphers HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/bacqup.com.conf: ssl_prefer_server_ciphers on;
/etc/nginx/conf.d/bacqup.com.conf: error_log /var/log/nginx/error.log;
/etc/nginx/conf.d/bacqup.com.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/bacqup.com.conf: index index.php;
/etc/nginx/conf.d/bacqup.com.conf: fastcgi_index index.php;
/etc/nginx/conf.d/bacqup.com.conf: client_max_body_size 8M;
/etc/nginx/conf.d/bacqup.com.conf: client_body_buffer_size 256K;
/etc/nginx/conf.d/bacqup.com.conf: location ~ .php$ {
/etc/nginx/conf.d/bacqup.com.conf: include fastcgi_params;
/etc/nginx/conf.d/bacqup.com.conf: fastcgi_pass 127.0.0.1:9000;
/etc/nginx/conf.d/bacqup.com.conf: fastcgi_param SCRIPT_FILENAME
$document_root$fastcgi_script_name;
/etc/nginx/conf.d/bacqup.com.conf: fastcgi_connect_timeout 60;
/etc/nginx/conf.d/bacqup.com.conf: fastcgi_send_timeout 180;
/etc/nginx/conf.d/bacqup.com.conf: fastcgi_read_timeout 180;
/etc/nginx/conf.d/bacqup.com.conf: fastcgi_buffer_size 128k;
/etc/nginx/conf.d/bacqup.com.conf: fastcgi_buffers 4 256k;
/etc/nginx/conf.d/bacqup.com.conf: fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/bacqup.com.conf: fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/bacqup.com.conf: fastcgi_intercept_errors on;
/etc/nginx/conf.d/bacqup.com.conf: }
/etc/nginx/conf.d/bacqup.com.conf:location / {
/etc/nginx/conf.d/bacqup.com.conf: rewrite ^/([a-z_]+).html$
/index.php?page=$1;
/etc/nginx/conf.d/bacqup.com.conf: }
/etc/nginx/conf.d/bacqup.com.conf:}
grep: /etc/nginx/conf.d/doinalefort.fr.conf: Permission denied
/etc/nginx/conf.d/for-help.koshie.fr.conf:server {
/etc/nginx/conf.d/for-help.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/for-help.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/for-help.koshie.fr.conf: server_name
for-help.koshie.fr www.for-help.koshie.fr;
/etc/nginx/conf.d/for-help.koshie.fr.conf: root
/var/www/koshie.fr/for-help;
/etc/nginx/conf.d/for-help.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/for-help.koshie.fr.conf: ssl_session_timeout
5m;
/etc/nginx/conf.d/for-help.koshie.fr.conf: ssl_protocols SSLv2
SSLv3 TLSv1;
/etc/nginx/conf.d/for-help.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/for-help.koshie.fr.conf:
ssl_prefer_server_ciphers on;
/etc/nginx/conf.d/for-help.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/for-help.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/for-help.koshie.fr.conf: index
index.php;
/etc/nginx/conf.d/for-help.koshie.fr.conf: fastcgi_index
index.php;
/etc/nginx/conf.d/for-help.koshie.fr.conf:
client_max_body_size 8M;
/etc/nginx/conf.d/for-help.koshie.fr.conf:
client_body_buffer_size
256K;
/etc/nginx/conf.d/for-help.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/for-help.koshie.fr.conf: include
fastcgi_params;
/etc/nginx/conf.d/for-help.koshie.fr.conf: fastcgi_pass
unix:/var/run/php5-fpm.sock;
/etc/nginx/conf.d/for-help.koshie.fr.conf: fastcgi_param
SCRIPT_FILENAME $document_root$fastcgi_script_name;
/etc/nginx/conf.d/for-help.koshie.fr.conf:
fastcgi_connect_timeout 60;
/etc/nginx/conf.d/for-help.koshie.fr.conf:
fastcgi_send_timeout 180;
/etc/nginx/conf.d/for-help.koshie.fr.conf:
fastcgi_read_timeout 180;
/etc/nginx/conf.d/for-help.koshie.fr.conf:
fastcgi_buffer_size 128k;
/etc/nginx/conf.d/for-help.koshie.fr.conf:
fastcgi_buffers
4 256k;
/etc/nginx/conf.d/for-help.koshie.fr.conf:
fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/for-help.koshie.fr.conf:
fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/for-help.koshie.fr.conf:
fastcgi_intercept_errors on;
/etc/nginx/conf.d/for-help.koshie.fr.conf: }
/etc/nginx/conf.d/for-help.koshie.fr.conf:}
/etc/nginx/conf.d/neko.koshie.fr.conf:server {
/etc/nginx/conf.d/neko.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/neko.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/neko.koshie.fr.conf: server_name
neko.koshie.fr www.neko.koshie.fr;
/etc/nginx/conf.d/neko.koshie.fr.conf: root
/var/www/koshie.fr/neko;
/etc/nginx/conf.d/neko.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/neko.koshie.fr.conf: ssl_session_timeout 5m;
/etc/nginx/conf.d/neko.koshie.fr.conf: ssl_protocols SSLv2 SSLv3
TLSv1;
/etc/nginx/conf.d/neko.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/neko.koshie.fr.conf: ssl_prefer_server_ciphers
on;
/etc/nginx/conf.d/neko.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/neko.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/neko.koshie.fr.conf: client_max_body_size
8M;
/etc/nginx/conf.d/neko.koshie.fr.conf: client_body_buffer_size
256K;
/etc/nginx/conf.d/neko.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/neko.koshie.fr.conf: include
fastcgi_params;
/etc/nginx/conf.d/neko.koshie.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/neko.koshie.fr.conf: fastcgi_param
SCRIPT_FILENAME $document_root$fastcgi_script_name;
/etc/nginx/conf.d/neko.koshie.fr.conf:
fastcgi_connect_timeout 60;
/etc/nginx/conf.d/neko.koshie.fr.conf:
fastcgi_send_timeout
180;
/etc/nginx/conf.d/neko.koshie.fr.conf:
fastcgi_read_timeout
180;
/etc/nginx/conf.d/neko.koshie.fr.conf:
fastcgi_buffer_size
128k;
/etc/nginx/conf.d/neko.koshie.fr.conf: fastcgi_buffers 4
256k;
/etc/nginx/conf.d/neko.koshie.fr.conf:
fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/neko.koshie.fr.conf:
fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/neko.koshie.fr.conf:
fastcgi_intercept_errors on;
/etc/nginx/conf.d/neko.koshie.fr.conf: }
/etc/nginx/conf.d/neko.koshie.fr.conf:}
/etc/nginx/conf.d/eo.koshie.fr.conf:server {
/etc/nginx/conf.d/eo.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/eo.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/eo.koshie.fr.conf: server_name eo.koshie.fr
www.eo.koshie.fr;
/etc/nginx/conf.d/eo.koshie.fr.conf: root
/var/www/koshie.fr/eo;
/etc/nginx/conf.d/eo.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/eo.koshie.fr.conf: ssl_session_timeout 5m;
/etc/nginx/conf.d/eo.koshie.fr.conf: ssl_protocols SSLv2 SSLv3
TLSv1;
/etc/nginx/conf.d/eo.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/eo.koshie.fr.conf: ssl_prefer_server_ciphers
on;
/etc/nginx/conf.d/eo.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/eo.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/eo.koshie.fr.conf: client_max_body_size
8M;
/etc/nginx/conf.d/eo.koshie.fr.conf: client_body_buffer_size
256K;
/etc/nginx/conf.d/eo.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/eo.koshie.fr.conf: include
fastcgi_params;
/etc/nginx/conf.d/eo.koshie.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/eo.koshie.fr.conf: fastcgi_param
SCRIPT_FILENAME $document_root$fastcgi_script_name;
/etc/nginx/conf.d/eo.koshie.fr.conf:
fastcgi_connect_timeout 60;
/etc/nginx/conf.d/eo.koshie.fr.conf: fastcgi_send_timeout
180;
/etc/nginx/conf.d/eo.koshie.fr.conf: fastcgi_read_timeout
180;
/etc/nginx/conf.d/eo.koshie.fr.conf: fastcgi_buffer_size
128k;
/etc/nginx/conf.d/eo.koshie.fr.conf: fastcgi_buffers 4
256k;
/etc/nginx/conf.d/eo.koshie.fr.conf:
fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/eo.koshie.fr.conf:
fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/eo.koshie.fr.conf:
fastcgi_intercept_errors on;
/etc/nginx/conf.d/eo.koshie.fr.conf: }
/etc/nginx/conf.d/eo.koshie.fr.conf:}
grep: /etc/nginx/conf.d/doinalefort.koshie.fr.conf: Permission denied
/etc/nginx/conf.d/metal.koshie.fr.conf:server {
/etc/nginx/conf.d/metal.koshie.fr.conf: listen 80;
/etc/nginx/conf.d/metal.koshie.fr.conf: listen 443 ssl;
/etc/nginx/conf.d/metal.koshie.fr.conf: server_name
metal.koshie.fr www.metal.koshie.fr;
/etc/nginx/conf.d/metal.koshie.fr.conf: root
/var/www/koshie.fr/metal;
/etc/nginx/conf.d/metal.koshie.fr.conf: msie_padding on;
/etc/nginx/conf.d/metal.koshie.fr.conf: ssl_session_timeout 5m;
/etc/nginx/conf.d/metal.koshie.fr.conf: ssl_protocols SSLv2
SSLv3
TLSv1;
/etc/nginx/conf.d/metal.koshie.fr.conf: ssl_ciphers
HIGH:!aNULL:!MD5;
/etc/nginx/conf.d/metal.koshie.fr.conf: ssl_prefer_server_ciphers
on;
/etc/nginx/conf.d/metal.koshie.fr.conf: error_log
/var/log/nginx/error.log;
/etc/nginx/conf.d/metal.koshie.fr.conf: access_log
/var/log/nginx/access.log;
/etc/nginx/conf.d/metal.koshie.fr.conf: client_max_body_size
8M;
/etc/nginx/conf.d/metal.koshie.fr.conf: client_body_buffer_size
256K;
/etc/nginx/conf.d/metal.koshie.fr.conf: location ~ .php$ {
/etc/nginx/conf.d/metal.koshie.fr.conf: include
fastcgi_params;
/etc/nginx/conf.d/metal.koshie.fr.conf: fastcgi_pass
127.0.0.1:9000;
/etc/nginx/conf.d/metal.koshie.fr.conf: fastcgi_param
SCRIPT_FILENAME $document_root$fastcgi_script_name;
/etc/nginx/conf.d/metal.koshie.fr.conf:
fastcgi_connect_timeout 60;
/etc/nginx/conf.d/metal.koshie.fr.conf:
fastcgi_send_timeout 180;
/etc/nginx/conf.d/metal.koshie.fr.conf:
fastcgi_read_timeout 180;
/etc/nginx/conf.d/metal.koshie.fr.conf:
fastcgi_buffer_size
128k;
/etc/nginx/conf.d/metal.koshie.fr.conf: fastcgi_buffers 4
256k;
/etc/nginx/conf.d/metal.koshie.fr.conf:
fastcgi_busy_buffers_size 256k;
/etc/nginx/conf.d/metal.koshie.fr.conf:
fastcgi_temp_file_write_size 256k;
/etc/nginx/conf.d/metal.koshie.fr.conf:
fastcgi_intercept_errors on;
/etc/nginx/conf.d/metal.koshie.fr.conf: }
/etc/nginx/conf.d/metal.koshie.fr.conf:}
/etc/nginx/conf.d/default.conf:server {
/etc/nginx/conf.d/default.conf: listen 80;
/etc/nginx/conf.d/default.conf: server_name localhost;
/etc/nginx/conf.d/default.conf: location / {
/etc/nginx/conf.d/default.conf: root /usr/share/nginx/html;
/etc/nginx/conf.d/default.conf: index index.html index.htm;
/etc/nginx/conf.d/default.conf: }
/etc/nginx/conf.d/default.conf: error_page 500 502 503 504
/50x.html;
/etc/nginx/conf.d/default.conf: location = /50x.html {
/etc/nginx/conf.d/default.conf: root /usr/share/nginx/html;
/etc/nginx/conf.d/default.conf: }
/etc/nginx/conf.d/default.conf:}
/etc/nginx/nginx.conf:user www-data;
/etc/nginx/nginx.conf:worker_processes 1;
/etc/nginx/nginx.conf:error_log /var/log/nginx/error.log debug;
/etc/nginx/nginx.conf:pid /var/run/nginx.pid;
/etc/nginx/nginx.conf:events {
/etc/nginx/nginx.conf: worker_connections 1024;
/etc/nginx/nginx.conf:}
/etc/nginx/nginx.conf:http {
/etc/nginx/nginx.conf: include /etc/nginx/mime.types;
/etc/nginx/nginx.conf: default_type application/octet-stream;
/etc/nginx/nginx.conf: index index.html index.php;
/etc/nginx/nginx.conf: log_format main '$remote_addr - $remote_user
[$time_local] “$request” ’
/etc/nginx/nginx.conf: '$status $body_bytes_sent
“$http_referer” ’
/etc/nginx/nginx.conf: ‘"$http_user_agent"
“$http_x_forwarded_for”’;
/etc/nginx/nginx.conf: access_log /var/log/nginx/access.log main;
/etc/nginx/nginx.conf: sendfile on;
/etc/nginx/nginx.conf: keepalive_timeout 65;
/etc/nginx/nginx.conf: gzip on;
/etc/nginx/nginx.conf: include /etc/nginx/conf.d/*.conf;
/etc/nginx/nginx.conf: include /etc/nginx/fastcgi_params;
/etc/nginx/nginx.conf:}

find /etc/nginx/sites-/|xargs -r grep -v ‘^\s*(#|$)’

/etc/nginx/sites-available/default:server {
/etc/nginx/sites-available/default: root /usr/share/nginx/www;
/etc/nginx/sites-available/default: index index.html index.htm;
/etc/nginx/sites-available/default: server_name localhost;
/etc/nginx/sites-available/default: location / {
/etc/nginx/sites-available/default: try_files $uri $uri/ /index.html;
/etc/nginx/sites-available/default: }
/etc/nginx/sites-available/default: location /doc/ {
/etc/nginx/sites-available/default: alias /usr/share/doc/;
/etc/nginx/sites-available/default: autoindex on;
/etc/nginx/sites-available/default: allow 127.0.0.1;
/etc/nginx/sites-available/default: allow ::1;
/etc/nginx/sites-available/default: deny all;
/etc/nginx/sites-available/default: }
/etc/nginx/sites-available/default:}
/etc/nginx/sites-enabled/default:server {
/etc/nginx/sites-enabled/default: root /usr/share/nginx/www;
/etc/nginx/sites-enabled/default: index index.html index.htm;
/etc/nginx/sites-enabled/default: server_name localhost;
/etc/nginx/sites-enabled/default: location / {
/etc/nginx/sites-enabled/default: try_files $uri $uri/ /index.html;
/etc/nginx/sites-enabled/default: }
/etc/nginx/sites-enabled/default: location /doc/ {
/etc/nginx/sites-enabled/default: alias /usr/share/doc/;
/etc/nginx/sites-enabled/default: autoindex on;
/etc/nginx/sites-enabled/default: allow 127.0.0.1;
/etc/nginx/sites-enabled/default: allow ::1;
/etc/nginx/sites-enabled/default: deny all;
/etc/nginx/sites-enabled/default: }
/etc/nginx/sites-enabled/default:}

Cordially, koshie


Sorry for my english, I’m trying the best in each e-mail writing. Tell
me
if I’m not clear enough.
This mail account is only for list reading, to contact me send an e-mail
at [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs