501 Bad address syntax:: when using Action Mailer

Trying to debug a mail problem.

We’re seeing the error “501 Bad address syntax” when trying to send
mail. Our mail is hosted by Dreamhost and our config is as follows:


ACTIVATION_EMAIL_ADDRESS = “[email protected]

ActionMailer::Base.delivery_method = :smtp
ActionMailer::Base.smtp_settings = {
:address => “mail.foo.domain.com”,
:port => 587,
:domain => “foo.domain.com”,
:user_name => ACTIVATION_EMAIL_ADDRESS,
:password => “password”,
:authentication => :login
}

ActionMailer::Base.perform_deliveries = true
ActionMailer::Base.raise_delivery_errors = true
ActionMailer::Base.default_charset = “utf-8”

FYI - if I change to the password to something incorrect we get the
error: 535 Error: authentication failed.

Thanks for any help.

Hi Will,

I am new to ROR and facing the same problem. I have also used the same
kind of smtp settings…

Please let me know if you have found the solution for this issue.

Email Address - [email protected]

Thanks In advance.

Neha

Will M. wrote:

Trying to debug a mail problem.

We’re seeing the error “501 Bad address syntax” when trying to send
mail. Our mail is hosted by Dreamhost and our config is as follows:


ACTIVATION_EMAIL_ADDRESS = “[email protected]

ActionMailer::Base.delivery_method = :smtp
ActionMailer::Base.smtp_settings = {
:address => “mail.foo.domain.com”,
:port => 587,
:domain => “foo.domain.com”,
:user_name => ACTIVATION_EMAIL_ADDRESS,
:password => “password”,
:authentication => :login
}

ActionMailer::Base.perform_deliveries = true
ActionMailer::Base.raise_delivery_errors = true
ActionMailer::Base.default_charset = “utf-8”

FYI - if I change to the password to something incorrect we get the
error: 535 Error: authentication failed.

Thanks for any help.

You haven’t shown us the interesting bit: when you actually try and
send the email
Fred

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs