500 Internal Server Error again

Hi all,

I installed and ran Typo (from SVN) + Webrick successfully. In fact, I
ran the stable version (2.6.0) + Webrick successfully too. However I
could not get Typo to work on apache 2.0.54 (FC4) with CGI (Not fast-cgi
!).

I changed the first line (#! to /usr/local/bin/ruby, which is where my
ruby is currently installed). I also changed .htaccess to use
dispatch.cgi (instead of dispatch.fcgi). The database.yml file works
fine since the Webrick version is ok. There is nothing logged to
production.log or development.log (I tried both environments by changing
the environment variable in environment.rb).

When I tried dispatch.cgi on command line, there was an error due to a
Nil object (probably because HTTP Request environment variable is
empty). So this seems normal.

The same apache + cgi-bin setup ran my own Ruby-on-Rail program
successfully. I was able to update, list, create new objects.

Has anyone encountered this before ? Is there anyway to turn on a more
detailed trace or debug log ? Many thanks

Regards,
Jin-Ho

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs