500 error when posting, no message in error logs

Hi All,

I’m running nginx 1.4.1 on OpenBSD 5.4 stable along with php and php-fpm
version 5.3.27 and mysql 5.1.70 on two systems. I’m trying to install
piwigo-2.6.1 and running into an issue on of of the systems as indicated
by
the subject.

When I access the site initially it takes me to the setup screen as
expected
on both systems. I enter in the data required and click on “start
installation”. On one system it installs perfectly in less than a
second,
in the second system it returns a page that simply says “server error”
if i
click on more info it says:

"The website encountered an error while retrieving
http://piwigo.domain.com/install.php?language=en_US. It may be down for
maintenance or configured incorrectly.

Reload this webpage.
Press the reload button to resubmit the data needed to load the page.

Error code: 500"

In the access log I see this:

10.0.0.10 - - [13/Feb/2014:12:50:46 -0500] “POST
/install.php?language=en_US
HTTP/1.1” 500 5 “http://piwigo.domain.com/install.php?language=en_US
“Mozilla/5.0 (X11; OpenBSD amd64) AppleWebKit/537.36 (KHTML, like Gecko)
Chrome/28.0.1500.45 Safari/537.36” “-”

No other information, nothing in the error_log.

I have run diff’s on the entire /etc/nginx directory and the only thing
that
is different between the two systems is the server name in the
sites-available/<servername.com> files.

I also diffed the php-fpm.conf files and they are identical, php.ini are
identical as well.

I would have consulted the piwigo group, but since it’s running
perfectly
on, actually 2 other systems with the same OS/software/config
combinations,
it seems like there must be something i’m missing on the nginx/php side.

I’m banging my head here, any help would be appreciated.

I have included my configuration files below.

TIA,

Aaron

working system:
nginx.conf:

cat /etc/nginx/nginx.conf

user www;
worker_processes 1;

events {
worker_connections 1024;
}

http {
server_tokens off;
include mime.types;
default_type application/octet-stream;
index index.html index.htm index.php;
error_log /var/www/logs/error.log debug;
keepalive_timeout 65;
gzip on;
log_format main '$remote_addr - $remote_user [$time_local]
“$request” ’
'$status $body_bytes_sent “$http_referer” ’
‘"$http_user_agent" “$http_x_forwarded_for”’;

    include         /etc/nginx/sites-enabled/*;

}

php-fpm.conf:

cat /etc/php-fpm.conf

error_log = /var/log/php-fpm.error.log
; alert, error, warning, notice, debug
log_level = error
; log_level = debug

[www]
user = www
group = www

listen = 127.0.0.1:9000

listen.owner = www
listen.group = www
listen.mode = 0666

listen.allowed_clients = 127.0.0.1
pm = dynamic

pm.max_children = 5
pm.start_servers = 2
pm.min_spare_servers = 1
pm.max_spare_servers = 3

php_admin_value[max_execution_time] = 600
php_admin_value[max_input_time] = 600

piwigo.domain.com:
cat piwigo26.domain.com
server {
listen 10.0.4.16:80;
server_name piwigo26.domain.com;
root /var/www/piwigo;
error_log /var/www/logs/piwigo_error_log;
access_log /var/www/logs/piwigo_access_log main;
client_max_body_size 5172M;

    location ~ \.php$ {
        fastcgi_pass   127.0.0.1:9000;
        fastcgi_index  index.php;
        fastcgi_split_path_info ^(.+\.php)(.*)$;
        fastcgi_param  SCRIPT_FILENAME

$document_root$fastcgi_script_name;
fastcgi_param PATH_INFO $fastcgi_path_info;
include fastcgi_params;
}

    location ~ /\.ht {
        deny  all;
    }

}

NON-working system:
nginx.conf:

cat /etc/nginx/nginx.conf

user www;
worker_processes 1;

events {
worker_connections 1024;
}

http {
server_tokens off;
include mime.types;
default_type application/octet-stream;
index index.html index.htm index.php;
error_log /var/www/logs/error.log debug;
keepalive_timeout 65;
gzip on;
log_format main '$remote_addr - $remote_user [$time_local]
“$request” ’
'$status $body_bytes_sent “$http_referer” ’
‘"$http_user_agent" “$http_x_forwarded_for”’;

    include         /etc/nginx/sites-enabled/*;

}

php-fpm.conf:

cat /etc/php-fpm.conf

error_log = /var/log/php-fpm.error.log
; alert, error, warning, notice, debug
log_level = error
; log_level = debug

[www]
user = www
group = www

listen = 127.0.0.1:9000

listen.owner = www
listen.group = www
listen.mode = 0666

listen.allowed_clients = 127.0.0.1
pm = dynamic

pm.max_children = 5
pm.start_servers = 2
pm.min_spare_servers = 1
pm.max_spare_servers = 3

php_admin_value[max_execution_time] = 600
php_admin_value[max_input_time] = 600

sites-available/piwigo.domain.com:
cat workhorse.piwigo.domain.com

server {
listen 172.17.37.77:80;
server_name piwigo.domain.com;
root /var/www/piwigo;
error_log /var/www/logs/piwigo_error_log debug;
access_log /var/www/logs/piwigo_access_log main;
client_max_body_size 5172M;

    location ~ \.php$ {
        fastcgi_pass   127.0.0.1:9000;
        fastcgi_index  index.php;
        fastcgi_split_path_info ^(.+\.php)(.*)$;
        fastcgi_param  SCRIPT_FILENAME

$document_root$fastcgi_script_name;
fastcgi_param PATH_INFO $fastcgi_path_info;
include fastcgi_params;
}

    location ~ /\.ht {
        deny  all;
    }

}

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,247530,247530#msg-247530

On Feb 13, 2014, at 23:23 , offthedeepnd wrote:

in the second system it returns a page that simply says “server error” if i

In the access log I see this:

10.0.0.10 - - [13/Feb/2014:12:50:46 -0500] “POST /install.php?language=en_US
HTTP/1.1” 500 5 “http://piwigo.domain.com/install.php?language=en_US
“Mozilla/5.0 (X11; OpenBSD amd64) AppleWebKit/537.36 (KHTML, like Gecko)
Chrome/28.0.1500.45 Safari/537.36” “-”

No other information, nothing in the error_log.

Try to log $upstream_status to see if this 500 error is returned by
backend.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs