403 Forbidden

Hi I can’t access my domain after installing nginx and coinfigurong the
default server conf file :

You may add here your

server {

}

statements for each of your virtual hosts to this file

You should look at the following URL’s in order to grasp a solid

understanding

of Nginx configuration files in order to fully unleash the power of

Nginx.

http://wiki.nginx.org/Pitfalls

http://wiki.nginx.org/QuickStart

http://wiki.nginx.org/Configuration

Generally, you will want to move this file somewhere, and start with a

clean

file but keep this around for reference. Or just disable in

sites-enabled.

Please see /usr/share/doc/nginx-doc/examples/ for more detailed

examples.

server {
listen 80;
server_name www.testmydomain.ovh *.testmydomain.ovh;
root /var/www/testmydomain.ovh/web;
access_log /var/www/logs/testmydomain.ovh.access.log;
error_log /var/www/logs/testmydomain.ovh.error.log;

index index.php index.html index.htm;

location ~* .(jpg|jpeg|gif|css|png|js|ico|html)$ {
access_log off;
expires max;
}

location ~ .php$ {
include fastcgi_params;
fastcgi_intercept_errors on;
# By all means use a different server for the fcgi processes if you
need to
fastcgi_pass unix:/var/run/php5-fpm.sock;
}
}

server {
listen 80 default_server;
listen [::]:80 default_server ipv6only=on;

root /usr/share/nginx/html;
index index.html index.htm;

Make site accessible from http://localhost/

server_name localhost;

location / {

First attempt to serve request as file, then

as directory, then fall back to displaying a 404.

try_files $uri $uri/ =404;

Uncomment to enable naxsi on this location

include /etc/nginx/naxsi.rules;

}

#error_page 404 /404.html;

redirect server error pages to the static page /50x.html

#error_page 500 502 503 504 /50x.html;
#location = /50x.html {

root /usr/share/nginx/html;

#}

pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000

#location ~ .php$ {

fastcgi_split_path_info ^(.+.php)(/.+)$;

# NOTE: You should have “cgi.fix_pathinfo = 0;” in php.ini

# With php5-cgi alone:

fastcgi_pass 127.0.0.1:9000;

# With php5-fpm:

fastcgi_pass unix:/var/run/php5-fpm.sock;

fastcgi_index index.php;

include fastcgi_params;

#}

deny access to .htaccess files, if Apache’s document root

concurs with nginx’s one

#location ~ /.ht {

deny all;

#}
}

another virtual host using mix of IP-, name-, and port-based

configuration

#server {

listen 8000;

listen somename:8080;

server_name somename alias another.alias;

root html;

index index.html index.htm;

location / {

try_files $uri $uri/ =404;

}

#}

HTTPS server

#server {

listen 443;

server_name localhost;

root html;

index index.html index.htm;

ssl on;

ssl_certificate cert.pem;

ssl_certificate_key cert.key;

ssl_session_timeout 5m;

ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;

ssl_ciphers “HIGH:!aNULL:!MD5 or HIGH:!aNULL:!MD5:!3DES”;

ssl_prefer_server_ciphers on;

location / {

try_files $uri $uri/ =404;

}

#}

What did I miss here ?

On Sat, Mar 07, 2015 at 01:01:11PM +0100, JACK LINKERS wrote:

Hi there,

Hi I can’t access my domain after installing nginx and coinfigurong the
default server conf file :

What request do you make; what response do you get; what response do
you want; and what do the logs say?

f

Francis D. [email protected]

It’s important that the right access is set for the files and folders in
/var/www/testdomain.ovh/web.

Nginx is running as user www-data (per default) and folders needs to be
set
with (at least) execute and read permissions for www-data. For files
read
permission is the least required.

~sjums

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs