403 (Forbidden) with Apache on Mongrel Cluster

Hi,

I’ve configured a rails application on my VPS to run on two
mongrels. When I run curl on localhost, the starting page comes up
fine. That is, mongrel is serving the app perfectly.

The problem arises when trying to access the app on my ip through
apache. I
get a 403 error. Just to test things out, I’ve set generous
permissions on the entire rails directory structure still to no avail.

I’ve also set up a non-rails virtual host, and everything works fine
there. So I doubt that it’s a vhost problem.

What could be the problem here? Any insights would be awesome; to me,
it’s been a real gordian knot.

Thanks,

Kyle

Hi,

I had a similar problem. I solved the problem by loading the proxy
modules:

LoadModule proxy_module /usr/lib/apache2-prefork/
mod_proxy.so
LoadModule proxy_http_module /usr/lib/apache2-prefork/
mod_proxy_http.so

in the apache configuration. Without the proxy-http module apache
delivers a 403 access denied

regards
– andi

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs