403 Forbidden! HELP!

I am installing rails on a hosting server (aplus.net) where I have
very limited access (no root access, I’m limited to my /home/
usernames/ dir). They had ruby installed but no rubygems or rails.

I got rubygems and rails up and running, I created a new app in
www.mydomain.com/testruby, but when I go there I get a 403 - Forbidden
error:

“Forbidden
You don’t have permission to access /testruby/ on this server.
You may need to create an index.html page or enable the directory
browsing by creating an .htaccess file containing “Options +Indexes”.”

The aplus.net server seems to be running:
Apache 1.3.36
CGI 3.10

I checked my CHMOD permissions on the dir and they seem to be set
correctly.

Man, I felt like I was so close to getting this running I could taste
it!

I’m new to this server stuff, could someone please help me?

“Forbidden
You don’t have permission to access /testruby/ on this server.
You may need to create an index.html page or enable the directory
browsing by creating an .htaccess file containing “Options +Indexes”.”

Your Apache doesn’t know that you want it to route requests for
testruby/ to
your Rails app (which must be a separate process running on a separate
port,
connected to Apache via some form of a proxy).

Read this: http://mongrel.rubyforge.org/docs/apache.html

Best regards,
Alex Verkhovsky

I just dealt with this yesterday, it took a while to figure it out.
For me, it had to do with using RewriteBase in side of a VirtualHost
declaration. There relevant lines in my .conf ended up looking like this

<VirtualHost *:80>
ServerName www.example.org
DocumentRoot /www/survey

<Directory /www/survey/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
Allow from all

Alias /application /www/application/current/public

<Directory “/www/application/current/public”>
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

 RewriteEngine On
 RewriteBase /application/

 RewriteCond %{REQUEST_FILENAME} !-f
 RewriteRule ^(.*)$ balancer://application_mongrel_cluster%

{REQUEST_URI} [P,QSA,L]

Hope that helps.

-Jason

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs