400 response HTTP code logged when using Haproxy 'option ssl-hello-chk'

Hello,
We’re using haproxy to load balance SSL between two nginx servers.
We’re using ‘option ssl-hello-chk’ for health monitoring in haproxy’s
config. The problem is it’s flooding our logs with 400 errors every 2
seconds. Is there a way to stop this?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,222212,222212#msg-222212

Hello!

On Fri, Feb 10, 2012 at 04:01:16AM -0500, trojan2748 wrote:

Hello,
We’re using haproxy to load balance SSL between two nginx servers.
We’re using ‘option ssl-hello-chk’ for health monitoring in haproxy’s
config. The problem is it’s flooding our logs with 400 errors every 2
seconds. Is there a way to stop this?

If you don’t want to see 400 errors, you may try something like
this (in a default server block):

error_page 400 /nolog;

location = /error_400 {
    access_log off;
    return 400;
}

Maxim D.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs