3rdRail creating new project issue - ubuntu 7.10

Hello, dudes:
When I am trying to create new rails project, the console in
3rdRail always says as follow and fails to create project related
files!

==========================

rails /media/sdb1/xxiao/program/3rdRail/workspace/wc
/usr/bin/ruby1.8: no Ruby script found in input (LoadError)
==========================

However, if I run “rails /media/sdb1/xxiao/program/3rdRail/
workspace/wc” in terminal, everything works fine as follow:

=========================
[email protected]:/usr/bin$ rails /media/sdb1/xxiao/program/3rdRail/
workspace/wc
exists
exists app/controllers
exists app/helpers
exists app/models
exists app/views/layouts
create config/environments
create components
exists db
create doc
create lib
create lib/tasks
create log

I have set the ruby interpreter path in 3rdRail, any good
suggestion??

Thanks in advance!
-Xi

myst_tt,

You might ask this question in the 3rdRail forum instead. You’ll get an
answer there. :slight_smile: Let me know if you don’t know where to find it.

Cody S.

Did you get the problem solved? 'cause i run into the same problem,
too.
When run “rake db:migrate” in 3rdrail, it threw an error: D:\ruby\bin
\ruby.exe: no Ruby script found in input (LoadError)

As far as I can tell, this is caused by the …/bin/rake file not having
a
��#! line.

So you should be able to add one, and continue as normal.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs