32 bit ruby versus 64 bit gem ELF issues

I am running into what I thought should be a simple solution…however
not the case yet.

I am running on Suse 64 bit:
Linux 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100
x86_64 x86_64 x86_64 GNU/Linux

My version of ruby is 32 bit version 1.8.7. I normally run a Lightty
front end with two instances of mongrel behind it. When I go to run the
gem install for mongrel 1.1.5 it builds fine, however, it builds as a 64
bit lib for http11.so. This causes ELF64 issues when I attempt to run
the rails (2.3.5) app.

Is there a way to have a gem compile as 32 bit when doing the install? I
could not find a command-line switch etc.

For now the plan has been to remain all 32-bit versus getting everything
to 64-bit…maybe that is not solid thinking.

Any information is appreciated…

thanks,
Rick

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs