2 Errors when checking ruby bindings for subversion


#1

I get these 2 errors when I do “make check-swig-rb”:

  1. Error:
    test_create(SvnFsTest):
    Svn::Error::FS_UNKNOWN_FS_TYPE: subversion/libsvn_fs/fs-loader.c:130
    Failed
    to load module for FS type ‘bdb’

/home/marlun/subversion-1.3.2/subversion/bindings/swig/ruby/svn/util.rb:58:in
`svn_fs_create’

/home/marlun/subversion-1.3.2/subversion/bindings/swig/ruby/svn/util.rb:58:in
`create’

/home/marlun/subversion-1.3.2/subversion/bindings/swig/ruby/svn/fs.rb:27:in
`create’

/home/marlun/subversion-1.3.2/subversion/bindings/swig/ruby/test/test_fs.rb:31:in
`test_create’

  1. Error:
    test_create(SvnReposTest):
    Svn::Error::FS_UNKNOWN_FS_TYPE: subversion/libsvn_fs/fs-loader.c:130
    Failed
    to load module for FS type ‘bdb’

/home/marlun/subversion-1.3.2/subversion/bindings/swig/ruby/svn/util.rb:58:in
`svn_repos_create’

/home/marlun/subversion-1.3.2/subversion/bindings/swig/ruby/svn/util.rb:58:in
`create’

/home/marlun/subversion-1.3.2/subversion/bindings/swig/ruby/svn/repos.rb:37:in
`create’

/home/marlun/subversion-1.3.2/subversion/bindings/swig/ruby/test/test_repos.rb:80:in
`test_create’

119 tests, 612 assertions, 0 failures, 2 errors

Is this normal?

Thanks in advance!


#2

Hi,

2006/6/5, Marlun (sent by Nabble.com) removed_email_address@domain.invalid:

I get these 2 errors when I do “make check-swig-rb”:

  1. Error:
    test_create(SvnFsTest):
    Svn::Error::FS_UNKNOWN_FS_TYPE: subversion/libsvn_fs/fs-loader.c:130 Failed
    to load module for FS type ‘bdb’
  2. Error:
    test_create(SvnReposTest):
    Svn::Error::FS_UNKNOWN_FS_TYPE: subversion/libsvn_fs/fs-loader.c:130 Failed
    to load module for FS type ‘bdb’

Is this normal?

Yes. This only shows your subversion doesn’t support BDB.

Thanks,