2.2.2 super simple upgrade question

I’ve been riding rails since 1.2 and had no problems (that i couldn’t
get over) upgrading. Since i’ve installed rails 2.2.2 (verified via gem
list, and rails -v) and I change my environment.rb to read

RAILS_GEM_VERSION = ‘2.2.2’

yet when i run script/server it still starts up in 2.1.0

=> Rails 2.1.0 application starting on http://0.0.0.0:3000

Am I missing something??

On Sat, Dec 27, 2008 at 7:52 PM, Richard S. <
[email protected]> wrote:

=> Rails 2.1.0 application starting on http://0.0.0.0:3000

Am I missing something??

Posted via http://www.ruby-forum.com/.

Hi, did you update the configuration files by running ‘rake
rails:update’ in
the root of your rails application? Also,
what version of ruby gems are you using (gem -v)?

-Conrad

Hi, did you update the configuration files by running ‘rake
rails:update’ in
the root of your rails application? Also,
what version of ruby gems are you using (gem -v)?

-Conrad

not sure if rake rails:update did anything but here’s the output of my
bash

166:slangasaurus richard$ rake rails:update
(in /Users/richardschneeman/Documents/AptanaStudio/slangasaurus)
166:slangasaurus richard$ gem -v
1.3.1

On Sat, Dec 27, 2008 at 8:14 PM, Richard S. <
[email protected]> wrote:

166:slangasaurus richard$ rake rails:update
(in /Users/richardschneeman/Documents/AptanaStudio/slangasaurus)
166:slangasaurus richard$ gem -v
1.3.1

Did you edit the RAILS_GEM_VERSION in the correct environment.rb?

Did you edit the RAILS_GEM_VERSION in the correct environment.rb?

here is my entire environment.rb file…http://pastie.org/347697

slangasaurus/config/environment.rb

RAILS_GEM_VERSION = ‘2.2.2’ unless defined? RAILS_GEM_VERSION

i’ve also tried just editing down to " RAILS_GEM_VERSION = ‘2.2.2’ "

166:slangasaurus richardschneeman$ rails -v
Rails 2.2.2

Nothing seems to affect the version that my script/server runs on…

richard-macbook-pro:slangasaurus richard$ sudo gem install rails
Successfully installed rails-2.2.2
1 gem installed
richard-macbook-pro:slangasaurus richard$ script/server
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.1.0 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
** Rails loaded.
** Loading any Rails specific GemPlugins
** Signals ready. TERM => stop. USR2 => restart. INT => stop (no
restart).
** Rails signals registered. HUP => reload (without restart). It might
not work well.
** Mongrel 1.1.5 available at 0.0.0.0:3000
** Use CTRL-C to stop.

Maybe not so simple of a question after all…

On Sat, Dec 27, 2008 at 8:30 PM, Richard S. <
[email protected]> wrote:

i’ve also tried just editing down to " RAILS_GEM_VERSION = ‘2.2.2’ "

166:slangasaurus richardschneeman$ rails -v
Rails 2.2.2

Nothing seems to affect the version that my script/server runs on…

Hi, I had a similar issue where I performed the following action to
resolve
the problem:

sudo gem install rails

-Conrad

On Sat, Dec 27, 2008 at 8:55 PM, Richard S. <
[email protected]> wrote:

** Starting Rails with development environment…
** Rails loaded.
** Loading any Rails specific GemPlugins
** Signals ready. TERM => stop. USR2 => restart. INT => stop (no
restart).
** Rails signals registered. HUP => reload (without restart). It might
not work well.
** Mongrel 1.1.5 available at 0.0.0.0:3000
** Use CTRL-C to stop.

Do you have multiple versions on rails installed (i.e. gem list)? Or do
you
have a version of rails installed in vendor/rails?

WOW, you’re fking awesome. I don’t know how i missed that. Thanks a
bunch, i knew it was something small. I had my rails version frozen, all
i had to do was delete the folder in under vendor. Thanks abunch!!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs