2.2.2 simple_captcha upgrade error

So thanks to Craig, i got up and running on rails 2.2.2, though now i’m
dealing with a whole new can of worms. I’ve done a good bit o searching
and haven’t found any solid leads. I’m using the simple_captcha plugin
on my site, and all is well until i call that plugin.

http://www.pastie.org/347721

ActionView::TemplateError (undefined method `transaction_status’ for
#PGconn:0x6a8ae20) on line #43 of
app/views/forms/_slang_form.html.erb:
42:
43: <%= show_simple_captcha %>
44:
45: <%= @f.submit “Submit” %>
46:

The plugin works great in 2.1.0, Has anyone seen anything like this
before??

It’s actually a problem with the postgres gem. I ran into this the
other day at work, if I remember correctly you just need to switch
which gem you hav installed. Unfortunately I don’t remember which one
to use and I’m not at the office.

On Dec 27, 11:57 pm, Richard S. <rails-mailing-l…@andreas-

That does make sense given all i’ve read about this error, thanks a
bunch!! I’m not in too much of a hurry to play wih 2.2.2, if its not too
much trouble whenever you get back to the office, could you let me know
what version of pgsql worked for you ( so i’m not just shooting in the
dark) ?

Right now i’m running 8.3.3 and if memory serves me correctly i had too
much trouble directly installing the gem, so I used mac ports. I tried
installing 8.2 from ports and wasn’t able to, i’m assuming whatever
version i end up with, i’ll have completely uninstall 8.3.3 first if i’m
using ports ?

It’s not the postgres (psql) version thats the problem, its actually
the ruby postgres gem that ActiveRecord uses to connect to psql. I
will be in the office tomorrow and will check it out.

On Dec 28, 10:48 am, Richard S. <rails-mailing-l…@andreas-

how shud we create tooltip in rails application…

Thanks in advance

I asked my boss what gem it was he determined we need to be on, he
claims “pr”, so I tried to install it and it fails to compile, so now
im back to square one. I really thought I had this all sorted out a
few weeks ago, maybe it was on a different computer.

richard$ gem list

postgres-pr (0.4.0)

richard$ sudo gem install postgres-pr
Password:
Successfully installed postgres-pr-0.5.0
richard$ script/server
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.2.2 application starting on http://0.0.0.0:3000

It worked great, Thanks!! No problems starting up or showing any of my
database entries, my app works just as it did before. Thanks for
everyone’s help!!

Try to install the postgres-pr gem install and use that.

Ryan B.
Freelancer
http://frozenplague.net

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs