2.2.2 rails for juggernaut

Hi gurus is there any site where i can obtain some guidelines in
Juggernaut for 2.2.2 I follwed this
http://www.slightlycoded.com/blog/the-juggernaut-a-push-server-for-ruby-on-rails
seems not to work after running

juggernaut -c juggernaut.yml -d

ive got this error

C:\InstantRails-2.2-win\rails_apps\chat_sandbox>juggernaut -c
juggernaut.yml -d
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/juggernaut-0.5.8/bin/…/lib/
juggernaut/runner.rb:205:in fork': fork() function is unimplemented on this mac hine (NotImplementedError) from C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/juggernaut-0.5. 8/bin/../lib/juggernaut/runner.rb:205:indaemonize’
from
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/juggernaut-0.5.
8/bin/…/lib/juggernaut/runner.rb:50:in initialize' from C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/juggernaut-0.5. 8/bin/../lib/juggernaut/runner.rb:11:innew’
from
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/juggernaut-0.5.
8/bin/…/lib/juggernaut/runner.rb:11:in run' from C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/juggernaut-0.5. 8/bin/juggernaut:4 from C:/InstantRails-2.2-win/ruby/bin/juggernaut:19:inload’
from C:/InstantRails-2.2-win/ruby/bin/juggernaut:19

C:\InstantRails-2.2-win\rails_apps\chat_sandbox>

please advice
tnx

On 24 Sep 2010, at 12:58, Luis Teko wrote:

C:\InstantRails-2.2-win\rails_apps\chat_sandbox>juggernaut -c
juggernaut.yml -d
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/juggernaut-0.5.8/
bin/…/lib/
juggernaut/runner.rb:205:in `fork’: fork() function is unimplemented
on
this mac

Quick google search:
"Kernel.fork is used to start a subprocess, which is sometimes needed
over just a Ruby thread (which is still part of the current process).
Unfortunately it doesn’t work on Windows because Windows doesn’t
support the fork command.

However, it does work under cygwin! Which is really useful :)"

Let’s be honest here, developing Rails apps on Windows is possible,
but there are quite a few gems with native libraries that will make
you run into these kinds of problems. You’re much better off
developing in a Linux VM or just switching to Linux completely.

Best regards

Peter De Berdt

master peter just to make a followup iwas able to run the juggernaut
server now removing flag -d

C:\InstantRails-2.2-win\rails_apps\chat_sandbox>juggernaut -c
juggernaut.yml
Starting Juggernaut server 0.5.8 on port: 5001…

but now im having issues with running the ruby script/server error
follows

C:\InstantRails-2.2-win\rails_apps\chat_sandbox>ruby script/server
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.2.2 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
Exiting
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.2-x86-mswin32/li
b/mongrel/tcphack.rb:12:in initialize_without_backlog': Only one usage of each socket address (protocol/network address/port) is normally permitted. - bind(2) (Errno::EADDRINUSE) from C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.2-x 86-mswin32/lib/mongrel/tcphack.rb:12:ininitialize’
from
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.2-x
86-mswin32/lib/mongrel.rb:93:in new' from C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.2-x 86-mswin32/lib/mongrel.rb:93:ininitialize’
from
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.2-x
86-mswin32/lib/mongrel/configurator.rb:139:in new' from C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.2-x 86-mswin32/lib/mongrel/configurator.rb:139:inlistener’
from
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.2-x
86-mswin32/bin/mongrel_rails:99:in cloaker_' from C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.2-x 86-mswin32/lib/mongrel/configurator.rb:50:incall’
from
C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.2-x
86-mswin32/lib/mongrel/configurator.rb:50:in initialize' ... 14 levels... from C:/InstantRails-2.2-win/ruby/lib/ruby/gems/1.8/gems/rails-2.2.2/lib /commands/server.rb:49 from C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom _require.rb:31:ingem_original_require’
from
C:/InstantRails-2.2-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom
_require.rb:31:in `require’
from script/server:3

any suggestion sir

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs