1.9.2 Snow Leopard Installation

Hi folks.

Been trying to install 1.9.2 on Snow Leopard all evening with another
dev helping me out. It’s not happening. RVM isn’t working either, but
that’s another story. This is what I am getting with the manual make:

ld: in /usr/local/lib/libsqlite3.dylib, missing required architecture x86_64 in
file for architecture x86_64
collect2: ld returned 1 exit status
make[1]: *** […/…/.ext/x86_64-darwin10.8.0/tcltklib.bundle] Error 1
make: *** [mkmain.sh] Error 1

sqlite is installed already for other technologies that I have, so I
can’t overwrite that.

Anybody know what I should be doing? I am following the directions
here:

http://www.iamseree.com/application-development/install-ruby-1-9-2-and-rails-3-1-0-rc-on-mac-os-x-snow-leopard

Cheers

On Mon, Aug 1, 2011 at 10:08 PM, Viaduct Productions

Been trying to install 1.9.2 on Snow Leopard all evening with another dev
helping me out. It’s not happening. RVM isn’t working either, but that’s another
story. This is what I am getting with the manual make:

ld: in /usr/local/lib/libsqlite3.dylib, missing required architecture x86_64 in
file for architecture x86_64
collect2: ld returned 1 exit status
make[1]: *** […/…/.ext/x86_64-darwin10.8.0/tcltklib.bundle] Error 1
make: *** [mkmain.sh] Error 1

sqlite is installed already for other technologies that I have, so I can’t
overwrite that.

How did you get the sqlite you do have? (Was it built for x86_64?)

What problem are you having with RVM?

On Tue, Aug 2, 2011 at 10:08 AM, Viaduct Productions
[email protected] wrote:

Anybody know what I should be doing? I am following the directions here:

http://www.iamseree.com/application-development/install-ruby-1-9-2-and-rails-3-1-0-rc-on-mac-os-x-snow-leopard

Cheers

rvm works fine here in Snow Leopard, check out the FAQ of RVM official
site
good luck


Twitter: @ghosTM55

Mechanism, not policy

On Aug 1, 2011, at 19:08, Viaduct Productions
[email protected] wrote:

ld: in /usr/local/lib/libsqlite3.dylib, missing required architecture x86_64 in
file for architecture x86_64
collect2: ld returned 1 exit status
make[1]: *** […/…/.ext/x86_64-darwin10.8.0/tcltklib.bundle] Error 1
make: *** [mkmain.sh] Error 1

sqlite is installed already for other technologies that I have, so I can’t
overwrite that.

You prolly compiled it for i386 and single architecture. Rebuild it for
both if you still need to link against anything else i386.

Hi there.

Installed with Lasso. I’m currently a Lasso developer.

RVM’s installation of 1.9.2 won’t work either, that’s what I meant to
say.


Rich in Toronto

Sorry, meant to say the RVM installation of 1.9.2 wasn’t working either.


Rich in Toronto

I have no control over this make and installation. So I can move ahead
with the 64 bit install and not worry about the tables?


Rich in Toronto

be lucky to use RVM.

On Tue, Aug 2, 2011 at 11:56 AM, Viaduct Productions <