1.8.7 doesn't work on Ubuntu


#1

Does anyone know how to get around this:

http://redmine.ruby-lang.org/issues/show/863

Thanks,
– Chad


#2

Chad W. wrote:

Does anyone know how to get around this:

Make sure to install every package under the sun before installing ruby
from source, perhaps?
-=r


#3

Hi,

In message “Re: 1.8.7 doesn’t work on Ubuntu”
on Thu, 7 May 2009 16:00:04 +0900, Chad W.
removed_email_address@domain.invalid writes:

|Also, I tried this after uninstalling the ruby that came with Ubuntu.
|Didn’t help. I also reinstalled the Ubuntu built-in ruby ssl package.
| Didn’t help.

Could you show us exact step to reproduce the problem, with all input
and errors? In addition, do you set any environment variables
e.g. RUBYOPT or RUBYPATH?

          matz.

#4

On Wed, May 6, 2009 at 11:37 PM, Roger P. removed_email_address@domain.invalid
wrote:

Make sure to install every package under the sun before installing ruby
from source, perhaps?

I’ve already installed everything that looks likely, the next step
would be to try to install every package with ‘ssl’ in the name.

BTW, looks like other people have had this issue with no resolution
either:

http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/305883
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/304053

Also, I tried this after uninstalling the ruby that came with Ubuntu.
Didn’t help. I also reinstalled the Ubuntu built-in ruby ssl package.
Didn’t help.


#5

On Thu, May 7, 2009 at 12:13 AM, Yukihiro M. removed_email_address@domain.invalid
wrote:

Yes! The patch you put on the ticket does seem to fix it! Thanks,
Matz…


#6

On Thu, 2009-05-07 at 13:49 +0900, Chad W. wrote:

Does anyone know how to get around this:

http://redmine.ruby-lang.org/issues/show/863

Thanks,
– Chad

Did you install libssl-dev?

Most of the time that errors like that occur on Ubuntu they are due to
the dev packages not being installed…

Matt