1.8.7 backward compatibility with 1.8.6

Hi,

Is ruby 1.8.7 on snow leopard backward compatible with ruby 1.8.6 on
leopard. I’d like to know if there are special known issues, that should
be taken care of when porting projects, based 1.8.6 leopard to 1.8.7
10.6? My project integrates RubyCocoa, which is a separate subject to
check, but currently the project, that worked in 1.8.6 enters an
infinite loop somewhere deep in RubyCocoa on 1.8.7 snow leopard. I’m
using the same 0.13.2 version in migration.

Thank you in advance
Nava

hm, ruby itself shouldn’t be a problem AFAIK. We had a thread about
1.8.7
some time ago and the general opinion was that it didn’t break anything
but
rather mostly add new features, thus it’s probably a cocoa issue.

Greetz!

2009/9/6 Nava C. [email protected]

Fabian S. wrote:

hm, ruby itself shouldn’t be a problem AFAIK. We had a thread about
1.8.7
some time ago and the general opinion was that it didn’t break anything
but
rather mostly add new features, thus it’s probably a cocoa issue.

Greetz!

2009/9/6 Nava C. [email protected]

You were right! There was an issue with RubyCocoa.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs