1.1RC and Lighttpd

I started what I thought was going to be a 30 minute project on the
train this morning to write a little timetracker for myself.

Amongst other things (don’t have a model called Task as it conflicts
with Rake at the moment, don’t have a model called Action as it
disappears in the hash when you submit a form :-), I had to use Webrick
as Lighty complained about an unknown variable CWD.

This looks to have been added to make the fcgi path absolute rather than
relative, but I get an error because it’s not set.

I can’t figure out how to do a fulltext search in Trac to see if it’s
been reported. A simple Browser find on the faults lists didn’t show up
‘CWD’ in the subject lines.

So any help on any of the following would be appreciated:

  1. Is this a known bug or should I report it? (rails fault list
    junkies?)
  2. Is it possible to do a fulltext search in Trac, if so, how ? (Trac
    experts ?)
  3. Is there a workaround? I suspect I just want to init th variable to
    RAILS_ROOT explicitly, but I’m not sure if the config file is missing an
    explicit variable set, or if CWD is a ‘magic’ variable thats just
    supposed to work, but isn’t. (Lighty users ?)

I’m on Tiger .5, using the 1.1RC gem, Ruby .4 and Lighty .7

A.

On Mar 24, 2006, at 4:07 AM, Alan F. wrote:

I started what I thought was going to be a 30 minute project on the
train this morning to write a little timetracker for myself.

Amongst other things (don’t have a model called Task as it conflicts
with Rake at the moment, don’t have a model called Action as it
disappears in the hash when you submit a form :-), I had to use
Webrick
as Lighty complained about an unknown variable CWD.

Check your version of Lighty. I believe the CWD thing is fairly new,
grab the latest.

-Scott

Scott B. wrote:

On Mar 24, 2006, at 4:07 AM, Alan F. wrote:

I started what I thought was going to be a 30 minute project on the
train this morning to write a little timetracker for myself.

Amongst other things (don’t have a model called Task as it conflicts
with Rake at the moment, don’t have a model called Action as it
disappears in the hash when you submit a form :-), I had to use
Webrick
as Lighty complained about an unknown variable CWD.

Check your version of Lighty. I believe the CWD thing is fairly new,
grab the latest.

-Scott

Thanks Scott. I was following the Hivelogic tutorial, so I suspect my
version (.8 rather than .7 as I originally posted) is out of date as I’d
have pasted the url rather than browsed for latest.

A.

Alan F. wrote:

Scott B. wrote:

Check your version of Lighty. I believe the CWD thing is fairly new,
grab the latest.

That sorted it. Thanks again.

A.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs