1.1.1 engine breaks with gem rails


#1

Posted this to the rails group as well. Found that upgrading to Rails
1.1.1 and the engines plugin 1.1.1 caused web server to not start. The
solution turned out as follows:

The following code is in the new version of engines.rb:

begin
require ‘rails_version’ # Rails 1.0, 1.1.0
rescue LoadError
require ‘rails/version’ # renamed as of Rails 1.1.1
end

but the exception from starting the web server is (Gem::Exception) from
the trace. Changing the above
to

begin
require ‘rails_version’ # Rails 1.0, 1.1.0
rescue
require ‘rails/version’ # renamed as of Rails 1.1.1
end

allows the web server to start.

Keith


#2

This error only seems to occur if you have BOTH Rails 1.1.0 and 1.1.1
gems installed (which is why I couldn’t replicate it before).

It has been fixed in the official release, please update or reinstall
your version of the Engines plugin.

Cheers

  • james

On 4/7/06, Keith L. removed_email_address@domain.invalid wrote:

end

http://lists.rails-engines.org/listinfo.cgi/engine-users-rails-engines.org

  • J *
    ~