Forum: Ruby Can't login to Rubyforge, just says "cookies must be enabled

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
05be5d6610e2c3f1780aa0e39e902e93?d=identicon&s=25 Farrel Lifson (Guest)
on 2007-02-28 23:16
(Received via mailing list)
I registered a new account on Rubyforge but can't seem to login. After
receiving the confirmation email and activating the account every time
I try to login I just get taken straight back to the login page. The
only message is above the user/password textboxes claiming "Cookies
must be enabled past this point. "  although cookies in my browser
(Firefox 2.0.0.2) are definitely enabled.

Is there something else I have to do to login?

Farrel
560c83ff6b6600e39315a1cf75b7c229?d=identicon&s=25 Tom Copeland (Guest)
on 2007-03-01 13:05
(Received via mailing list)
On Thu, 2007-03-01 at 07:15 +0900, Farrel Lifson wrote:
> I registered a new account on Rubyforge but can't seem to login. After
> receiving the confirmation email and activating the account every time
> I try to login I just get taken straight back to the login page. The
> only message is above the user/password textboxes claiming "Cookies
> must be enabled past this point. "  although cookies in my browser
> (Firefox 2.0.0.2) are definitely enabled.
>
> Is there something else I have to do to login?

Hi Farrel -

Hm, were you able to get this sorted out?  If not, please post a support
req here:

http://rubyforge.org/tracker/?atid=102&group_id=5&...

Thanks,

Tom
05be5d6610e2c3f1780aa0e39e902e93?d=identicon&s=25 Farrel Lifson (Guest)
on 2007-03-01 17:33
(Received via mailing list)
> Hi Farrel -
>
> Hm, were you able to get this sorted out?  If not, please post a support
> req here:
>
> http://rubyforge.org/tracker/?atid=102&group_id=5&...
>
> Thanks,
>
> Tom

Still have the same problem. Have posted a support request.

Farrel
181af584c3f0598b18cedfaf32b68eb5?d=identicon&s=25 Samantha (Guest)
on 2007-03-01 19:33
(Received via mailing list)
On 3/1/07, Farrel Lifson <farrel.lifson@gmail.com> wrote:
>
> Still have the same problem. Have posted a support request.
>
> Farrel
>
>

Have you tried another browser, just to be on the safe side?

--
Samantha

http://www.babygeek.org/

"Beware when the great God lets loose a thinker on this planet. Then all
things are at risk."
  --Ralph Waldo Emerson
05be5d6610e2c3f1780aa0e39e902e93?d=identicon&s=25 Farrel Lifson (Guest)
on 2007-03-01 20:25
(Received via mailing list)
On 01/03/07, Samantha <rubygeekgirl@gmail.com> wrote:
>
I've only got Gecko based browsers on my machine (Firefox, Mozilla and
Epiphaby) and they all do the same thing. My Firefox 2.0.0.2 install
at work (on XP) however logs in fine.

Farrel
181af584c3f0598b18cedfaf32b68eb5?d=identicon&s=25 Samantha (Guest)
on 2007-03-01 20:35
(Received via mailing list)
On 3/1/07, Farrel Lifson <farrel.lifson@gmail.com> wrote:
>
> On 01/03/07, Samantha <rubygeekgirl@gmail.com> wrote:
>
> I've only got Gecko based browsers on my machine (Firefox, Mozilla and
> Epiphaby) and they all do the same thing. My Firefox 2.0.0.2 install
> at work (on XP) however logs in fine.
>
> Farrel
>
>
Yikes.  That tells me that there is a common component on your one
machine
that is causing the issue.  If you are able to login with your proper
credential at work, something is up with your browser.  If you want, you
can
email me offlist and we can see if we can figure something out.

Samantha


--
Samantha

http://www.babygeek.org/

"Beware when the great God lets loose a thinker on this planet. Then all
things are at risk."
  --Ralph Waldo Emerson
05be5d6610e2c3f1780aa0e39e902e93?d=identicon&s=25 Farrel Lifson (Guest)
on 2007-03-01 20:37
(Received via mailing list)
On 01/03/07, Farrel Lifson <farrel.lifson@gmail.com> wrote:
> I've only got Gecko based browsers on my machine (Firefox, Mozilla and
> Epiphaby) and they all do the same thing. My Firefox 2.0.0.2 install
> at work (on XP) however logs in fine.
>
> Farrel

I even tried links and it's not working.

Farrel
Fd22ee3cfc7dac283ce8e451af324f7d?d=identicon&s=25 Chad Perrin (Guest)
on 2007-03-01 22:29
(Received via mailing list)
On Fri, Mar 02, 2007 at 04:36:40AM +0900, Farrel Lifson wrote:
> On 01/03/07, Farrel Lifson <farrel.lifson@gmail.com> wrote:
> >I've only got Gecko based browsers on my machine (Firefox, Mozilla and
> >Epiphaby) and they all do the same thing. My Firefox 2.0.0.2 install
> >at work (on XP) however logs in fine.
> >
> >Farrel
>
> I even tried links and it's not working.

That sounds like a firewall issue of some sort, though I'm not entirely
sure how one would go about configuring a firewall to block any cookies.
It may also, I suppose, be related to some kind of read/write permission
issue.

I'm grasping at straws, really.  Your problem (that no browser, whether
Gecko-based GUI or console-based TUI, will interact properly with the
site) is on the weird side of the line.
560c83ff6b6600e39315a1cf75b7c229?d=identicon&s=25 Tom Copeland (Guest)
on 2007-03-01 23:00
(Received via mailing list)
> That sounds like a firewall issue of some sort, though I'm
> not entirely sure how one would go about configuring a
> firewall to block any cookies. It may also, I suppose, be
> related to some kind of read/write permission issue.
>
> I'm grasping at straws, really.  Your problem (that no
> browser, whether Gecko-based GUI or console-based TUI, will
> interact properly with the
> site) is on the weird side of the line.

Yeah, it's weird indeed... and as Chad said, since it doesn't happen to
you at work, it does seem like a client-side problem.  Not sure if it's
browser or firewall, though.... odd.

Yours,

Tom
Fd22ee3cfc7dac283ce8e451af324f7d?d=identicon&s=25 Chad Perrin (Guest)
on 2007-03-02 00:30
(Received via mailing list)
On Fri, Mar 02, 2007 at 06:59:47AM +0900, Tom Copeland wrote:
> > That sounds like a firewall issue of some sort, though I'm
> you at work, it does seem like a client-side problem.  Not sure if it's
> browser or firewall, though.... odd.

Perhaps more to the point, it's clearly outside of the browser itself,
since links doesn't have any relation to Firefox or other Gecko-based
browsers.  That makes it a system configuration issue or a network
configuration issue.  Is there another computer at the same network
location you could use to test for the ability to log in?  Is there some
way you could try logging in from the same computer but outside of
whatever you're using for a network gateway?  Either of these two
tactics would help narrow down the problem somewhat, so that you should
be able to thereby determine whether it's a system or network issue.
181af584c3f0598b18cedfaf32b68eb5?d=identicon&s=25 Samantha (Guest)
on 2007-03-02 00:59
(Received via mailing list)
I emailed with him a few times offlist... He's in Gentoo in the GNOME
Environment.  I thought of permission issues, so suggested that he run
firefox as root, but looks like he tried it and it didn't work.

It definitely sounds like a system or network issue, though.

Maybe something funky in the .mozilla folder underneath the
/home/username directory.

I'm not sure if all the Mozilla browsers like Seamonkey, Epiphany, and
Firefox use that directory or not.
--
Samantha

http://www.babygeek.org/

"Beware when the great God lets loose a thinker on this planet. Then
all things are at risk."
  --Ralph Waldo Emerson
Fd22ee3cfc7dac283ce8e451af324f7d?d=identicon&s=25 Chad Perrin (Guest)
on 2007-03-02 01:08
(Received via mailing list)
On Fri, Mar 02, 2007 at 08:58:24AM +0900, Samantha wrote:
> I emailed with him a few times offlist... He's in Gentoo in the GNOME
> Environment.  I thought of permission issues, so suggested that he run
> firefox as root, but looks like he tried it and it didn't work.
>
> It definitely sounds like a system or network issue, though.
>
> Maybe something funky in the .mozilla folder underneath the
> /home/username directory.

He reported trying to connect via the links browser, which also did not
work.  As such, it seems unlikely that it has anything to do with the
operation of any of his browser applications.
05be5d6610e2c3f1780aa0e39e902e93?d=identicon&s=25 Farrel Lifson (Guest)
on 2007-03-02 10:44
(Received via mailing list)
On 02/03/07, Chad Perrin <perrin@apotheon.com> wrote:
> He reported trying to connect via the links browser, which also did not
> "A script is what you give the actors.  A program
> is what you give the audience." - Larry Wall
>
>

I posted a request on a local OSS mailing list (I'm in South Africa by
the way) asking if anyone is having the same issues and I got a reply
from a person having the same issue. I'm not sure if our beloved
Telkom (worst telco in the world) is doing something wonky with SSL
packets (they have a penchant for traffic shaping) but that doesn't
explain why other sites usin SSL works fine or why I am able to log in
at work (which is a large SA corporation).

Farrel
05be5d6610e2c3f1780aa0e39e902e93?d=identicon&s=25 Farrel Lifson (Guest)
on 2007-03-02 11:01
(Received via mailing list)
On 02/03/07, Farrel Lifson <farrel.lifson@gmail.com> wrote:
> >
> > CCD CopyWrite Chad Perrin [ http://ccd.apotheon.org ]
> explain why other sites usin SSL works fine or why I am able to log in
> at work (which is a large SA corporation).
>
> Farrel

I'm beginning to suspect that this is being caused by Telkom's
transparent proxy that most SA HTTP internet traffic goes through.
From the local OSS mailing list it seems it has caused issues before
because it gets blacklisted by sites.

Farrel
19605c7ede229e507e894865308a6d53?d=identicon&s=25 Gustav Paul (Guest)
on 2007-03-02 11:05
(Received via mailing list)
Farrel Lifson wrote:
>>
>> CCD CopyWrite Chad Perrin [ http://ccd.apotheon.org ]
> explain why other sites usin SSL works fine or why I am able to log in
> at work (which is a large SA corporation).
>
> Farrel
>
>
I'm in South Africa too (Stellenbosch) and have the same issue. I've
tested it in Firefox 2.0 in both Windows XP and openSuSE 10.2 and both
show this behaviour. I have found that after several attempts I usually
get a page or so further (and the cookie gets set properly), but the
problem resurfaces a click or two later (and the cookie is suddenly
vanished).

Cheers,
Gustav Paul
560c83ff6b6600e39315a1cf75b7c229?d=identicon&s=25 Tom Copeland (Guest)
on 2007-03-02 15:32
(Received via mailing list)
On Fri, 2007-03-02 at 19:04 +0900, Gustav Paul wrote:
> I'm in South Africa too (Stellenbosch) and have the same issue. I've
> tested it in Firefox 2.0 in both Windows XP and openSuSE 10.2 and both
> show this behaviour. I have found that after several attempts I usually
> get a page or so further (and the cookie gets set properly), but the
> problem resurfaces a click or two later (and the cookie is suddenly
> vanished).

Yikes. What a bummer...

Tom
181af584c3f0598b18cedfaf32b68eb5?d=identicon&s=25 Samantha (Guest)
on 2007-03-02 15:43
(Received via mailing list)
On Thursday 01 March 2007 07:07:52 pm Chad Perrin wrote:
> He reported trying to connect via the links browser, which also did not
> work.  As such, it seems unlikely that it has anything to do with the
> operation of any of his browser applications.

:) I thought he said he had even tried using *links*.  (as in a href=
Hyperlinks, as the Lynx browswer isn't spelled links.) :)

It's obviously a network issue after seeing that it affects more people
in the
area...

--
Samantha

http://www.babygeek.org/

"Beware when the great God lets loose a thinker on this planet. Then
all things are at risk."
  --Ralph Waldo Emerson
97550977337c9f0a0e1a9553e55bfaa0?d=identicon&s=25 Jan Svitok (Guest)
on 2007-03-02 15:53
(Received via mailing list)
On 3/2/07, Gustav Paul <gustav@rails.co.za> wrote:
> >> > /home/username directory.
> >> --
> > packets (they have a penchant for traffic shaping) but that doesn't
> problem resurfaces a click or two later (and the cookie is suddenly
> vanished).
>
> Cheers,
> Gustav Paul

Maybe some other proxy (tor?) or a ssh tunnel could solve this? Try
e.g. http://www.rootshell.be/
6cd89bb751e19c97e17b026e88c08da5?d=identicon&s=25 Deniz Dogan (Guest)
on 2007-03-02 16:05
(Received via mailing list)
Samantha wrote:
> :) I thought he said he had even tried using *links*.  (as in a href=
> Hyperlinks, as the Lynx browswer isn't spelled links.) :)

There is an alternative browser to lynx, called elinks, or sometimes
just *links*.

--Deniz Dogan
Fd22ee3cfc7dac283ce8e451af324f7d?d=identicon&s=25 Chad Perrin (Guest)
on 2007-03-02 20:10
(Received via mailing list)
On Fri, Mar 02, 2007 at 11:42:31PM +0900, Samantha wrote:
> >
> > He reported trying to connect via the links browser, which also did not
> > work.  As such, it seems unlikely that it has anything to do with the
> > operation of any of his browser applications.
>
> :) I thought he said he had even tried using *links*.  (as in a href=
> Hyperlinks, as the Lynx browswer isn't spelled links.) :)

Debian:
  $ apt-cache show links
  Package: links
  Priority: optional
  Section: web
  Installed-Size: 936
  Maintainer: Peter Gervai <grin@tolna.net>
  Architecture: i386
  Version: 0.99+1.00pre12-1
  Provides: www-browser
  Depends: libc6 (>= 2.3.2.ds1-4), libgpmg1 (>= 1.19.6-1)
  Conflicts: links-ssl (<< 0.99-1.1)
  Filename: pool/main/l/links/links_0.99+1.00pre12-1_i386.deb
  Size: 384846
  MD5sum: d4670831b63a80e4d4fbe01b1155350d
  SHA1: 52209622cf4c9e9c4d9d59c652370bcca4cfc2f6
  SHA256:
db6f879de6afbd6de526569eda0fb85cf8949fa7a3730d8854885871c9c02ead
  Description: Character mode WWW browser
   Links is a lynx-like character mode browser. It includes support
   for rendering tables and frames, features background downloads, can
   display colors and has many other features.


FreeBSD:
  $ cat /usr/ports/www/links/pkg-descr
  Lynx-like WWW browser with text and graphics modes with many features
  like displaying tables, menus, etc.

  WWW: http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/

  - Michael Vasilenko
  acid@stu.cn.ua


>
> It's obviously a network issue after seeing that it affects more people in the
> area...

I'm beginning to think it's an ISP issue, yeah.
Fd22ee3cfc7dac283ce8e451af324f7d?d=identicon&s=25 Chad Perrin (Guest)
on 2007-03-02 20:12
(Received via mailing list)
On Sat, Mar 03, 2007 at 12:05:06AM +0900, Deniz Dogan wrote:
> Samantha wrote:
> >:) I thought he said he had even tried using *links*.  (as in a href=
> >Hyperlinks, as the Lynx browswer isn't spelled links.) :)
>
> There is an alternative browser to lynx, called elinks, or sometimes
> just *links*.

Technically, links and elinks are two separate applications -- in much
the same way that vi and Vim are two separate applications.  Of course,
the difference from my perspective is "I use Vim.  When someone asks if
I use vi or emacs, I'll answer vi."  Thus, I guess the difference is
sorta academic.
181af584c3f0598b18cedfaf32b68eb5?d=identicon&s=25 Samantha (Guest)
on 2007-03-02 20:57
(Received via mailing list)
On 3/2/07, Chad Perrin <perrin@apotheon.com> wrote:
>   Maintainer: Peter Gervai <grin@tolna.net>
>   Description: Character mode WWW browser
>   WWW: http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/
> I'm beginning to think it's an ISP issue, yeah.
>
> --
> CCD CopyWrite Chad Perrin [ http://ccd.apotheon.org ]
> "The ability to quote is a serviceable
> substitute for wit." - W. Somerset Maugham
>
>
Nice!  Ya learn something new everyday. :)

I'll have to check Links out!
--
Samantha

http://www.babygeek.org/

"Beware when the great God lets loose a thinker on this planet. Then all
things are at risk."
  --Ralph Waldo Emerson
05be5d6610e2c3f1780aa0e39e902e93?d=identicon&s=25 Farrel Lifson (Guest)
on 2007-03-05 18:46
(Received via mailing list)
I've managed to solve the problem! It was an issue with Telkom's
transparent proxying. I managed to find a list of alternate Telkom
SAIX proxies at http://en.wikipedia.org/wiki/User:Dewet/SAIX_proxies
and one of them worked! For other SA users who can't log in to
Rubyforge check out that page and find one that works for you.

Thanks for all your help.

Farrel
B73dde621deaf42324793d8517b0b78c?d=identicon&s=25 Greg Hurrell (Guest)
on 2007-03-08 03:25
(Received via mailing list)
For what it's worth, I can't log in to Rubyforge either.

I've tried using Safari and Firefox but I keep getting redirected back
to the login page. This is in Spain, I'm not aware of any transparent
proxies set up by my ISP (Telefónica), and cookies are turned on. I
was previously able to log in fine but over the last few days no
luck...

Greg
669b7046f02e5dfc4bda4421f1069731?d=identicon&s=25 Alex Fenton (Guest)
on 2007-03-12 23:51
(Received via mailing list)
Farrel Lifson wrote:
> I've managed to solve the problem! It was an issue with Telkom's
> transparent proxying. I managed to find a list of alternate Telkom
> SAIX proxies at http://en.wikipedia.org/wiki/User:Dewet/SAIX_proxies
> and one of them worked! For other SA users who can't log in to
> Rubyforge check out that page and find one that works for you.

Anyone else in the UK on NTL/Virgin Media having this problem as of the
last week or two? - and any suggestions for a fix?

thanks
alex
163755a5d3a5c57bd79c4f41bdda7a22?d=identicon&s=25 Clifford Heath (Guest)
on 2007-03-14 12:25
(Received via mailing list)
Greg Hurrell wrote:
> For what it's worth, I can't log in to Rubyforge either.
> I've tried using Safari and Firefox but I keep getting redirected back
> to the login page.

I had the same problem here, but if you entered the right password,
you have the login cookie and are in fact logged in. It's just that
the page didn't direct you back where you wanted to be. If you enter
the RubyForge URL again, you'll find that you are already logged in.

Clifford Heath.
669b7046f02e5dfc4bda4421f1069731?d=identicon&s=25 Alex Fenton (Guest)
on 2007-03-14 19:50
(Received via mailing list)
Clifford Heath wrote:

> I had the same problem here, but if you entered the right password,
> you have the login cookie and are in fact logged in. It's just that
> the page didn't direct you back where you wanted to be. If you enter
> the RubyForge URL again, you'll find that you are already logged in.

With a bit more poking, that's not quite what's happening for me (on NTL
UK, which uses transparent proxies).

When I login, the session cookie is set correctly, but then immediately
after, rubyforge sends a 'deleted' cookie to expire the login. If I
accept the first cookie but reject the subsequent ones I can wriggle by,
but it's obviously not right.

I've tried explicitly setting my proxy to one only of the five possible
ones, but thsi doesn't help. I've also confirmed  that the proxies are
setting the X-Forwarded-For http header to my IP address, so there
should be a unique IP to latch onto.

 I'm stumped and would appreciate any help - especially b/c we're
currently trying to put out a new release of wxruby....

cheers
alex
This topic is locked and can not be replied to.