Forum: Ruby on Rails SCGI / Apache 2 / Win32 not working / no output / help?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
3203ed0e608d3bfae1e31282e629ffa2?d=identicon&s=25 peter.fitzgibbons (Guest)
on 2005-11-12 12:49
(Received via mailing list)
Hello all,

I'm trying to use SCGI on Apache2/Win32. I followed your apache2 wiki
links
as far as possible... but I only "connection refused" on
http://127.0.0.1:82/ or http://localhost:82.

Do you have any other resources for Apache/Win32/SCGI config ?

This is the end of my ./conf/httpd.conf

SCGIMount / 127.0.0.1:9999 <http://127.0.0.1:9999>

<VirtualHost 127.0.0.1:82 <http://127.0.0.1:82>>
AddDefaultCharset utf-8
ServerName www.yourdomain
DocumentRoot C:/ruby/dev/buildview2/public
ErrorDocument 500 /500.html
ErrorDocument 404 /404.html
# handle all requests throug SCGI
SCGIMount / 127.0.0.1:9999 <http://127.0.0.1:9999>
# matches locations with a dot following at least one more characters,
that
is, things like *,html, *.css, *.js, which should be delivered directly
from
the filesystem
<LocationMatch \..+$>
# don't handle those with SCGI
SCGIHandler Off
</LocationMatch>
<Directory C:/ruby/dev/buildview2/public/>
Options +FollowSymLinks
Order allow,deny
allow from all
</Directory>
</VirtualHost>


--
Peter Fitzgibbons
E2489efc6ec10ec818b71965909ea109?d=identicon&s=25 jinslee (Guest)
on 2005-11-12 12:49
(Received via mailing list)
I have a httpd.conf similar to yours, and don't have the problems you
described. Did you configure your scgi correctly using scgi_ctrl and run
scgi_service?

Jin
14e7346c7db5626171fe7cd40423a289?d=identicon&s=25 rowan (Guest)
on 2005-11-12 12:49
(Received via mailing list)
You probably did what I did and not realise you have to install
scgi_rails.
You have to have the scgi_rails deal started and running as a service
before
the mod_scgi deal will work.



Look at the readme on HYPERLINK
"http://www.zedshaw.com/projects/scgi_rails/rdoc/in...
aw.com/projects/scgi_rails/rdoc/index.html.



If again like me you get errors when trying to run scgi_ctrl (from
memory),
youâ??ll need to use gem install <missing dependency> . youâ??ll get the
missing
dependency name when you try starting scgi_ctrl. There was about 3 or 4
of
them I had to install.



Kind Regards,

Rowan



   _____

From: rails-bounces@lists.rubyonrails.org
[mailto:rails-bounces@lists.rubyonrails.org] On Behalf Of Peter
Fitzgibbons
Sent: Wednesday, November 09, 2005 6:55 AM
To: rails@lists.rubyonrails.org
Subject: [Rails] SCGI / Apache 2 / Win32 not working / no output / help?



Hello all,

I'm trying to use SCGI on Apache2/Win32.  I followed your apache2 wiki
links
as far as possible... but I only "connection refused" on HYPERLINK
"http://127.0.0.1:82/"http://127.0.0.1:82/ or HYPERLINK
"http://localhost:82"http://localhost:82.

Do you have any other resources for Apache/Win32/SCGI config ?

This is the end of my ./conf/httpd.conf

SCGIMount / HYPERLINK "http://127.0.0.1:9999"127.0.0.1:9999

<VirtualHost HYPERLINK "http://127.0.0.1:82"127.0.0.1:82>
    AddDefaultCharset utf-8
    ServerName www.yourdomain
    DocumentRoot C:/ruby/dev/buildview2/public
    ErrorDocument 500 /500.html
    ErrorDocument 404 /404.html
    # handle all requests throug SCGI
    SCGIMount / HYPERLINK "http://127.0.0.1:9999"127.0.0.1:9999
    # matches locations with a dot following at least one more
characters,
that is, things like   *,html, *.css, *.js, which should be delivered
directly from the filesystem
    <LocationMatch \..+$>
        # don't handle those with SCGI
        SCGIHandler Off
    </LocationMatch>
    <Directory C:/ruby/dev/buildview2/public/>
        Options +FollowSymLinks
        Order allow,deny
        allow from all
    </Directory>
</VirtualHost>
This topic is locked and can not be replied to.