Forum: Ruby on Rails Cannot find gem for Rails

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Ab4f2861e1f40c2092c09ba993a87462?d=identicon&s=25 (Guest)
on 2007-02-21 18:44
(Received via mailing list)
I've been working with Ruby on Rails through Locomotive for the past
year or so, but for this particular task, I need to run a Rails
application outside the Locomotive environment. I can create a Rails
application just fine, using "rails my_app", and it boots up properly
in Mongrel, but whenever I run rake to migrate my database, I get the
following error:

 Cannot find gem for Rails ~>
    Install the missing gem with 'gem install -v=1.2.2 rails', or
    change environment.rb to define RAILS_GEM_VERSION with your
desired version.

I have tried everything I can think of: re-installing Rails with gems
by copying-and-pasting the line above into the terminal (as superuser
of course), pasting the rails_gem ='rails'... line
from my boot.rb into irb (which does execute correctly), but I still
can't get rake to run. Does anyone have any tips?

Thank you very much,

System configuration:

G4 PowerBook, with OS X 10.4.8.
I've installed Ruby, Gems, and Rails:
  rschenk$ ruby -v
  ruby 1.8.5 (2006-12-25 patchlevel 12) [powerpc-darwin8.8.0]
  rschenk$ gem -v
  rschenk$ rails -v
  Rails 1.2.2

When I type ./script/about:
  About your application's environment
  Ruby version                 1.8.5 (powerpc-darwin8.8.0)
  RubyGems version             0.9.2
  Rails version                1.2.2
  Active Record version        1.15.2
  Action Pack version          1.13.2
  Action Web Service version   1.2.2
  Action Mailer version        1.3.2
  Active Support version       1.4.1
  Application root             /Users/rschenk/Desktop/
  Environment                  development
  Database adapter             mysql
This topic is locked and can not be replied to.