Forum: Ruby on Rails Trouble Running my app

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Ed78a8e4ce036b46633e7385addea006?d=identicon&s=25 Matt (Guest)
on 2007-02-21 01:13
(Received via mailing list)
Im having trouble running my app :(

I get the error message application error rails failed to start

So not being a total idiot(I may regret saying that) i checked the
logs and there was a problem in the server log only. It stated
premature end to headers for dispatch.cgi

I then tried to run the dispatch.cgi from a terminal expecting to see
error 500 but instead i get this:

matt@as public]# ./dispatch.cgi
Status: 400 Bad Request
dependencies.rb:405:in `to_constant_name': Anonymous modules have no
name to be referenced by (ArgumentError)
 from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/
active_support/dependencies.rb:215:in `qualified_name_for'
 from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/
active_support/dependencies.rb:477:in `const_missing'
 from /usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:117:in
 from /usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:51:in
 from ./dispatch.cgi:10

Which means nothing to me and google isn't bringing anything up :(

I have tried to reinstall rails and also updated gems and again no

Any clues at all would be most helpful

Cheers in advance

Ed78a8e4ce036b46633e7385addea006?d=identicon&s=25 Matt (Guest)
on 2007-02-21 10:15
(Received via mailing list)
Has nobody any ideas how I should go about solving this?

Its really annoying me now:(
Ed78a8e4ce036b46633e7385addea006?d=identicon&s=25 Matt (Guest)
on 2007-02-21 15:24
(Received via mailing list)
Please im going insane. if there is anymore information that is
required please dont hesitate to ask I will provide it. I just cant
see the problem and my efforts with google have been exhausted.

2b891e820c238ded365d035771603f21?d=identicon&s=25 Bill Walton (Guest)
on 2007-02-21 16:02
(Received via mailing list)
Hi Matt,

Try the rails-deploy list with this question.  It looks more like an
infrastructure question.  Can you start any Rails app?  If you haven't
it, just create a small table, then scaffold a model / controller on it
work up from there.

Sorry I can't be more help.

Ed78a8e4ce036b46633e7385addea006?d=identicon&s=25 Matt (Guest)
on 2007-02-21 16:12
(Received via mailing list)
Cheers Bill didn't know such a place existed thanks.

Incidently I can get the scaffold working etc, and also can run the
webrick server too.

Just can't run the main apache way.

Thanks again
B09a3f6cdc4797532647d2d264b5df49?d=identicon&s=25 Jodi Showers (jshow)
on 2007-02-21 16:27
(Received via mailing list)
On 21-Feb-07, at 10:12 AM, Matt wrote:

> On 21 Feb, 15:00, "Bill Walton" <> wrote:
>> Bill

as Bill said, try simple things first Matt.

build a new project, and serve that from apache.

If that doesn't work,  and it serves from webrick, then you've got an
apache config problem - which might include file permissions, etc.

If it does, then you're likely dealing with an old (pre 1.2) project?
did you run "rake rails:update"  - does your environment.rb set a
specific rails version to run?

narrowing down your scope of concerns, will help you post info that
can help us help you. The deploy list has a bunch of crazy-deploy-fu
people (who are likely here as well), but the signal-to-noise ratio
is higher there.

This topic is locked and can not be replied to.