Forum: Rails deployment log does not exist...

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Bc0e53263853a850ba3e63bcb8c6a2f3?d=identicon&s=25 Brian LeRoux (Guest)
on 2007-02-20 06:22
(Received via mailing list)
I'm getting the following error when I stop mongrel..... I know its
running but I need the log files. It appears the log isn't being
created / written to. I this message:

!!! PID file log/ does not exist.  Not running?

This is my mongrel_cluster.yml
cwd: /var/rails/soca/current
port: "8000"
environment: production
pid_file: log/
servers: 2

.....and I've the following permissions on the directory:

drwxrwxrwx   2 bleroux root 4096 Feb 19 16:44 log

Which is here:

[root@server1 current]# pwd

Any ideas??
C381828d1907912eab30cbe38d5ea245?d=identicon&s=25 Aníbal Rojas (Guest)
on 2007-02-20 12:54
(Received via mailing list)

    Have you tried using a full path for: pid_file: ?

Aníbal Rojas
E7cff3cfd41c495e1012227d7dc24202?d=identicon&s=25 Luis Lavena (luislavena)
on 2007-02-20 14:15
(Received via mailing list)
On 2/20/07, Brian LeRoux <> wrote:
> cwd: /var/rails/soca/current
> Which is here:
> [root@server1 current]# pwd
> /var/rails/soca/current
> Any ideas??

It is a known bug. You should specify full path log and pid files for

Luis Lavena
Multimedia systems
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi
Bc0e53263853a850ba3e63bcb8c6a2f3?d=identicon&s=25 Brian LeRoux (Guest)
on 2007-02-20 20:05
(Received via mailing list)
Ok ---thanks guys, I tried specifying a full path for the pid but still
no go.
This must be a permissions issue.. but the directory is open to the
world to modify. This is odd.
83d161c2d186f9664b08f982522ddca6?d=identicon&s=25 Lance (Guest)
on 2007-02-21 16:56
(Received via mailing list)
This may be a silly question, but does the pid file actually exist?
Have you checked yourself?

I'm running into an issue like this myself, which seems to be
triggered by a slow shutdown of one thread (on port 8001, say).
Capistrano doesn't wait for the shutdown and tries to do a restart,
but when the new thread on 8001 starts it can't write the pid file
because the old one is still shutting down. Then the next time I do a
rake deploy, the pid file doesn't exist and I lose touch with the

At least, that's my best current theory.
Bc0e53263853a850ba3e63bcb8c6a2f3?d=identicon&s=25 Brian LeRoux (Guest)
on 2007-02-21 22:39
(Received via mailing list)
I finally figured it was permissions issues the whole time... which is
my dumb. =) Runs like a champ now!
6a2f7f7a997fab1dbf815d155cca50ee?d=identicon&s=25 (Guest)
on 2007-02-23 19:32
(Received via mailing list)
I am having this exact same issue, and perms for log/ seem correct:

kmarsh@host:shared$ ll
total 20K
drwxr-xr-x   3 kmarsh 4.0K Feb 15 01:36 assets/
drwxrwxrwx   2 kmarsh 4.0K Feb 23 14:36 log/
drwxr-xr-x 595 www    8.0K Feb 23 18:22 photos/
drwxrwxr-x   2 kmarsh 4.0K Dec 11 16:06 system/

Any ideas?
Bc0e53263853a850ba3e63bcb8c6a2f3?d=identicon&s=25 Brian LeRoux (Guest)
on 2007-02-23 20:48
(Received via mailing list)
Can I see your mongrel config?
0ff4b2f49c3df249959a4560c0e16510?d=identicon&s=25 (Guest)
on 2007-02-26 21:02
(Received via mailing list)
Brian you mention it being a known bug, is the fact that sometimes
when restarting mongrel clusters I will get an error stating that the
PID already exists?

Almost like the restart process didn't give the mongrels enough time
to shutdown before attempting to start them up again.
This topic is locked and can not be replied to.