Forum: Ruby on Rails DL driver for sqlite3-ruby is deprecated and will be removed

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
4c3edba422163f461070c1d32c84a1f8?d=identicon&s=25 Rob Park (Guest)
on 2007-02-15 06:07
(Received via mailing list)
Hi everybody, been a while since I posted here (I think I unsubscribed
back in the 0.12 days...)

Anyway, I'm having a slight issue with rails here. Nothing is broken
but I'm getting this warning message and I'd like to fix the issue
before something explodes later on. This is the error message:

The DL driver for sqlite3-ruby is deprecated and will be removed
in a future release. Please update your installation to use the
Native driver.

I get this message mostly when running 'rake test', but I also see it
every now and then in the webrick output. I just updated to the latest
rails using rubygems, but I'm running on MacOSX Tiger which has an
older sqlite3 installation (v. 3.1.3 compared to the latest which is
3.3.13). I'm a bit stuck with the software that ships with Tiger as I
made poor partitioning choices that have left me with not enough free
space to install the developer tools, which are necessary for
compiling and installing newer versions of many things.

I'm not sure what it means by using the 'native' driver ... I followed
the instructions here:
HowtoUseSQLite and it explained about choosing the highest-numbered
"ruby" driver. Is this now wrong?

I suspect this issue is just due to the older sqlite3 version, which
will go away when I reformat for Leopard, leaving enough space for the
developer tools this time around. Oops ;)

If anybody has any insight on this issue, it'd be appreciated. Thanks.
This topic is locked and can not be replied to.