Forum: Ruby on Rails Missing template isn't missing

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Abfecec49e4871d38bfeedf7590c06ed?d=identicon&s=25 Milo Thurston (milo)
on 2007-01-31 17:18
I have just added a new method to a controller, and though all the
pre-existing methods are working as expected the new ones do not. I get
the following error:

Missing template
script/../config/../app/views/repository/new_method.rhtml

The path given above is correct relative to the application's base
directory (not the public_html). The view is present in the
app/views/repository directory and has the correct name, suffix and
content. Even stranger is that if I remove views relating to the working
methods then they still keep working...
The problem seems to be unrelated to whether I use the full url or the
ones mapped in config/routes.rb, which has such lines as:

map.connect '/new_method', :controller => 'repository', :action =>
'new_method'

This problem has appeared when developing with WEBrick. Can anyone
suggest what the cause might be?
10a8337cf8879d37affd54e1cab4d79e?d=identicon&s=25 Andy Koch (Guest)
on 2007-01-31 19:40
(Received via mailing list)
are you working in development mode?  rather than production mode

alternatively, have you tried restarting the WEBrick?

/ak

Milo Thurston schrieb:
Abfecec49e4871d38bfeedf7590c06ed?d=identicon&s=25 milo (Guest)
on 2007-01-31 22:03
Andy Koch wrote:
> are you working in development mode?  rather than production mode

I've been running it in development mode.

> alternatively, have you tried restarting the WEBrick?

I've re-started it a few times and it does not
seem to have made any difference, which is very odd.
Abfecec49e4871d38bfeedf7590c06ed?d=identicon&s=25 Milo Thurston (milo)
on 2007-02-01 13:08
Finally fixed it. I never did find the cause, but upgrading Rails and
components to 1.2.1 got it working again.
This topic is locked and can not be replied to.