Forum: Ruby on Rails CSV::Writer with Rails 1.2.1

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
5f3d52658aafcf0aabe76a5147e8909f?d=identicon&s=25 Tom (Guest)
on 2007-01-31 01:52
(Received via mailing list)
Is anyone else having problems generating CSV files after upgrading to

The error looks like this:

  uninitialized constant MyController::CSV
dependencies.rb:478:in `const_missing'

It worked fine until the 1.2.1 upgrade!

C4dc94c893471878a105761a9207f29b?d=identicon&s=25 Zack Chandler (Guest)
on 2007-01-31 01:57
(Received via mailing list)
On 1/30/07, Tom <> wrote:
> It worked fine until the 1.2.1 upgrade!
> Thanks!
> Tom

Are you explicitly requiring csv?

require 'csv'
class MyController < ApplicationController

Zack Chandler
5f3d52658aafcf0aabe76a5147e8909f?d=identicon&s=25 Tom (Guest)
on 2007-01-31 02:00
(Received via mailing list)
Thanks Zack!  I didn't think about explicitly requiring it, but that
did the trick!

This topic is locked and can not be replied to.