Forum: Ruby on Rails No reaction from memcached

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
01c56ec01516ed2ae5c4cdac24439a25?d=identicon&s=25 (Guest)
on 2007-01-30 18:48
(Received via mailing list)
I've been following the instructions here
articles/read/716 on how to get started with memcached.

Starting up ./script/console production I get at couple of deprecation

./script/console production
Loading production environment.
DEPRECATION WARNING: model is deprecated and will be removed from
Rails 2.0  See for details.
(called from ./script/../config/../config/../app/controllers/
DEPRECATION WARNING: depend_on is deprecated and will be removed from
Rails 2.0  See for details.
(called from model_without_deprecation at /usr/lib/ruby/gems/1.8/gems/

ActiveRecord instances load just fine but I get no indication that any
caching is taking place. I get no output from my memcached-process,
nothing in the rails logs and nothing on the console says anything
about caching.

I guess that I have a config error somewhere or a version mismatch.

Here's what I have at the end of environment.rb
CACHE = 'localhost:11211', :namespace => 'my_rails_app'

I've also tried these settings with the same result:

require 'cached_model'

memcache_options = {
  :c_threshold => 10_000,
  :compression => true,
  :debug => false,
  :namespace => 'my_rails_app',
  :readonly => false,
  :urlencode => false

CACHE = memcache_options
CACHE.servers = 'localhost:11211'

Here's my installed versions of the relevant gems:

rails (1.2.1,
cached_model (1.3.1,
memcache-client (1.2.0,

I've done some googling but I'm at a loss about how to troubleshoot
this further.

Any ideas?
This topic is locked and can not be replied to.