Forum: Ruby on Rails SOAP4R Error in Rails

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
2e3d01ef4f4cb07809aaacf837b0d006?d=identicon&s=25 Alex Amat (alexamat)
on 2007-01-29 15:02
Hi all

I have a ruby script that calls a web service which works just fine,
However when i try to use the same code from a rails model I get the
following error:

uninitialized constant SOAP::Mapping::EncodedRegistry

I have tried to load the gem soap4r from both the model and the
config/environment.rb files but i still get the same error

Any ideas on what I'm doing wrong ???

Fd5b8048d157a919043272d6292cb2b1?d=identicon&s=25 alex (Guest)
on 2007-02-01 12:02
(Received via mailing list)
Try posting your question on You might get your answer

On Jan 29, 3:02 pm, Alex Amat <>
43b0e87ab26acf70728003f0ad49a7f8?d=identicon&s=25 SHiBuMi (Guest)
on 2007-03-17 22:43
(Received via mailing list)

It seems that when you 'require' soap4r, it conflicts with Ruby's soap
library and Rails tries to use Ruby's soap library instead of soap4r.

Copy the folder \ruby\gems\1.8\gems\soap4r-\lib\soap to
\ruby\lib\ruby\1.8\soap and try again. It worked for me.

Hope this helps
This topic is locked and can not be replied to.