Forum: Ruby on Rails ActionMailer and Gmail

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Eec43f946d65be32e6b9fd2b3a1582a5?d=identicon&s=25 adam.groves (Guest)
on 2005-11-21 13:30
(Received via mailing list)
Has anyone successfully sent a mail from AM through google's smtp?
 in environment.rb I have:
  # Include your app's configuration here:
ActionMailer::Base.server_settings = {
:address => "smtp.gmail.com <http://smtp.gmail.com>",
:port => 587,
:domain => 'www.mydomain.com <http://www.mydomain.com>',
:user_name => "<a
href='mymail@googlemail.com'>mymail@googlemail.com</a>",
:password => "password",
:authentication => :login
}
 I ask because I don't have access to a mail server, have a gmail
account
though and want to try out action mailer.
05d703f649ef1d07e78d7b479fb4c4ac?d=identicon&s=25 james.adam (Guest)
on 2005-11-21 13:38
(Received via mailing list)
Why is your :user_name formatted with HTML?

- james
Acd864a79c581fd5f7203ec993896c10?d=identicon&s=25 Deepak Surti (Guest)
on 2005-11-23 08:39
Hi,

Try this. Install a mail server on your machine.

on my winxp based machine i installed the following mail server:

http://www.youngzsoft.net/cmailserver/email-server...

create an account : test@yourdomain.com with secret password

then use following settings

:smpt

&&&& [see ur cmail server tools -> configuration]

address - localhost
port - 25
domain - yourdomain.com
authenticate - login
user_name - test
password - secret

This works. Hope this helps.
11af91e6fb1d80fcb90985158a154809?d=identicon&s=25 André Medeiros (andremedeiros)
on 2005-11-23 16:44
AFAIK, you can't use GMail's SMTP with AM, because it communicates
through the SSL layer (see GMail's help on how to setup thunderbird, for
instance).
B4af929375cd6f302a770a88a7655d09?d=identicon&s=25 André Camargo (andre)
on 2005-11-23 17:54
andremedeiros wrote:
> AFAIK, you can't use GMail's SMTP with AM, because it communicates
> through the SSL layer (see GMail's help on how to setup thunderbird, for
> instance).

yeah, André Medeiros is right... gmail's smtp server only accepts TLS
connections...

let's extend AM to make this happen?

any rails guru around to help on this? :-) hehe
A52b0e1c5d982f2512a03c5dbfd033d6?d=identicon&s=25 rasputnik (Guest)
on 2005-11-24 13:28
(Received via mailing list)
Why not setup a local MTA to talk to GMail for you?

My little brother wrote a howto if you're on *NIX:

    http://typo.submonkey.net/articles/2005/09/09/use-...


On 23/11/05, André Camargo <andreribeirocamargo@gmail.com> wrote:
> any rails guru around to help on this? :-) hehe
>
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Rails mailing list
> Rails@lists.rubyonrails.org
> http://lists.rubyonrails.org/mailman/listinfo/rails
>


--
Rasputin :: Jack of All Trades - Master of Nuns
http://number9.hellooperator.net/
Bb4bdf2b184027bc38d4fb529770cde5?d=identicon&s=25 Wes Gamble (weyus)
on 2007-01-29 07:07
Deepak Surti wrote:
> then use following settings
>
> :smpt
>
> &&&& [see ur cmail server tools -> configuration]
>
> address - localhost
> port - 25
> domain - yourdomain.com
> authenticate - login
> user_name - test
> password - secret
>
> This works. Hope this helps.

I did this and added the following to my environment.rb file, _inside_
the Rails::Initializer.run do |config| block:

#Mail Server Settings
config.action_mailer.server_settings = {:address => 'localhost',
                                        :port => 25,
                                        :domain => 'mydomain.com',
                                        :user_name => 'user',
                                        :password => 'password',
                                        :authentication => 'plain'}

Would you expect this to work?

Does this section need to be set up with
ActionMailer::Base.server_settings = {...}?

My development log seems to think that the mail is being sent but it
isn't going through.

Thanks,
Wes
153107d9ef8352ea7f787d2090d81666?d=identicon&s=25 marston@sugarstats.com (Guest)
on 2007-01-29 10:35
(Received via mailing list)
Interesting, please let me know if this works for you.  For me I
haven't had such luck, I'm using Google Domain Apps for my domain.  At
the moment I just have Rails talk to the local postfix install which
then simply smartrelay's over SSL to smtp.gmail.com.  There seems to
be issues configuring it from within the rails app due to gmail's
security requirements for logins?  Though I'd love to get this working
straight from my rails app.

On Jan 29, 7:07 am, Wes Gamble <rails-mailing-l...@andreas-s.net>
8f59dd1756c99858d05f25217b2ac3ff?d=identicon&s=25 Carl Woodward (Guest)
on 2007-01-29 10:38
(Received via mailing list)
Hey mate,

If your development is on a mac, go to your terminal and run mail. If
mail isnt getting sent out it will tell you why in there.

Cheers,
Carl.

On 1/29/07, marston@sugarstats.com <marston@sugarstats.com> wrote:
> wrote:
> > > authenticate - login
> >                                         :user_name => 'user',
> >
> > Thanks,
> > Wes
> >
> > --
> > Posted viahttp://www.ruby-forum.com/.
>
>
> >
>


--
Carl Woodward
0412218979
cjwoodward@gmail.com
This topic is locked and can not be replied to.