Forum: Ruby RMagick prerequisite changes

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
3afd3e5e05dc9310c89aa5762cc8dd1d?d=identicon&s=25 Timothy Hunter (Guest)
on 2007-01-26 00:46
(Received via mailing list)
Just a heads-up about the next major RMagick release:

The current release of RMagick, 1.15.0, supports ImageMagick >= 6.0.0,
Ruby >= 1.6 (RVG requires Ruby 1.8), and all releases of GraphicsMagick.
Testing RMagick with so many possible configurations has become
impractical. Therefore the next major release of RMagick will be 2.0.0.
RMagick 2 will require Ruby 1.8 and a recent version of ImageMagick,
probably 6.3.0 or later. (The current version is 6.3.2.)

Regrettably RMagick 2 will not include support for GraphicsMagick.
GraphicsMagick-only methods and constants (of which there are _very_
few) will not be available. This breaks backward compatibility therefore
I'm bumping the major version number. I believe the impact will be
minimal and that 99.99% of all RMagick scripts will continue to run
unchanged. I'd very much like to continue supporting GraphicsMagick
(especially since GraphicsMagick's maintainer, Bob Friesenhahn, has been
a friend to RMagick since 2002) but its development has slowed and the
two APIs have drifted apart considerably.

I don't have a schedule for RMagick 2.0.0 but I'm guessing that it will
be two or three months from now.

I'll keep RMagick 1.15.0 available for as long as necessary and fix bugs
for a reasonable period of time.

I hope that by updating RMagick's prerequisites I can streamline the
installation process and put RMagick in a better position for Ruby 1.9.
Please let me know if you have any questions or concerns about this
This topic is locked and can not be replied to.