Forum: Ruby Acts_as_taggable (the gem) woes (solved)

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
75da740d43c5780539214f24ce1148a6?d=identicon&s=25 Jean Helou (Guest)
on 2007-01-19 23:20
(Received via mailing list)

I had to battle quite a bit to find how to load acts_as_taggable
without using require_gem.

where I previously had

require_gem 'acts_as_taggable'

I tried replacing by the obvious

gem 'acts_as_taggable'
require 'acts_as_taggable'

this failed miserably. The trick is that the acts_as_taggable module
is in a file named taggable in the lib directory of the gem. so to get
it to work you have to replace the require with :

require 'taggable'

Now you can use acts_as_taggable without any warnings. While this may
seem obvious to many here, I hope it prevents the waste of a couple
hours to a few other newbies thus my post.

Back to tracking every last of these deprecation warnings now that my
test pass again :)

75da740d43c5780539214f24ce1148a6?d=identicon&s=25 Jean Helou (Guest)
on 2007-01-19 23:47
(Received via mailing list)
I posted to the wrong list.
Sorry about that
This topic is locked and can not be replied to.