Forum: Rails France rails 1.2.1

5e79fd967217ff929f644d85a590498d?d=identicon&s=25 guillaume belleguic (Guest)
on 2007-01-19 16:30
(Received via mailing list)
Bonjour,

Mon appli en dev fonctionnait très bien avec la version 1.2 RC2 mais, ce
matin, n'écoutant que mon courage :-), j'installe rails 1.2.1 (pas en
"plugins") et la c'est le drame, ca ne marche plus du tout :

"Expected C:/Documents and
Settings/guillaume/user/RailsERP/config/../app/controllers/invoice_controller.rb
to define InvoiceController

c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:250:in
`load_missing_constant'

c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:453:in
`const_missing'

c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:465:in
`const_missing'

c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/inflector.rb:251:in
`constantize'

c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/core_ext/string/inflections.rb:148:in
`constantize'

c:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.13.1/lib/action_controller/routing.rb:1258:in
`recognize'

c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:40:in
`dispatch'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel/rails.rb:73:in
`process'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:551:in
`process_client'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:550:in
`each'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:550:in
`process_client'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:636:in
`run'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:636:in
`initialize'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:636:in
`new'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:636:in
`run'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:625:in
`initialize'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:625:in
`new'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:625:in
`run'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:956:in
`run'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:955:in
`each'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:955:in
`run'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/bin/mongrel_rails:127:in
`run'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel/command.rb:199:in
`run'

c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/bin/mongrel_rails:235

C:\ruby\bin\mongrel_rails:18:in `load'

C:\ruby\bin\mongrel_rails:18

-e:3:in `load'

-e:3"

Si vous avez déjà installé la version 1.2.1 et ca marche chez vous ?

--
--------------------------------

Guillaume BELLEGUIC
LES ACCORDEURS DE RESEAUX
e-ngoma  / Ker data
4, cours Kennedy
35000 Rennes

guillaume.belleguic@e-ngoma.net
http://www.e-ngoma.net

tèl : +33 (0)299 33 87 48
fax : +33 (0)299 33 97 31

RCS Rennes 487 799 892

--------------------------------
13ea48f056b19349027d2f4a6921a46a?d=identicon&s=25 Jean-François (Guest)
on 2007-01-19 16:31
(Received via mailing list)
Guillaume :
> Mon appli en dev fonctionnait très bien avec la version 1.2 RC2 mais,
> ce matin, n'écoutant que mon courage :-), j'installe rails 1.2.1 (pas en
> "plugins")

autant que je sache, c'est impossible de l'installer en plugin :)

> et la c'est le drame, ca ne marche plus du tout :
>
> "Expected C:/Documents and
> Settings/guillaume/user/RailsERP/config/../app/controllers/invoice_controller.rb
> to define InvoiceController

Faudrait voir à quoi ressemble invoice_controller.rb

   -- Jean-François.
C211e4b403330c86c56db30357a2b64c?d=identicon&s=25 Guillaume Betous (Guest)
on 2007-09-25 22:37
(Received via mailing list)
> rake rails:freeze:edge TAG=rel_1-2-1

merci à tous les 2 (-:

gUI

--
Pour la santé de votre ordinateur, préférez les logiciels libres !

Guillaume Betous : (05 61) 19 40 65 / bureau 602N
9df94e5f6379a9163e07801c23414e13?d=identicon&s=25 guillaume belleguic (Guest)
on 2007-09-25 22:38
(Received via mailing list)
Je me suis mal exprimé, pas en plugins, mais dans /vendor/rails...

Jean-François a écrit :
>> Settings/guillaume/user/RailsERP/config/../app/controllers/invoice_controller.rb
> Railsfrance mailing list
> Railsfrance@rubyonrails.fr
> http://lists.rubyonrails.fr/mailman/listinfo/railsfrance
>
> ------------------------------------------------------------------------
>
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.5.432 / Virus Database: 268.17.0/639 - Release Date: 18/01/2007 18:47
>


--
--------------------------------

Guillaume BELLEGUIC
LES ACCORDEURS DE RESEAUX
e-ngoma  / Ker data
4, cours Kennedy
35000 Rennes

guillaume.belleguic@lesaccordeurs.com
http://www.e-ngoma.net

tèl : +33 (0)299 33 87 48
fax : +33 (0)299 33 97 31

RCS Rennes 487 799 892

--------------------------------
Bae3272fbe1313479c4c9c375d75c462?d=identicon&s=25 jmb (Guest)
on 2007-09-25 22:39
(Received via mailing list)
>> Je me suis mal exprimé, pas en plugins, mais dans /vendor/rails...

>je connais pas ce mécanisme.

>ça signifie qu'on se fait suivre dans l'appli la bonne version de Rails ?
>comment fait-on pour cela ?


-- > rake rails:freeze:gems
C211e4b403330c86c56db30357a2b64c?d=identicon&s=25 Guillaume Betous (Guest)
on 2007-09-25 22:43
(Received via mailing list)
> Je me suis mal exprimé, pas en plugins, mais dans /vendor/rails...

je connais pas ce mécanisme.

ça signifie qu'on se fait suivre dans l'appli la bonne version de Rails ?
comment fait-on pour cela ?

gUI

--
Pour la santé de votre ordinateur, préférez les logiciels libres !

Guillaume Betous : (05 61) 19 40 65 / bureau 602N
13ea48f056b19349027d2f4a6921a46a?d=identicon&s=25 Jean-François (Guest)
on 2007-09-25 22:44
(Received via mailing list)
Guillaume :
> > Je me suis mal exprimé, pas en plugins, mais dans /vendor/rails...
>
> je connais pas ce mécanisme.
>
> ça signifie qu'on se fait suivre dans l'appli la bonne version de Rails ?
> comment fait-on pour cela ?

rake rails:freeze:edge TAG=rel_1-2-1

   -- Jean-François.
This topic is locked and can not be replied to.