Forum: Ruby on Rails Trouble reading attachments on OS X

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
71f2b97ba470aac5d47640ae9fe7c617?d=identicon&s=25 Christoph Hilty (huli)
on 2007-01-18 15:32
I am sending e-mails with actionmailer and I have the following code to
send an e-mail with an attachment:

      @headers['Content-Type'] = "text/plain; charset=utf-8;
format=flowed"
      @body["application_id"] = app_id
      unless (file.blank? || file.kind_of?(StringIO))
           attachment :content_type => "multipart/mixed",
              :body => tempfile.read,
              :filename => tempfile.original_filename,
              :charset => "utf-8"
      end

That works fine as long as I am reading the e-mails (with the
attachments) on a windows operating system. Strangely enough it does not
work on OS X. On Tiger for example this does not work. An image (jpg)
file works but a pdf file will not be readable. (Strange characters
only) I can read the e-mails on Mac but I cannot open the attachments.
The server is a debian sarge.

Any ideas?

Thanks a lot.
70ca58d0e0e0eabbdb74d177417d09d7?d=identicon&s=25 augustlilleaas@gmail.com (Guest)
on 2007-01-18 16:39
(Received via mailing list)
Sounds kinda weird that this is platform related like that. Does it
apply to all (or at least more than one) e-mail clients on OS X?

On Jan 18, 3:32 pm, Chris Huli <rails-mailing-l...@andreas-s.net>
71f2b97ba470aac5d47640ae9fe7c617?d=identicon&s=25 Christoph Hilty (huli)
on 2007-01-18 16:56

I am not sure about that but at least it happened on every e-mail client
it was tested. (So far on 2 Installations) Don't know which e-mail
client those guys used - but I can get this information I think.
This topic is locked and can not be replied to.