Forum: Ruby IDE

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
IDE
Cc07c1f1c709ae4419d52ba19d87f5d0?d=identicon&s=25 Adrian Roskrow (madsurfer)
on 2007-01-12 17:59
Hi

I was wishing to get an IDE to use with ruby, after trying eclipse
(which appears to be good but complicated) I thought about using
Mondrian. After downloading it for my Ubuntu I went ahead to try install
it. After many attempts to do this (building the required libs etc) I
have come up against a problem that I as of yet can not seem to solve

adrianr@geko80:~$ irb
irb(main):001:0> require 'fox16'
LoadError: libFOX-1.6.so.0: cannot open shared object file: No such file
or directory - /usr/local/lib/site_ruby/1.8/i486-linux/fox16.so
        from /usr/local/lib/site_ruby/1.8/i486-linux/fox16.so
        from (irb):1
irb(main):002:0>

Having checked whether this lib is there (it is),what should I do!! I
have run out of ideas on how to move further
0276239ca57aee241d4b41379587fa20?d=identicon&s=25 Lyle Johnson (Guest)
on 2007-01-19 16:31
(Received via mailing list)
On 1/12/07, Adrian Roskrow <adrian@hang10systems.co.uk> wrote:

> I was wishing to get an IDE to use with ruby, after trying eclipse
> (which appears to be good but complicated) I thought about using
> Mondrian. After downloading it for my Ubuntu I went ahead to try install
> it. After many attempts to do this (building the required libs etc) I
> have come up against a problem that I as of yet can not seem to solve

<snip>

The answer to this question can be found in the FXRuby User's Guide.
7fa59f01218f241aeeeffd999346ed2e?d=identicon&s=25 Sachin Gadkar (Guest)
on 2007-01-19 16:31
(Received via mailing list)
I think vim is the best editor.. just set the syntax highlighting etc
for
ruby..

On 1/12/07, Adrian Roskrow <adrian@hang10systems.co.uk> wrote:
> irb(main):001:0> require 'fox16'
> Posted via http://www.ruby-forum.com/.
>
>


--
sachin.gadkar@gmail.com

URL : http://nichas143.tripod.com
This topic is locked and can not be replied to.