Forum: Ruby Rdoc: unknown tag: sections ?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
4fbf24e8c9b1d2b71955b1e3dbfbc688?d=identicon&s=25 Nate Murray (Guest)
on 2007-01-06 19:30
(Received via mailing list)
Hey All. Trying to use jamis buck's template for rdoc (
http://svn.jamisbuck.org/rdoc-templates/jamis.rb ).

Rdoc runs fine with no errors when I try to use the standard "html"
template. However if I use jamis.rb it says:

......
Generating HTML...
rake aborted!
unknown tag: sections
/usr/local/lib/ruby/site_ruby/1.8/rdoc/template.rb:183:in
`substitute_into'
/usr/local/lib/ruby/site_ruby/1.8/rdoc/template.rb:146:in
`write_html_on'
/usr/local/lib/ruby/site_ruby/1.8/rdoc/generators/html_generator.rb:763:in
`write_on'
/usr/local/lib/ruby/site_ruby/1.8/rdoc/generators/html_generator.rb:1170:in
`gen_into'
/usr/local/lib/ruby/site_ruby/1.8/rdoc/generators/html_generator.rb:1170:in
`gen_into'
... # more

I've poked around at the code for a while and wasn't able to figure it
out. Has anyone encountered this or have any ideas on how to fix it?
4fbf24e8c9b1d2b71955b1e3dbfbc688?d=identicon&s=25 Nate Murray (Guest)
on 2007-01-06 19:30
(Received via mailing list)
I figured out my problem. I had an older version of rdoc. Once I
upgraded to ruby 1.8.5 this issue was resolved.
This topic is locked and can not be replied to.