Forum: Rails Engines Migrating to 1.2

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
James Nelson (Guest)
on 2007-01-06 19:30
(Received via mailing list)
Hi there

I've been trying to move my rbac plugin over to the new rails. So far
worked pretty well - all my models work from the console, and after
configuration over to class variables that all still works. The biggest
problem is that all my old routes don't work. I've got a user controller
example, with a login action. I used to go to /user/login and the login
action would be run (as you'd expect) - this worked with the default
routes. However, now /user/login generates a routing error telling me it
doesn't exist. Is there anything i'm supposed to do with the new
James Adam (Guest)
on 2007-01-19 16:30
(Received via mailing list)
Hi James,

Well spotted - this was a result of the fact that plugins can be
'enginized' as part of the plugin loading process now, which occurs
before routing is started up. Previously this wasn't an issue because
Engines.start was called after routing was configured. There's a fix
in the release branch; see
for more details.

- James
This topic is locked and can not be replied to.