Forum: Rails I18n globalize_languages doesn't exist error

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
3504745159d79c585e4f7df8df76aa10?d=identicon&s=25 Ingo Weiss (ingoweiss)
on 2007-01-04 20:23

I am getting started with globalize and so far it works ok. At some
point I had to do 'rake globalize:teardown' to reset the database (I had
the problem where all user translations were stored as 'built_in' as
described on the 'example application' pag). Now when I run 'rake
globalize:setup' again I got the following error:

rake aborted!
Mysql::Error: #42S02Table 'globalize_development.globalize_languages'
doesn't exist: SHOW FIELDS FROM globalize_languages

and I thought: of course it doesn't exist - I just deleted it! ;-)

I am actually getting the same error now when trying to run any

Thanks for any hint how to fix this!

E3eace5bb863c17ce1bb1c8bdd94a06c?d=identicon&s=25 Charles Brian Quinn (Guest)
on 2007-01-06 19:30
(Received via mailing list)
The problem occurs when you require Globalize and then do anything
with Locale.set in your rails environment.  Whenever rake tasks run,
it loads the entire environment.

I ended up using the following code (in environment.rb) so that I
could teardown and setup and use capistrano to manage my app:

# require globalize plugin and set default locale to us english
include Globalize

  Locale.set_base_language AppConstants::DEFAULT_LOCALE
  Locale.set AppConstants::DEFAULT_LOCALE
  puts "** Warning: Install Globalize plugin first and setup using
rake globalize:setup"

Hope this helps,

Charles Brian Quinn
highgroove studios:
slingshot hosting:

Ruby on Rails Bootcamp at the Big Nerd Ranch
Intensive Ruby on Rails Training:
This topic is locked and can not be replied to.