Forum: Rails I18n randomly keys translation missing in production

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
ruby_noob (Guest)
on 2011-01-15 14:13
(Received via mailing list)
Hello everyone
i use
rails (= 3.0.3)
i18n (0.5.0)

in development all fine
in production i get  translation missing
i found temp solution to change

config.cache_classes = false

in production but i wouldn't like turn off caching...

my locale is :ru

ls -l config/locales/
итого 24
-rw-rw-r-- 1 dnevnik dnevnik 1850 Янв 15 00:18 devise.en.yml
-rw-rw-r-- 1 dnevnik dnevnik 2717 Янв 15 00:18
-rw-rw-r-- 1 dnevnik dnevnik  305 Янв 15 00:18 en.yml
-rw-rw-r-- 1 dnevnik dnevnik  678 Янв 15 00:18
-rw-rw-r-- 1 dnevnik dnevnik 6529 Янв 15 00:18 ru.yml

grep i18n config/application.rb

    config.i18n.load_path += Dir[Rails.root.join('my', 'locales', '*.
    config.i18n.default_locale = :ru

Any suggestions?
Diogo Andre Assumpcao (Guest)
on 2011-02-24 14:53
(Received via mailing list)
Exactly the same thing is happening with me. Turning off cache also
the problem.

I tried clearing the cache using Rails.cache.clear withing a
but did't produce any results.

Still no clue on what's causing it.

Any ideas?


Diogo Andre Assumpcao (Guest)
on 2011-02-24 15:03
(Received via mailing list)
Looks like this guy got to the bottom of it.

His solution worked for me, altought I did make a small change on the
path, to include all my locales, just in case.


This topic is locked and can not be replied to.