Forum: Rails Engines Errors after upgrading engines, user_engine & login_engine

4606521b2f3140ea2c5ad0936333c9b1?d=identicon&s=25 Joerg Battermann (justbe)
on 2006-10-16 21:34
(Received via mailing list)
Hey there,

I just upgraded an old project of mine (rails 1.1.3 + hotfix and the
engines, user_engine & login_engine from back then (which was all
working perfectly)) to rails 1.1.6, and the following engines:

Engines plugin: 1.1.4
user_engine: unknown
login_engine: 1.0.2

.. svn externals is:
Engines plugin: 1.1.4
user_engine: unknown
login_engine: 1.0.2


... I ran an svn up afterwards (dunno why rake engines:info returns
login_engine: 1.0.2 and unkown for user_engine though), and started
up a server. I can log in, list users, but when checking their roles,
rails throws this error:

Mysql::Error: Table '<dbname>.users_roles' doesn't exist: SHOW FIELDS
FROM users_roles

... and I wonder why. the rake db:migrate:engines-command changed the
table:

(in /Users/joerg/Development/finecoleads_machine)
Migrating engine 'user_engine'
== RenameUsersRolesTableToRolesUsersOrEquivalent: migrating
===================
-- execute("SELECT * FROM users_roles")
    -> 0.0003s
renaming table
-- rename_table("users_roles", "roles_users")
    -> 0.0275s
== RenameUsersRolesTableToRolesUsersOrEquivalent: migrated (0.0282s)
==========


... but why does it still try to look at users_roles?

Any ideas/suggestions what I am doing wrong/or miss?


The environment.rb part looks like this:

module LoginEngine
   config :salt, "somesalt"
   config :use_email_notification, false
   config :admin_email, "jb@justbe.com"
   config :app_name, 'Some name'
   config :app_url, 'http://localhost:3000'
   config :changeable_fields, [ 'firstname', 'lastname', 'anrede',
'firma', 'strasse', 'plz', 'ort', 'telefon', 'fax',
'plz_zustaendigkeit_von', 'plz_zustaendigkeit_bis']
end

# see http://api.rails-engines.org/user_engine/
module UserEngine
    config :admin_login, "admin"
    config :admin_email, "jb@justbe.com"
    config :admin_password, "abc"
end

Engines.start :login, :user
UserEngine.check_system_roles


:-(


Best Regards / Mit freundlichen Gruessen,
Joerg Battermann
--
Freelancer, Entrepreneur,
Open Source Advocate

E-Mail: jb@justbe.com
Cell: +49 179 7861273
Skype: joerg.battermann
http://justbe.com || http://blog.justbe.com
This topic is locked and can not be replied to.