Forum: Ruby-Forum.com Rake Problem w/ Postgresql 7.x on Debian Sarge

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
D23f436b8e718e80f447712cdac67083?d=identicon&s=25 Amr Malik (amrmalik)
on 2006-08-23 14:47
Hey folks,

I'm having a heck of a time trying to get Rails to talk to the
Postgresql installed on my debian box.

Here is the setup on my LayeredTech dedicated box:

Debian Sarge
Postgresql 7.x
Ruby 1.8.2
Rails 1.1.6
rForum latest (933) -----> this is where I'm getting the problem
postgres-pr gem (v 0.4.0)
postgres gem (had compile probs so un-installed it)


here is what I have already done:

== created a forum database in PostgreSQL
== create a user for it with password
== installed postgres and postgres-pr gems (got a few errors in the
postgres
   install, but it claims the gem was "installed" but I de-activated it)

===>>>> tried rake db:migrate which craps out with the following error:

rake aborted!
FATAL   C28000  MIDENT authentication failed for user "tingforum"
Fauth.c L395    Rauth_failed

the full trace is located here: http://pastebin.com/773941


I keep getting authentication errors regardless of which postgres gem I
use. I tried the pure ruby one just to test, and got the above error.

NOTE: I did fix the pg_hba.conf file for Postgres to accept cleartext or
MD5 hashes and it seems to work fine from the commandline (i can connect
with the db via psql) The above test was run with 'password' as the
method ie NO IDENT/SAMEUSER stuff in the conf file.

I'm at a loss, maybe someone can give a pointer?

thanks,

Amr
D23f436b8e718e80f447712cdac67083?d=identicon&s=25 Amr Malik (amrmalik)
on 2006-08-24 01:03
I installed postgresql 8.1 and it seems to be moving forward now.
This topic is locked and can not be replied to.