Forum: Ruby-Forum.com Forum not found

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
38007b98b4915b915e1be2480c886f2f?d=identicon&s=25 Stian H (Guest)
on 2006-07-12 20:58
I just now tried upgrading from 0.2 to a recently grabbed SVN version of
RForum on my testing server, and all worked fine. Nothing in my
procedure changed when applying the same upgrade on my actual board,
however I am getting the message "Forum not found" instead of my board
:(

Any suggestions?
38007b98b4915b915e1be2480c886f2f?d=identicon&s=25 Stian H (Guest)
on 2006-07-12 21:02
Actually, it's all there I discover, but just the index (/, and /forum)
is giving this error: http://rubyonrails.no compared to
http://rubyonrails.no/forum/5
38007b98b4915b915e1be2480c886f2f?d=identicon&s=25 Stian H (Guest)
on 2006-07-12 23:28
Fc559d53343b6d7fae00a04fcf0777dc?d=identicon&s=25 Andrew Hodgkinson (pond)
on 2006-07-13 12:49
Stian H wrote:

> Oh, http://rubyonrails.no/forum/list works like it used to do on
> http://rubyonrails.no/

Well right now I'm just getting an application error either way, but
when it's running, it sounds like there's just a missing or incorrect
entry in config/routes.rb - check the '' and 'forum' mappings are set
up. Something like this should do the trick:

  map.connect '', :controller => 'forum', :action => 'list'
  map.connect 'forum', :controller => 'forum', :action => 'list'

You may need to be a bit more explicit with leading or trailing "/"
characters in the first parameter - not too sure.
38007b98b4915b915e1be2480c886f2f?d=identicon&s=25 Stian H (Guest)
on 2006-07-13 14:34
That worked great, I had to use '/' in the first route, the other one
wasn't there, so I added it. Thanks :)
Fc559d53343b6d7fae00a04fcf0777dc?d=identicon&s=25 Andrew Hodgkinson (pond)
on 2006-07-13 19:30
Stian H wrote:

> That worked great, I had to use '/' in the first route, the other one
> wasn't there, so I added it. Thanks :)

Good stuff. For what it's worth, it all seems to be working from where
I'm sitting. Looks like you're up and running.
This topic is locked and can not be replied to.