Forum: Ruby on Rails gem install rails --include-dependencies fails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Olivier Kaloudoff (Guest)
on 2006-06-13 14:27
(Received via mailing list)
Hello,

    I'm very new to ruby, and don't understand the following error,
while trying to
auto-install rubyonrails via gem;


[root@svrlnweb02 root]# gem install rails --include-dependencies
/opt/rubygems/0.8.11/bin/gem:3:in `require': no such file to load --
rubygems (LoadError)
        from /opt/rubygems/0.8.11/bin/gem:3

[root@svrlnweb02 root]# type gem
gem is hashed (/opt/rubygems/0.8.11/bin/gem)

[root@svrlnweb02 root]# ls /opt/rubygems/0.8.11/bin/
gem  gem_mirror  gem_server  gemwhich  generate_yaml_index.rb
update_rubygems

[root@svrlnweb02 root]# type ruby
ruby is hashed (/usr/local/bin/ruby)


Can you advise ?


Best Regards,


--
Olivier Kaloudoff
Linux / Solaris Support / IT Design Nice

Texas  Instruments France
  821  av Jack Kilby
06270  VILLENEUVE LOUBET
This topic is locked and can not be replied to.