Forum: Rails Engines Override User controller works sometimes

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
48ae1944e6a82dffa18694663e72c931?d=identicon&s=25 Pedro Visintin (peterpunk)
on 2006-06-12 01:37
I dont know if I did the right things.

Im using Login and User Engine

I created a user_controller on my app/controllers with all actions
included.
At my local win32 machine works fine, but in my production server the
controller at the first request uses the rigth user controller on
app/controllers but when I post to signup or logout the flash[:notice]
comes from the login_engine/app/user_controller.rb seems that my
controller was ignored.

Any Idea?

thanks

P

Pedro Visintin
http://blogs.onrails.com.ar
65342ebdc372fe2d94ac6c9d8bb801a2?d=identicon&s=25 Marek Stanczyk (Guest)
on 2006-07-10 15:54
(Received via mailing list)
Pedro Visintin <pedro.visintin@...> writes:

> I created a user_controller on my app/controllers with all actions
> included.
> At my local win32 machine works fine, but in my production server the
> controller at the first request uses the rigth user controller on
> app/controllers but when I post to signup or logout the flash[:notice]
> comes from the login_engine/app/user_controller.rb seems that my
> controller was ignored.

I have the same problem, and can't find anything about this.
Do you have a solution yet?

Marek
48ae1944e6a82dffa18694663e72c931?d=identicon&s=25 Pedro Visintin (peterpunk)
on 2006-07-10 16:29
Marek Stanczyk wrote:
> Pedro Visintin <pedro.visintin@...> writes:
>
>> I created a user_controller on my app/controllers with all actions
>> included.
>> At my local win32 machine works fine, but in my production server the
>> controller at the first request uses the rigth user controller on
>> app/controllers but when I post to signup or logout the flash[:notice]
>> comes from the login_engine/app/user_controller.rb seems that my
>> controller was ignored.
>
> I have the same problem, and can't find anything about this.
> Do you have a solution yet?
>
> Marek

No solution yet,

I will try with the last Engines plugin 1.1.3 release.

P
This topic is locked and can not be replied to.