Forum: Ruby on Rails Shopify_App : New to rails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
D4153455281b080b976089da23c42f31?d=identicon&s=25 Gautam Sharma (gautamiwiz)
on 2017-05-02 21:51
Hello,
I am new to rails and I am unable to move forward. I listed the below
gem in my gemfile and after running "bundle install" i get the below
error.
Can someone tell me what to do, where to list or edit the correct
gems/dependencies

gem:
gem 'rails', '~> 5.0.2'
gem 'shopify_app'

===========================

Bundler could not find compatible versions for gem "activesupport":
  In Gemfile:
    shopify_app x64-mingw32 was resolved to 7.0.10, which depends on
      shopify_api (~> 4.2) x64-mingw32 was resolved to 4.2.0, which
depends on
        activeresource x64-mingw32 was resolved to 2.0.1, which depends
on
          activesupport (= 2.0.1) x64-mingw32

    rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
      activejob (= 5.0.2) x64-mingw32 was resolved to 5.0.2, which
depends on
        globalid (>= 0.3.6) x64-mingw32 was resolved to 0.4.0, which
depends on
          activesupport (>= 4.2.0) x64-mingw32

    rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
      activesupport (= 5.0.2) x64-mingw32

    rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
      activesupport (= 5.0.2) x64-mingw32

    rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
      activesupport (= 5.0.2) x64-mingw32

    rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
      activesupport (= 5.0.2) x64-mingw32

    rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
      activesupport (= 5.0.2) x64-mingw32

    rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
      activesupport (= 5.0.2) x64-mingw32

    rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
      activesupport (= 5.0.2) x64-mingw32

    rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
      actionpack (= 5.0.2) x64-mingw32 was resolved to 5.0.2, which
depends on
rails-dom-testing (~> 2.0) x64-mingw32 was resolved to 2.0.2, which
depends on
          activesupport (< 6.0, >= 4.2.0) x64-mingw32

    rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
sprockets-rails (>= 2.0.0) x64-mingw32 was resolved to 3.2.0, which
depends on
        activesupport (>= 4.0) x64-mingw32
Bundler could not find compatible versions for gem "rails":
  In Gemfile:
    rails (~> 5.0.2) x64-mingw32

    shopify_app x64-mingw32 was resolved to 0.1.0, which depends on
      rails (~> 3) x64-mingw32

D:\Ruby On Rails\firstRailsProject>rails s
Could not find gem 'shopify_app x64-mingw32' in any of the gem sources
listed in
 your Gemfile.
Run `bundle install` to install missing gems.
3e312ef6c09f4106f0f76b83d9dc7602?d=identicon&s=25 Johnny Stewart (j77j)
on 2017-05-05 10:40
Gautam Sharma wrote in post #1185854:
> Hello,
> I am new to rails and I am unable to move forward. I listed the below
> gem in my gemfile and after running "bundle install" i get the below
> error.
> Can someone tell me what to do, where to list or edit the correct
> gems/dependencies
>
> gem:
> gem 'rails', '~> 5.0.2'
> gem 'shopify_app'
>
> ===========================
>
> Bundler could not find compatible versions for gem "activesupport":
>   In Gemfile:
>     shopify_app x64-mingw32 was resolved to 7.0.10, which depends on
>       shopify_api (~> 4.2) x64-mingw32 was resolved to 4.2.0, which
> depends on
>         activeresource x64-mingw32 was resolved to 2.0.1, which depends
> on
>           activesupport (= 2.0.1) x64-mingw32
>
>     rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
>       activejob (= 5.0.2) x64-mingw32 was resolved to 5.0.2, which
> depends on
>         globalid (>= 0.3.6) x64-mingw32 was resolved to 0.4.0, which
> depends on
>           activesupport (>= 4.2.0) x64-mingw32
>
>     rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
>       activesupport (= 5.0.2) x64-mingw32
>
>     rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
>       activesupport (= 5.0.2) x64-mingw32
>
>     rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
>       activesupport (= 5.0.2) x64-mingw32
>
>     rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
>       activesupport (= 5.0.2) x64-mingw32
>
>     rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
>       activesupport (= 5.0.2) x64-mingw32
>
>     rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
>       activesupport (= 5.0.2) x64-mingw32
>
>     rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
>       activesupport (= 5.0.2) x64-mingw32
>
>     rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
>       actionpack (= 5.0.2) x64-mingw32 was resolved to 5.0.2, which
> depends on
> rails-dom-testing (~> 2.0) x64-mingw32 was resolved to 2.0.2, which
> depends on
>           activesupport (< 6.0, >= 4.2.0) x64-mingw32
>
>     rails (~> 5.0.2) x64-mingw32 was resolved to 5.0.2, which depends on
> sprockets-rails (>= 2.0.0) x64-mingw32 was resolved to 3.2.0, which
> depends on
>         activesupport (>= 4.0) x64-mingw32
> Bundler could not find compatible versions for gem "rails":
>   In Gemfile:
>     rails (~> 5.0.2) x64-mingw32
>
>     shopify_app x64-mingw32 was resolved to 0.1.0, which depends on
>       rails (~> 3) x64-mingw32
>
> D:\Ruby On Rails\firstRailsProject>rails s
> Could not find gem 'shopify_app x64-mingw32' in any of the gem sources
> listed in
>  your Gemfile.
> Run `bundle install` to install missing gems.

It doesn't look like you are using the correct version of the gems
required.

from the shopify_app github page:

Rails 5

shopify_app is compatible with Rails 5 but since the latest
ActiveResource release (4.1) is locked on Rails 4.x, you'll need to use
the unreleased master version:

gem 'shopify_app'
gem 'activeresource', github: 'rails/activeresource'

Johnny
This topic is locked and can not be replied to.