Forum: Ruby RVM Question

0f4e3c4b24c489a3c0c66e8dde07dac3?d=identicon&s=25 Karta Larchmont (kel)
on 2017-03-07 07:23
Perhaps this is a dumb question...

I am installing sciruby-full in Mint 18 (Ubuntu).
System Ruby is(was?) 2.3

A sciruby package wanted v2.4

I used RVM to install Ruby 2.4

It installed fine. BUT:

Ruby is now under /usr/local/rvm

Postgresql for Ruby is in Synaptic, but somehow if it tries to install
under gem, it acts as if it isnt there.

But calling require for it, and another, gsl -which could not compile-
yields TRUE.

V2.3 seems to have disappeared, but occasionally shows up in compiling
errors in /var/lib/gems .

But nothing of 2.3 is in the envirnment vars.


Has 2.3 been assimilated into 2.4, somehow?

With Perl its pretty much straightforward. Another version a a
completely separate directory structure, though in reality the older
version SITE modules could have its directories added to the new
version's path (at the end) with a potential for problems, but few in
practice.

I've read alot of stuff on Ruby, but nothing has addressed this aspect.
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.