Forum: Ruby pgsql on rails issue

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
A9cf38a5a27c8b738866c03085d39951?d=identicon&s=25 Ninja Panther (ninjapanther)
on 2016-11-04 05:14
I am unable to deploy pgsql
C:\wom\website>rails  _4.2.0_ s
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/pg-0.17.1-x64-mingw32/lib/pg.rb:10:in
`require': cannot load such file -- 2.3/pg_ext (LoadError)
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/pg-0.17.1-x64-mingw32/lib/pg.rb:10:in
`rescue in <top (required)>'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/pg-0.17.1-x64-mingw32/lib/pg.rb:3:in
`<top (required)>'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:91:in
`require'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:91:in
`block (2 levels) in require'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:86:in
`each'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:86:in
`block in require'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:75:in
`each'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:75:in
`require'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bundler-1.13.6/lib/bundler.rb:106:in
`require'
        from C:/wom/website/config/application.rb:7:in `<top
(required)>'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:78:in
`require'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:78:in
`block in server'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:75:in
`tap'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:75:in
`server'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:39:in
`run_command!'
        from
C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-4.2.6/lib/rails/commands.rb:17:in
`<top (required)>'
        from bin/rails:4:in `require'
        from bin/rails:4:in `<main>'

C:\wom\website>
This topic is locked and can not be replied to.