Forum: Ruby Installing VisualRuby on MacOS

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
E12965e29fca8752eb65a844836bca60?d=identicon&s=25 Jeremy Bush (jjaj823)
on 2016-09-29 22:40
Hi everyone!

I am new to Ruby and Mac and am attempting to install VisualRuby on my
macOS Sierra machine.  I ran the steps located at the VisualRuby website
and everything seems to be installing correctly, however when I run it,
I get a quick splash screen and then the program quits.  I get the
following output from the terminal:


/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/gobject-introspection-3.0.9/lib/gobject-introspection/loader.rb:37:in
`require': Typelib file for namespace 'GtkSource' (any version) not
found (GLib::Error)
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/gobject-introspection-3.0.9/lib/gobject-introspection/loader.rb:37:in
`load'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/gtksourceview3-3.0.9/lib/gtksourceview3.rb:52:in
`init'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/gtksourceview3-3.0.9/lib/gtksourceview3.rb:37:in
`const_missing'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/visualruby-3.0.23/src/editor/VR_Document.rb:2:in
`<top (required)>'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/require_all-1.3.3/lib/require_all.rb:108:in
`require'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/require_all-1.3.3/lib/require_all.rb:108:in
`block in require_all'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/require_all-1.3.3/lib/require_all.rb:106:in
`each'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/require_all-1.3.3/lib/require_all.rb:106:in
`require_all'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/require_all-1.3.3/lib/require_all.rb:153:in
`block in require_rel'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/require_all-1.3.3/lib/require_all.rb:152:in
`each'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/require_all-1.3.3/lib/require_all.rb:152:in
`require_rel'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/visualruby-3.0.23/vr:18:in
`load_everything'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/visualruby-3.0.23/vr:41:in
`block in <top (required)>'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/gobject-introspection-3.0.9/lib/gobject-introspection/loader.rb:114:in
`invoke'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/gobject-introspection-3.0.9/lib/gobject-introspection/loader.rb:114:in
`block in define_singleton_method'
  from
/Users/jeremy/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/visualruby-3.0.23/vr:44:in
`<top (required)>'
  from /Users/jeremy/.rbenv/versions/2.3.1/bin/vr:22:in `load'
  from /Users/jeremy/.rbenv/versions/2.3.1/bin/vr:22:in `<main>'

Any assistsance greatly appreciated!
This topic is locked and can not be replied to.